Performance Problems (SNES, N64, PSX)

Home Forums RetroPie Project Everything else related to the RetroPie Project Performance Problems (SNES, N64, PSX)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 7 replies, has 6 voices, and was last updated by Profile photo of neighbourhoodnerd neighbourhoodnerd 2 years, 2 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #88489
    Profile photo of
    Anonymous

    Hi,
    I use the latest version of RetroPi. But the emulators has some performance problems – but not with all games, only with some ROMs.
    Example SNES (with and without overclocking): Lufia, Super Mario RPG, Super Mario World, Mario Kart, Donkey Kong works fine. If I try Kirbys Fun Pak, Tetris or F-Zero the game has lags that’s not very playful.
    Example N64: Without overclocking you can’t play anything. With maximum overclock, Mario64 has lags, Pokemon Stadium starts but if you start a game (“new game” in the game) I see only a black screen. Same with Mario Kart 64.
    Example PSX: Crash Badincoot runs with lags without overclocking. It runs well with maximum overclocking. Tomb Raider starts with and without overclocking, but if I start the game (“new game” in the game) I only see a black screen.

    I’m using an Pi Version B+. Tried both – install on a Raspbian system and used the full card image. Problems are the same.
    And I don’t understand it, the power of the RasPi should be enough for SNES games. And why are some working and some not?

    I’m glad to get some ideas to fix this problems. Thank you

    Greetings
    FluGar

    #88500
    Profile photo of gizmo98
    gizmo98
    Participant

    You should use medium OC (900MHz). RetroPie >= 2.4 uses stock clocks. RetroPie <=2.3 used medium OC.

    #88501
    Profile photo of noobian
    noobian
    Participant

    me too..having problems with Kirby,Starfox and Doom on snes…theyre just too sloowwww….also Stunt Race FX gives a black screen checking for mode 7 or somethin???..i havent yet overclocked my b+ and checked..

    you know sometimes these problems occur with emulators…try a different one and the same game might run perfectly smooth.

    Also i guess the only fix for n64 and PSX is to buy the new raspberry pi 2 quad core..the videos on youtube shows smooth gameplay..

    #88513
    Profile photo of fallersaur
    fallersaur
    Participant

    This is essentially why I just got my RPi 2.

    The problem with some SNES games like Starfox, Stunt Race FX, etc…is that those games used an FX chip. Unfortunately, those games do not run well on the RPi B+, but I have seen some reports that FX games work perfectly with the RPi 2.

    Same with most N64/PSX games. Although I have seen some users manage to get N64/PSX games “mostly” playable, the best bet is to go for the RPi 2. Again, I have already seen some people report much better performance with both of these.

    Either way…just like gizmo98 said, I would recommend overclocking to at least medium to get better performance out of the RPi B+.

    also Stunt Race FX gives a black screen checking for mode 7

    I think that is just a modded rom. I’ve seen the occasional “Mode 7” intro screen with certain roms and have seen forum posts where sometimes the modded intro screens can prevent some roms from running at all with the libretro emulators.

    #88529
    Profile photo of GameRockeR
    GameRockeR
    Participant

    Stunt Race FX works with CATSFC libretro core but is completely unplayable, slow and glitchy.

    #88531
    Profile photo of fallersaur
    fallersaur
    Participant

    Just in case you want to spend $35 on another Pi, I just tested the following SNES/N64 games on the RPi2:

    Note: I am using RetroPie 2.6.0 and am using the RPi2 overclock setting from within raspi-config. I also placed my roms in n64-mupen64plus to use that emulator instead (thanks floob for your videos on youtube!)

    Starfox – Runs really well now. I played it for like 30 seconds and saw no issues using this setup.

    Stunt Race FX – I will have to check if my rom is corrupt or if this game just doesn’t emulate well. I was able to do everything in the menu, but after entering a game it gave an error that it was unable to create my car. It failed to render any car/track upon entering a race.

    Super Mario 64 – Works very smooth. I only ran around for a bit, but it runs smooth and sounds great.

    Super Mario Kart 64 – Works very smooth. I did a test race with only 1 player and that went very well.

    Legend of Zelda 64 – I need to play around with this one. I attempted to load it and it never finished loading. I may need to try it on the other emulator, with a different rom, or play with some graphics settings within mupen64plus itself.

    #88565
    Profile photo of noobian
    noobian
    Participant

    hmm…sadly the pi 2 came out by surprise just one month after i bought my b+…so i guess i aint gonna upgrade it soon…will wait some time till they release some more revisions i guess…

    #88626
    Profile photo of neighbourhoodnerd
    neighbourhoodnerd
    Participant

    I can confirm that SuperFX SNES titles run great on Pi2.
    Some N64 titles work great; depends on the emulator.
    PSX Emulation is extremely smooth video-wise; some audio issues at present but I think these can be resolved by software tweaks.

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar