Performance Issues on FBA

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of rvizcaino rvizcaino 2 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #8246
    Profile photo of rvizcaino
    rvizcaino
    Participant

    Hi friends, I have this problem with my retropie setup.

    My raspberry pi is highly overclocked, but still almost all my fba roms play very (very) slowly, in Neo Turf Masters (A simple golf game) I can not get over 35FPS, the sound is terrible, so I did the following reasearch:

    I am running the games with the retroarch core, if I change to the binary version the games run fine, but I can’t get the games in full screen, big black borders on top and bottom (and yes I have my overscan adjusted, with retroarch fills everything just right) and I just don’t know how to adjust that. Besides that I prefer using the retroarch core because of configuration options.

    Another thing I found is that when I disable completely sound (audio_enabled = false) I get perfect 60FPS in all games! Please help and thank you in advance!

    PD: Sorry for my english, I am from Colombia (Yes, Falcao and Shakira)

    #8287
    Profile photo of kitchuk
    kitchuk
    Participant

    The Retroarch FBA core is terrible in the pi. I doubt you will be able to get full speed with it. Have you tried going into the Pi-fba config file and changing the aspect ratio? This way you can make the image fill the screen. I definitely recommend the binary over retroarch.

    Sent from my GT-I9300 using Tapatalk

    #8316
    Profile photo of rvizcaino
    rvizcaino
    Participant

    Hi, thanks for your answer, the problem is I don’t know the options in fba2x.cfg, in terms of video configuration I only see:

    [Graphics]
    DisplaySmoothStretch=1
    # Display Effect: 0 none, 1 scanlines
    DisplayEffect=0
    DisplayBorder=0
    MaintainAspectRatio=1

    Can you guide me how to get it working full screen? Thanks

    PD: pisnes is working full-screen flawless with this setup.

    #8329
    Profile photo of kitchuk
    kitchuk
    Participant

    MaintainAspectRatio=0 that will make it fill the screen for you. Plus all games will run at 60fps.

    Sent from my GT-I9300 using Tapatalk

    #8331
    Profile photo of rvizcaino
    rvizcaino
    Participant

    You’re right, MaintainAspectRatio=0 fills the screen but as I have an 16:9 TV, image looks stretched, I wish to have the image in the original aspect ratio.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar