Perfect Sound/Graphic Settings For PSX on RPi 2

Home Forums RetroPie Project Everything else related to the RetroPie Project Perfect Sound/Graphic Settings For PSX on RPi 2

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of jamesandjome-com jamesandjome-com 1 year, 12 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #96281
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    Hello all,

    By hitting the hotkey button and F1 in game, you get access to (Retroarch?) menu.

    Going to Options >> Core Options and ensuring “Dynamic Recompiler” is enabled, PSX sound is absoulutley fantastic. Great.

    Now there is another option called “Enhanced Resolution” with a (Slow) warning. When enabled the graphics look absolutely amazing, however the sound then gets terrible.

    So I have everything I want, great sound, great graphics, but they will not work together.

    I have tried an aggressive overclock like this,

    force_turbo=1 #Voids Warranty!!!
    arm_freq=1100
    sdram_freq=500
    core_freq=500
    over_voltage=6
    temp_limit=80 #Will throttle to default clock speed if hit.

    and there was no improvement. Although shaders can be used they have nothing on the “Enhanced Resolution” setting.

    Has anyone figured out how to get both sound and graphics top notch?

    #96283
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    An example of the difference between Enhanced Resolution disabled/enabled.

    Sorry about the potato quality.

    Attachments:
    #96413
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    Does anyone have any input on this?

    Enhanced Resolution looks amazing and I would really appreciate your help to try to get this working smoothly.

    #96426
    Profile photo of pokeparadox
    pokeparadox
    Participant

    I know for the OpenPandora the HiResolution settings run full speed but this is an Cortex A8 and maybe the Neon instructions run more optimally.

    Additionally The Pandora has auto frameskip. You can only set a constant frameskip value in RetroArch. You can get reasonable performance by setting this to 1 but it’s not perfect as you do see more juddering.

    #96441
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    That’s a start for me to tinker with, thank you.

    #96464
    Profile photo of trixster
    trixster
    Participant

    I can run with high quality sound and the higher quality graphics at the same time, no issue. My pi2 is similarly overclocked as yours. I can’t really help you with your issue though, sorry.

    #96477
    Profile photo of patrickm
    patrickm
    Participant

    Hello all,

    By hitting the hotkey button and F1 in game, you get access to (Retroarch?) menu.

    Going to Options >> Core Options and ensuring “Dynamic Recompiler” is enabled, PSX sound is absoulutley fantastic. Great.

    Now there is another option called “Enhanced Resolution” with a (Slow) warning. When enabled the graphics look absolutely amazing, however the sound then gets terrible.

    So I have everything I want, great sound, great graphics, but they will not work together.

    I have tried an aggressive overclock like this,

    force_turbo=1 #Voids Warranty!!!
    arm_freq=1100
    sdram_freq=500
    core_freq=500
    over_voltage=6
    temp_limit=80 #Will throttle to default clock speed if hit.

    and there was no improvement. Although shaders can be used they have nothing on the “Enhanced Resolution” setting.

    Has anyone figured out how to get both sound and graphics top notch?

    The very best video output for all systems is IMO achieved by using the default core options with the scanline overlay and sharp-bilinear filter. This will give you a clean image with scanlines, similar to using an XRGB-Mini.

    go to settings -> overlay settings -> effects -> wii -> scanlines.cfg

    go to options -> shader options -> shader passes and select “1”. Go to shader 0 and select “sharp-bilinear.” Go to shader 0 filter and select linear. Select apply settings.

    make sure your scaling is correct! Enable integer scaling if you haven’t. You should immediately be able to tell if scaling is correct by just looking at some small text – some pixels will be warped/distorted as a result of bad scaling. The scanline overlay makes it easy to detect bad scaling, as the scanlines should always line up with pixel edges.

    Enhanced smoothing is the devil, you’re losing detail and introducing artifacts into the image, which is bad 😛

    • This reply was modified 1 year, 12 months ago by Profile photo of patrickm patrickm.
    #96485
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    I can run with high quality sound and the higher quality graphics at the same time, no issue. My pi2 is similarly overclocked as yours. I can’t really help you with your issue though, sorry.

    Thats strange, I have 2 of the RPi 2’s and cannot achieve this. Perhaps it is the games I am playing?

    My testing has been done on GT 2, Tenchu 2 and Diablo. If you do think of anything that maybe could help I would appreciate it.

    #96486
    Profile photo of jamesandjome-com
    jamesandjome-com
    Participant

    The very best video output for all systems is IMO achieved by using the default core options with the scanline overlay and sharp-bilinear filter. This will give you a clean image with scanlines, similar to using an XRGB-Mini.

    go to settings -> overlay settings -> effects -> wii -> scanlines.cfg

    go to options -> shader options -> shader passes and select “1”. Go to shader 0 and select “sharp-bilinear.” Go to shader 0 filter and select linear. Select apply settings.

    make sure your scaling is correct! Enable integer scaling if you haven’t. You should immediately be able to tell if scaling is correct by just looking at some small text – some pixels will be warped/distorted as a result of bad scaling. The scanline overlay makes it easy to detect bad scaling, as the scanlines should always line up with pixel edges.

    Enhanced smoothing is the devil, you’re losing detail and introducing artifacts into the image, which is bad :P
    [/quote]

    Hello and thank you for this. I will try these settings tonight.

    Your post reminded me also that I changed my config to say Video Smooth =True.
    I’ll ammend this and see if any of the above gives me what I am hoping to achieve.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar