PCEngine control mapping different between mednafen versions

Home Forums RetroPie Project Controller Configuration in RetroPie PCEngine control mapping different between mednafen versions

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 1 year, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #102579
    Profile photo of ratsflif
    ratsflif
    Participant

    The newer builds for the Pi2 use lr-mednafen-pce as the default pcengine emulator but the controls are not mapped correctly. Using my SNES controller as an example the two pcengine buttons get mapped to Y and B.

    If you load the pcengine roms with the lr-mednafen-pce-fast emulator then the two pcengine buttons are mapped correctly to the A and B buttons.

    Not sure of the differences between the two emulators but thought I would bring it up.

    • This topic was modified 1 year, 9 months ago by Profile photo of ratsflif ratsflif.

    #102581
    Profile photo of herbfargus
    herbfargus
    Moderator

    That is good to know. BTW you should be able to remap the core controls now under the quick menu in the rgui (called core input remapping) so that they match the other PC engine without needing to change your retroarch.cfg

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar