Overscan Issues with Terminal and Emulator

Home Forums RetroPie Project Video Output on RetroPie Overscan Issues with Terminal and Emulator

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 4 voices, and was last updated by Profile photo of dankcushions dankcushions 1 year, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #110116
    Profile photo of goldglv
    goldglv
    Participant

    I was trying to adjust the overscan seetings to get my emulators displaying full screen on my 1080p 70″ LCD TV. Once I got the overscan settings correct, the Terminal and Emulation Station screens were spilling off the edges of the screen.

    So for instance, when I would log into the Terminal, I wouldn’t be able to see part of the command prompt. Then I’d edit a file and the left side of the file is not visible, by say 5-10 characters.

    So when I’m trying to modify a file through the Terminal, I can’t see what I’m doing.
    Emulation Station is having same issue, can’t see some menu options on the bottom left part of the screen.

    There is only one config.txt file, is there any way to fix this or am I stuck with either having the black bars on the sides of the Emulators or having the Terminal not completely visible when typing commands?

    Thanks….

    #110551
    Profile photo of kittyjuls
    kittyjuls
    Participant

    I’m experiencing a similar problem. I have a custom frame buffer of 940 x 600 as I have mounted a 10.1″ screen (native 1280 x 720) into a Macintosh classic which only has a 9″ 4:3 screen opening. It seems everything except ES seems to respect my frame buffer settings.

    When I run /opt/vc/bin/tvservice -s the Pi tells me that I’m running 1280×720 16:9 which I’m guessing ES is using this value to configure the menu display. So I’m wondering if there is a way to force the Pi to accept the custom screen size so that the ES menu will follow suit?

    many thanks

    J.

    • This reply was modified 1 year, 5 months ago by Profile photo of kittyjuls kittyjuls.
    #110560
    Profile photo of buzz
    buzz
    Keymaster
    #110595
    Profile photo of dankcushions
    dankcushions
    Participant

    yeah you only want to use the overscan settings until emulationstation appears without any black borders/cut off edges. it sounds like you’re trying to use this setting to remove the vertical borders in emulated games? i wouldn’t do that! the emulators themselves have their own settings for aspect ratios/resolutions. you want to adjust this within the emulators, not via the overscan settings.

    for any retroarch emulators, i’d set the retroarch render resolution to ‘video output’ (https://github.com/RetroPie/RetroPie-Setup/wiki/runcommand) and then fiddle with the aspect ratio settings in the retroarch GUI. you also want to be aware of the ‘integer scaling’ option – if you have this turned on then your emulators will no fit to the edge of the screen UNLESS their native resolution is a factor of your TV screen (which is effectively true for NES, megadrive, snes, and some others)

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar