Official Wifi dongle not working

Home Forums RetroPie Project Everything else related to the RetroPie Project Official Wifi dongle not working

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of flowlance flowlance 1 year, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #107994
    Profile photo of flowlance
    flowlance
    Participant

    Hello there 🙂
    I have two Raspberry Pi 2 B’s, and two official wifi dongles (like this).

    The problem is that I can’t connect to any network, but it does detect wifi networks nearby. Other wifi dongles, such as the Edimax one, works. Also, the official wifi dongle works in a clean raspbian installation.

    The problem happens on both of my pi’s. Is there any solution to this?

    Thanks!

    Attachments:
    #108007
    Profile photo of herbfargus
    herbfargus
    Moderator

    You can always try it manually:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-Up-Wifi

    You can check the content of

    /etc/wpa_supplicant/wpa_supplicant.conf

    It should have your ssid and password there if it worked correctly.

    #108011
    Profile photo of buzz
    buzz
    Keymaster

    Am interested in the contents of /etc/wpa_supplicant/wpa_supplicant.conf after install. Even if it says it doesn’t connect, if the config is in place it may connect after a reboot or waiting for some minutes. Also interested in contents of “/var/log/wpa_supplicant.log” (or similar named file)

    #108033
    Profile photo of flowlance
    flowlance
    Participant

    here’s /etc/wpa_supplicant/wpa_supplicant.conf
    it seems to have the correct info:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    # RETROPIE CONFIG START
    network={
            ssid="andersennett"
            psk="*password*"
    }
    # RETROPIE CONFIG END

    Also, after manually editing /etc/network/interfaces, it hangs for a while at boot (see attached image), still does not seem to work

    Attachments:
Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar