Odd monitor issue

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of Floob Floob 2 years, 3 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #84607
    Profile photo of rookiewill
    rookiewill
    Participant

    Newbie here, haven’t touched linux since 1995 or really done any thing technical since 1999 other than boot up my computer for email, excel and powerpoint – rather embarrassing for someone who has a degree in computer and electrical engineering… However, discovered this blog and this project and immediately loved the idea. Picked up a B+ a few days ago, set everything up and have been enjoying teaching my kids what it was like to play video games before the WII or XBOX ONE was available. I’ve read a ton of posts and have learned a lot from this forum (and this blog) – so thanks to everyone.

    However, I am having what I think is an odd issue and I can’t seem to figure out. When I initially reboot my pi after plugging in the monitor and pressing f4 in emulation station, everything in the terminal mode looks perfectly fine. However, once I play a few games and then go into terminal mode, the screen has shifted to the left – so I can’t read the first 2-3 characters in any of the terminal applications. If I then do a reboot, problem persists. I literally need to unplug my HDMI cable for it to reset.

    This is only a problem when I am trying to mess with various configuration files in terminal mode. When I am playing a game it is not a problem (or I don’t notice a problem). Any suggestions?

    #84608
    Profile photo of Floob
    Floob
    Moderator

    You could try setting overscan to shift the screen right a little

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84659
    Profile photo of rookiewill
    rookiewill
    Participant

    I tried the overscan and it works fine, until after I load a game, then it loses the overscan. When I exit emultationstation, I get the following message (also uploaded screenshot – http://imgur.com/xwA5xQ6)

    Powering on HDMI with explicit setting (CEA Mode 4)
    Frontend supports RGB565 – will use that instead of XRGB1555.
    RetroArch[WARN] :: [GL] Stock GLSL shaders will be used.
    Powering on HDMI with preferred settings
    ondemand

    (or at least that is what I think it says, I had to hook it up to a 40 inch monitor to read it as the left is cut off on the monitor I am primarily using – see this screenshot – http://imgur.com/MpUnpoZ – sorry for the poor screen shots, just trying to be quick)

    #84694
    Profile photo of Floob
    Floob
    Moderator

    Could you post your congif.txt as an attachment. Then perhaps we can see something useful when comparing to the options available

    http://elinux.org/RPiconfig#Video

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84726
    Profile photo of rookiewill
    rookiewill
    Participant

    First file is config.txt from /boot (I changed the left overscan as part of playing around with it, was previously 16 and has no impact after I exit ES)

    Second file is output from tvservice script

    #84730
    Profile photo of rookiewill
    rookiewill
    Participant

    I edited the /etc/emulationstation/es_system.cfg and took in the NES part of the script turned the “runcommand.sh 4” to “runcommand.sh 5” and the problem has gone away (I’ve only done this for NES, but imagine it will solve it for others).

    I guess this resolves my problem, but two questions

    1. the default for NES is 4, and I imagine that is the idea environment. I am guessing that there is a setting somewhere for CEA Mode 4 (if that is what it is called) where it is doing an overscan to the left less than I want to. Can’t I edit that somewhere?

    2. Is there any harm in having it run in mode 5 (1080i) vs. 4 (720p)?

    #84758
    Profile photo of Floob
    Floob
    Moderator

    I’m not sure what this does, as its not in the manual?
    overscan=1
    Try removing that.

    Also, change #disable_overscan=1 to
    disable_overscan=0

    So just making sure it is using that setting basically.
    Try specifying all the overscan values, so

    overscan_left=40
    overscan_right=16
    overscan_top=16
    overscan_bottom=16

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar