Not saving to gamelist.xml

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of scotty Scott 2 years, 8 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #21229
    Profile photo of spiffo
    spiffo
    Participant

    Ok, I’ve installed a new image of v2.3 followed the setup guide and all is going great but I still have one problem.

    If I Scrape some metadata for my Megadrive Roms it all shows up in Emulation Station nicely but as soon as I reboot all the images and text have gone and I have to start again !

    I’ve used Filezilla to have a look around and the images are all there in the downloaded-images folder but the gamelist.xml is still the blank default one, looks like it just isn’t writing to it for some reason ???

    #21891
    Profile photo of spiffo
    spiffo
    Participant

    OK, I’ve solved it !

    The default gamelist.xml files are not formatted correctly, if you open one in a Text Editor it is formatted like this:

    <?xml version=”1.0″?>
    <gameList />

    What you need to do is correctly format the default gamelist.xml like this:

    <?xml version=”1.0″?>
    <gameList>
    </gameList>

    No idea why they are all wrong as this was built from a 2.3 image and I didn’t alter them ???

    #22509
    Profile photo of rjanak
    rjanak
    Participant

    On mine, I’ve found that if I shutdown or restart the Pi from within Emulation Station, it does not save my gamelist.xml files. If I exit Emulation Station, and then shutdown or restart, it does save them.

    From what I can tell, mine are formatted correctly… or at least they don’t have the same error you posted.

    #22957
    Profile photo of spiffo
    spiffo
    Participant

    Yep, agreed, mine is the same.

    I need to exit Emulation Station first then do a sudo reboot from the Terminal otherwise any changes aren’t saved !

    #45160
    Profile photo of scotty
    Scott

    I had the same issue however the “root” cause was the permissions on the game list.XML file. Since I copied over a new file logged in as root to see the files the owner was now root. I changed the owner to the default login of Pi and it now works without issue.

    Alternatively I could have left the owner and changed the permission to read and write for everyone.

    Hope this helps someone.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar