Noob Question – No audio

Home Forums Community General discussion Noob Question – No audio

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of flavad99 flavad99 1 year, 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #101041
    Profile photo of flavad99
    flavad99
    Participant

    I realize this probably gets asked a lot but I have been through some of the steps outlined on the web and am still having trouble getting sound.

    I installed Retropie a few days ago, NES, SNES, Genesis working great, still ironing out the details on PSX / Neo Geo (Haven’t had time to look at the BIOS solutions out there yet). I have a Retropie 2 and installed the Beta 3.0 version. Built from an SD image, SNES gamepad, keyboard, mouse, and USB plugged in. Games on the NES, SNES, Genesis emulate fine, however, I get no sound. I am connecting through an hdmi monitor.

    I followed the steps here

    http://elinux.org/R-Pi_Troubleshooting#Sound

    but didn’t receive any luck. The only thing I can think of is that I am rebooting (sudo reboot) afterchanging the settings. I have tried returning directly to the emulationstation screen using startx, but my pi freezes on a white screen when I try this.

    Any ideas? Thanks for any help you could provide, as you might tell, I have no programming experience prior to getting one of these.

    #101057
    Profile photo of buzz
    buzz
    Keymaster

    You dont use startx to load emulationstation you just type emulationstation.

    you need to reboot if adjusting config.txt, but I can’t advise further other than what is on that page and other threads on the forum with ideas. usuaully hdmi_drive sorts it if using dmt mode and you want sound over hdmi.

    • This reply was modified 1 year, 10 months ago by Profile photo of buzz buzz.
    #101077

    Post your config.txt

    #101133
    Profile photo of flavad99
    flavad99
    Participant

    from the /boot/config.txt file

    #hdmi_safe=1
    #disable_overscan=1

    Overscans equal to 16

    #framebuffer_width=1280
    #framebuffer_height=720
    #hdmi_force_hotplug=1
    #hdmi_group=1
    #hdmi_mode=1
    #hdmi_drive=2
    #config_hdmi_boost=4
    #sdtv_mode=2

    Is this sufficient? Thanks!

    #101286
    Profile photo of flavad99
    flavad99
    Participant

    Fixed it. I saw this on another forum. You can’t just edit the hdmi_drive=2 within the pre-existing text, you have to add an additional line at the bottom. Write the text to the configuration file, reboot, and my sound worked.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar