no writing permission for retroarch.cfg

Home Forums RetroPie Project Everything else related to the RetroPie Project no writing permission for retroarch.cfg

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 12 replies, has 7 voices, and was last updated by Profile photo of mccarthy mccarthy 2 years, 8 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #12109

    Thomas

    es 2.2

    i want so save my changes in retroarch / pocketsnes…

    couldnt do it! i dont can save changes the retroarch.cfg in /opt/…

    whats wrong?

    i have no writing permission for /opt/ in WinSCP…

    #12111
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    the answers to your question is in the previous topic before this one, mate

    Sent from my iPhone using Tapatalk

    #12112
    Profile photo of tafazzi87
    tafazzi87
    Participant

    from terminal you’ve to use sudo command

    #12115
    Profile photo of smatticus
    smatticus
    Participant

    In ES Hit f4 to exit to command prompt. Use the command
    sudo passwd
    and choose a password. Then when you go to connect via winscp, enter root as the username and your new password as the password

    #12116

    Thomas

    no

    i want to save from retroarch…

    start the game… open the config menu… do my changes and so i want to save…

    “cant save to …”

    i cant copy or change files in /opt/

    #12117

    Thomas

    Then when you go to connect via winscp, enter root as the username and your new password as the password

    worked for winscp, but not in the emulator..

    #12125
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    look here…
    http://blog.petrockblock.com/forums/topic/2-1-permissions/

    and here…
    http://blog.petrockblock.com/forums/topic/retropie-2-0-help/

    both the same, both will help with what your asking

    #12200

    Thomas

    i want to do my changes in the retroarch menu of the running rom…

    but if i activate save on exit —>> nothing

    and if i want to save to a new config, it shows ” cant save to /opt/

    how can i get always root rights in the running retropie

    if I use the retroarch menu to edit settings within a rom and I go to “save new retroarch” or whatever it says, I get the error “cannot save to retropie/configs/a…”

    #12205
    Profile photo of jakko36
    jakko36
    Participant

    Same happend to me with Mame4all-pi, i did not have permission to save the config to opt/retropie…… etc etc.
    What i found was to do this in terminal: sudo chmod 777 (the map you need permission for) then go back mame4all-pi and you can map your buttons and save the config.
    The same thing works with retroarch.
    you will need root acces to cfg the most emulators.

    #12219
    Profile photo of nemo93
    nemo93
    Participant

    Hi Guys,

    I was a bit reluctant to propose this workaround as I haven’t tested it thoroughly but given the increasing number of posts about it here we go!

    Launch a command line and issue the following command:

     $ sudo chown -R pi:pi /opt/retropie/
    

    You should end up with:

    $ ls -la /opt/retropie/
    total 24
    drwxr-xr-x  6 pi   pi   4096 Jul  1 22:40 .
    drwxr-xr-x  5 root root 4096 Jul  1 21:34 ..
    drwxr-xr-x 17 pi   pi   4096 Jul  1 21:47 configs
    drwxr-xr-x 13 pi   pi   4096 Jul  1 21:42 emulatorcores
    drwxr-xr-x 24 pi   pi   4096 Jul  1 22:30 emulators
    drwxr-xr-x  5 pi   pi   4096 Jul  1 22:31 supplementary
    

    Let me know if this does improve your situation.
    cheers,

    #12265
    Profile photo of zsprawl
    zSprawl

    May want to only do the configs subfolder?

    This is certainly better than using the root user though imho.

    #12309
    Profile photo of ribenickel
    ribenickel
    Participant

    As a windows user and linux starter i like to change my retroarch files inside a gui. To do that i type “sudo su” in shell to get root acces and afterwards “startx” to enter rasbian gui then i can open the file via leaf and save changes. After I’m done i just reboot to loose root acess again…

    #30867
    Profile photo of mccarthy
    mccarthy
    Participant

    Hi guys,
    I have a big problem. The ps3 controller doesn’t work for me, too, but there is no “minimal.CPP”. The whole src-folder isn’t there.
    Thanks for help.
    Cheers

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar