No WLan0 interface – Raspberry Pi 3

Home Forums RetroPie Project New to RetroPie? Start Here! No WLan0 interface – Raspberry Pi 3

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: ,

This topic contains 9 replies, has 4 voices, and was last updated by Profile photo of meneerjansen meneerjansen 1 year, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #121605
    Profile photo of marcwallace
    marcwallace
    Participant

    Hi,

    Hope someone can help? I’m very new to this and it was all going so well.

    I installed retro pie 3 last week when my new pi3 came, it was going into an arcade cabinet me and a friend were building. I was able to connect to it using filezilla and was able to transfer roms, all was good.

    Yesterday i fired it up for a quick test and I can’t see the wlan0 interface at all. Running ifconfig only shows eth0 and lo.

    I don’t have a long enough cable to connect it to my router so I’m a bit stuck.

    I had gotten the latest versions of doing an update command before putting any rooms on and it had rebooted a few times before it failed, so I’m stuck as to what could have broken this.

    I followed some posts about editing the interfaces file to make sure wlan0 was in there, mine now reads

    auto lo
    iface lo net loopback
    iface ethic net manual
    auto wlan0

    Can anyone help a noob?

    Thanks

    Marc

    #121621
    Profile photo of meneerjansen
    meneerjansen
    Participant

    What you might try:

    In Emulationstation/RetroPie go to: Retropie (i.e. the setup menu) –> Configure WiWi –> choose ‘Connect to WiFi network’

    You’ve probably done that already and apparently it won’t work. Unfortunately for you is that this dialog screen already does “every Linux trick” in the book to connect.

    Since successfully connecting to your beloved Pi the first time: did you change something w/ regard to hardware? Like connecting other USB devices? An USB hub? In my experience WiFi can eat a lot of power and due to extra hardware your Pi might be under powered now.

    P.S. The way I force my Pi to connect to WiFi is:

    sudo ifconfig wlan0 up
    And then wait a minute.

    Check IP address and if your connection is up w/:

    ifconfig
    Good luck! 🙂

    P.S. Thanks to Buzz I corrected the typo in wlan0.

    • This reply was modified 1 year, 2 months ago by Profile photo of meneerjansen meneerjansen.
    • This reply was modified 1 year, 2 months ago by Profile photo of meneerjansen meneerjansen. Reason: Typo in wlan0 edited!
    #121624
    Profile photo of buzz
    buzz
    Keymaster

    You may have already damaged your /etc/network/interfaces file – the content you posted above is not correct. Also the instructions above for ifconfig has a typo too (should be wlan0)

    the default /etc/network/interfaces file contains

    
    # interfaces(5) file used by ifup(8) and ifdown(8)
    
    # Please note that this file is written to be used with dhcpcd
    # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'
    
    # Include files from /etc/network/interfaces.d:
    source-directory /etc/network/interfaces.d
    
    auto lo
    iface lo inet loopback
    
    iface eth0 inet manual
    
    allow-hotplug wlan0
    iface wlan0 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    
    allow-hotplug wlan1
    iface wlan1 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    
    
    #121628
    Profile photo of marcwallace
    marcwallace
    Participant

    Hi,

    Firstly, thanks for replying! I’ve tried to go into wifi config in Retro pie and unfortunately no networks are displayed, there should be over 10 e.g. neighbours etc.

    trying sudo ifconfig wlan0 up just gives me error while getting interface flags: no such device.

    In the pi I have plugged in a usb keyboard, it’s also hooked up to a joystick setup that me and a mate have built and a usb gamepad. I had no wi fi before plugging in the custom joystick setup and the gamepad / keyboard were plugged in then. There’s no hub plugged in, I do have a 2.1 setup plugged into the headphone socket.

    Ifconfig only shows eth01 and lo.

    #121631
    Profile photo of marcwallace
    marcwallace
    Participant

    Hi,

    Thanks for replying. I’ve replaced my interfaces file with your post and unfortunately still no interface.

    Do you have any other ideas please?

    thanks

    #121655
    Profile photo of herbfargus
    herbfargus
    Moderator
    #121674
    Profile photo of marcwallace
    marcwallace
    Participant

    Hi,

    I’ve gone through that Wiki page before and I had successfully set up the wireless connection. I was able to update the versions and get a load of roms on. It’s only after a few reboots and a few days passing, no wireless interface anymore.

    #121696
    Profile photo of meneerjansen
    meneerjansen
    Participant

    Hi,

    I’ve gone through that Wiki page before and I had successfully set up the wireless connection. I was able to update the versions and get a load of roms on. It’s only after a few reboots and a few days passing, no wireless interface anymore.

    Which of the 4 methods described there did you use?

    #121725
    Profile photo of marcwallace
    marcwallace
    Participant

    Hi,

    I’ve gone through that Wiki page before and I had successfully set up the wireless connection. I was able to update the versions and get a load of roms on. It’s only after a few reboots and a few days passing, no wireless interface anymore.

    Which of the 4 methods described there did you use?

    I used method 1 originally and it was working perfectly. I tried option 2 yesterday following a post on here. Neither have worked. I have a 5m ethernet cable coming today which should allow me to bridge to the router. I will then run another update just in case.

    I really appreciate your help.

    #121872
    Profile photo of meneerjansen
    meneerjansen
    Participant

    The update thing might work best… Anyway, considering that you used “Method 2” from the Retropie Wifi Wiki you might also consider to reset the /etc/network/interfaces file to what I have and what works for me w/ Method 1 (i.e. use the dialog wizard from Retropie):

    auto lo
    iface lo inet loopback
    
    iface eth0 inet manual
    
    allow-hotplug wlan0
    iface wlan0 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    
    allow-hotplug wlan1
    iface wlan1 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    

    Good luck! 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar