No keyboard or controller after update

Home Forums RetroPie Project Controller Configuration in RetroPie No keyboard or controller after update

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of simonmoon simonmoon 1 year, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #112337
    Profile photo of simonmoon
    simonmoon
    Participant

    I just updated a fully functional version 3 RC to current 3.3 via the binary update. The keyboard does not work, nor either controller an ibufallo classic SNES controller, or the F310. The system sees the controllers, but not any input. I use the controllers separately one at a time as the player one controller.

    Pi Model: Raspberry Pi 2
    RetroPie Version Used: 3 beta from image sucessfully updated to 3 RC2 then update to 3.3
    Built From: (SD Image, Binary, Source)
    USB Devices connected: keyboard, IBuffalo, or F310

    • This topic was modified 1 year, 4 months ago by Profile photo of simonmoon simonmoon.
    • This topic was modified 1 year, 4 months ago by Profile photo of simonmoon simonmoon.

    #112666
    Profile photo of pinoob
    pinoob
    Participant

    did you try to enable/disable the xbox driver for it.. I had the same problem where it would detect it as the F310, then work for Emulation Station, but not the actual retroarch… so I did the Retropie ->retropie setup -> #3 -> #328 disable xbox then re-enable it and now it works in games… as well as the exit hot key combination..

    #112670
    Profile photo of Nima
    Nima
    Participant

    hi
    yes . i had controller problems (x360 – ps3 – twin joy) in new ver 3.3 and 3.3.1 . finly after half hour find a slution . its changin joypad driver from sdl2 to udev .

    its best to do after starting fresh instal and after configing joy in emulation station .

    i dont have retropi runing now but i remember some :
    start > retropie > setup-retropie [2nd from down] > setup [3rd section] > config retro arch setting > change commen setting [1st section] > all [1st] > change joypad driver from sdl2 to udev . after that back to first page and perform rebbot . and all set .

    plz after testing post result . thanks

    #112835
    Profile photo of simonmoon
    simonmoon
    Participant

    I had customized my RetroArch.cfg, so I could exit games using start/select. This screwed up the updated retropie, and is no longer needed.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar