No Controls In SNES Game

Home Forums RetroPie Project Controller Configuration in RetroPie No Controls In SNES Game

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of rmr110 rmr110 1 year, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #96830
    Profile photo of rmr110

    I’m using Raspberry Pi 2 (1GB Memory) and RetroPie SD-card Image for Raspberry Pi 2 Version 2.6 Before I start, I must say that I am new to Retropie & Linux. Not afraid to mess up and start from scratch thanks to Floob’s very helpful videos.

    So I have this very odd problem which I cannot find an answer to:

    My controller does not work after a game has been started while using a SNES rom. I’ll use Super Mario All Stars as an example.

    1) A to Select Super Nintendo Entertainment System from main menu.
    2) A to Launch Super Mario All Stars game.
    3) Start to bypass (game) splash screen.
    4) L/R D-pad to select game (Super Mario 1987)
    5) Start to start game.
    6) Start to select file A.
    7) U/D D-pad to select 1 or 2 player game.
    8) Start to start game.

    So everything is works up to the part where the actual game starts. After that the only buttons that work are the Select + Start and that only exits the game completely.

    I’ve tried other ROMS and different versions of Super Mario Bros. and it is pretty much the same thing.

    Other games – Pac Man in MAME – work without a problem.

    Profile photo of paquito

    Configure your buttons in “Retropie” option -> Configure retroarch controller (or something similar)

    Profile photo of Floob

    Can you try Mario Kart as an example game? Its just that All Stars can have issues.

    What is your controller? Do you get yellow text appear at the bottom of the screen when a game starts?

    RetroPie help guides -->
    Please read this before asking for help -->

    Profile photo of rmr110

    I did try Super Mario Bros. (stand alone) before the All Stars version and it was non-responsive. I’ll see if I can find a couple more SNES ROMS to see what happens.

    I’m using a PS3 controller. Works for MAME & Finalburn Alpha – just have to figure out how to re-map the buttons from default.

    I am getting the yellow text Joystick Port #0 …

    OK, I just found The Legend of Zelda – A Link to the Past (I remember playing that game when it first came out – LOL!!) and it works. I’ll try a few more games though and see if I can find some more SMB versions to try out.

    Forgot to add: A HUGE thanks Floob for putting up those videos. I’ve learned a lot in such a short time 🙂

    • This reply was modified 1 year, 11 months ago by Profile photo of rmr110 rmr110.
    Profile photo of rmr110

    I tried a couple more versions of the All Stars & All Stars + World only to have the same problem – no controls after game start.

    I found a stand alone version of Super Mario World and that worked without issue.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar