New to RetroPie, Attempting to build a portable project but stuck!!!

Home Forums RetroPie Project New to RetroPie? Start Here! New to RetroPie, Attempting to build a portable project but stuck!!!

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.


This topic contains 5 replies, has 3 voices, and was last updated by Profile photo of stuartfox stuartfox 1 year, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #108698
    Profile photo of stuartfox

    Hi there everyone, My first post.

    I’ve got stuck with a portable build (into the case of an original, faulty GameBoy).

    I have both the Adafruit 2.8 and 3.5″ PiTfts, and I’ve followed instructions to download and configure their drivers on top of the RetroPie image. Not getting any joy!

    I’ve used the latest retropie image, then followed the steps here

    This results in the following error:

    Failed (code8).
    [FAIL] File system check failed. A log is being saved in /var/log/fsck/checkfs if that location is writable. Please repair the file system manually. … failed!
    [warn] a maintenance shell will now be started. CONTROL-D will terminate this shell and resule system boot. … (warning).
    sulogin: root account is locked, starting shell

    I’ve tried a few other ways – but I feel I’m in a bit over my head – and I can’t get it running on my TFT screen.

    Hoping someone here knows what I’m doing wrong. 🙁

    Profile photo of buzz

    Not sure if you are saying whether retropie initialy works or not ? if not – check image checksum with the one listed on the site – if it matches rewrite it – if not, then re-download (use the torrent).

    if it does, then looks like you are getting some sdcard corruption after use or something.

    Profile photo of stuartfox

    The retropie image boots and runs fine with an hdmi monitor attached. Trying to add the adafruit drivers causes the issue.

    I’ve now tried starting out with Adafruits raspian image which does work with the screen then installing Retropie with the setup script. Not able to do it though:

    git clone git://
    Cloning into ‘RetroPie-Setup’…
    fatal: unable to connect to[0:]: errno=No route to host

    Wifi is connected and working 🙁

    Profile photo of herbfargus
    Profile photo of stuartfox

    I’ve followed this on top of Adafruits Wheezy image ( )

    After the restart when all steps were complete I lost use of USB keyboard so I SSH’d into the pi and tried to launch emulationstation.

    Got these errors

    Could not find <gameList> node in gamelist “/home/pi/.emulationstation/gamelists/wonderswan/gamelist.xml”!

    Even though I had a couple of roms installed. Also couldn’t find the file location specified in the errors.

    Sorry – I have the feeling these issues are pretty simple but I can’t get my head around it. I assumed it would be easier to get RetroPie working with one of the screens I have.

    Profile photo of stuartfox

    OK – just to add – the errors above appear on the TFT screen, but when a monitor is connected as well via HDMI, Emulation Station runs as normal on this while the TFT screen continues to display the errors in text.

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar