NES resolution

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of vincegun vincegun 2 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #91245
    Profile photo of vincegun
    vincegun
    Participant

    Hi, I’m trying to change the screen resolution of the NES emulator. Basically, I’d like to stop it from being 16:9 and be 4:3.

    How do I go about doing this? The retroarch.cfg file in /opt/retropie/configs/nes is empty save for a few lines about shaders, FWIW.

    #91246
    Profile photo of monstrx
    monstrx
    Participant

    Hi mate.
    I believe this is what you’re looking for.

    http://blog.petrockblock.com/forums/topic/force-43-screen/

    Cheers

    Sent from my GT-I9505 using Tapatalk

    #91247
    Profile photo of cacophony555
    cacophony555
    Participant

    If you didn’t mess with resolution/aspect ratio settings before then I would try switching the aspect ratio of your TV. It’s possible you have it on some sort of stretch mode.

    The reason I say this is because the 2.6 image by default displayed the retroarch NES emulators at a 4:3 ratio on my 16:9 TV. It looks great and I didn’t have to change a thing. When you start messing with the aspect ratio correction in retroarch the output image gets fuzzier in my experience.

    • This reply was modified 2 years, 1 month ago by Profile photo of cacophony555 cacophony555.
    • This reply was modified 2 years, 1 month ago by Profile photo of cacophony555 cacophony555.
    #91326
    Profile photo of vincegun
    vincegun
    Participant

    Well, my RPi B+ is hooked to my computer’s lcd via DVI. If I start a snes game via pisnes, the game doesn’t take up the full screen. There are black bars at either size and the game is at the correct size.

    However, nes games take up the full screen. It doesn’t look horrible, but I prefer to view it the way it was originally intended. Sorry, I’m just a little picky in that regard.

    I tried what the 4th comment on http://blog.petrockblock.com/forums/topic/force-43-screen/ said about runcommand.sh, but it didn’t seem to work.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar