NES Emulator Video Output Exceeding Screen Edges

Home Forums RetroPie Project Video Output on RetroPie NES Emulator Video Output Exceeding Screen Edges

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 13 replies, has 3 voices, and was last updated by Profile photo of dankcushions dankcushions 1 year, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #101916
    Profile photo of cattmlark
    cattmlark
    Participant

    Hi All,
    Relatively new to this and have had my retropie for the last week, have managed to find almost everything i need on here so far with regards to setting things up and configuring controllers and emulators etc, great forum and project so thanks a lot.

    I have one issue that is still outstanding and am struggling to find a solution for. The trickiest part is knowing what the problem is technically called so i cant really get a decent search on the specific problem. The issue is with the NES emulator video output going beyond the 4:3 resolution so i am missing the very left and very right of the screen.

    Pi Model- 2 ModelB
    RetroPie Version Used- 2.6.0
    Built From- SD Image
    USB Devices connected- iBuffalo x2
    Controller used- iBuffalo x2

    I have played with many a setting in the boot config.txt such as overscan and overscan edges and tried many different resolutions but although these make changes to the video output, the NES emulation still misses of the edges of the game screen in all modes.

    I have attached a picture of castlevania on the NES to help as you can clearly see the edges missing. I appreciate any help on this and thanks for reading.

    Matt

    nes

    Attachments:
    #101918
    Profile photo of cattmlark
    cattmlark
    Participant

    Just to add to this, i want to keep the 4:3 aspect ratio and the resolution that the screen is running is 1280×720 and as said in the OP changing these to other settings and the issue still happens.

    Emulation Station runs in 16:9 and there are no edges missing with that etc, i dont think this issue is to do with the retropie video output / settings but more likely to do with the libretro/retroarch settings for this specific emulator. Just hoping someone out there will be able to understand this and help me out.

    Matt

    #101923
    Profile photo of Floob
    Floob
    Moderator

    Although I’m not 100% clear on what you want the output to be, you can change the resolution that the output is set by pressing x as the game starts and choose the res for that system.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101927
    Profile photo of cattmlark
    cattmlark
    Participant

    Hi floob, it’s your vids I have been watching and following which I have found incredibly helpful.

    It’s really hard to explain the issue but the x or m on emulator start (although changing the resolution) doesn’t help with the issue. Can you see in the castlevania image I attached how instead of the top left saying “player and enemy” it says “layer and nemy” it’s because the left side of the screen is cut off. It’s not cut off the TV as there are the normal black borders of a 4:3 screen on a 16:9.

    If I use retroarch menu to change top left and bottom right it simply stretches what is already there, it doesn’t show any more of the picture.

    Any ideas?

    #101934
    Profile photo of Floob
    Floob
    Moderator

    As a first step I’d set the overscan and all other video settings in the /boot/config.txt back to default (comment out). Also make sure the output (via the menu accesses by x) is set to your TV output i.e. 720 or 1080p.

    Is that a TV or monitor you have there? Is it 1080p?

    Then try it on another TV/monitor to check if it any different.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101937
    Profile photo of cattmlark
    cattmlark
    Participant

    Thanks for the reply. I have tried everything back to defaults so that all is hashed out, the screen resolution changes and I get the black borders round the whole picture (top, bottom, left and right), then made sure the emulator resolution option is also set to default, but I still lose the same amount of relative screen edge what ever settings I choose.

    It’s a 720p TV, full resolution is 1366 x 786 which I have also tried setting manually in the config.txt with the same issue. Other emulators seem fine, it just seems to be the NES

    What happens if you try and launch castlevania on the NES? Would be interested to see if it is just that game/rom and if it’s reproducable?

    I will try another TV but I don’t think it is the set, as everything else (raspian, emulationstation, other consoles) seem okay, with no overscan or screen missing.

    Thanks again for trying to help. I could probably put up with it, but as most NES games are a decent difficulty and reaction based, losing a bit of the screen, really hampers my progress, the turbo tunnel doesn’t need to be any harder :-S

    Matt

    #101938
    Profile photo of Floob
    Floob
    Moderator

    Ok, looks like it may be emulator specific.
    As the game starts, press x, and choose nestopia as the default emulator.

    Other games seem fine with the default FCEUmm emulator.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101940
    Profile photo of cattmlark
    cattmlark
    Participant

    I will try now, so did you get the same for that game missing parts of the screen, as i would like to know if it is a global thing or if it is just my setup?

    I can’t see an option to change emulator when pressing x, just video res for emulator, game or rom.

    Cheers,
    Matt

    #101942
    Profile photo of Floob
    Floob
    Moderator

    Yes, I got the same issue, but it was fine when I changed emulator.
    Sorry, I’m using RetroPie 3 beta 4, I forgot thats not there in 2.6.0.

    I’m struggling to remember the 2.6.0 filesystem layout.
    Do you have a couple of nes sounding directories here?
    /home/pi/RetroPie/roms/

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101943
    Profile photo of cattmlark
    cattmlark
    Participant

    Okay thats cool, not to worry I have seen a vid before on how to change the emulator in a config file or move the rom to a different folder, so I will try that.

    It was mainly driving me crazy trying lots of things to do with video output to sort it and nothing helping.

    Do you think it is just this game and the default emulator as opposed to all games? I have tried a few other NES ROMs and not noticed it, but with some games it’s not always as obvious as it was with castlevania because of the words missing letters.

    Just wanted to say a big thankyou for your help and really quick responses so far, you’ve helped put my mind at rest that my setup is right (as much as it can be) and it just happens to be the first game I tried to play properly that had a slight issue. If it’s fine with nestopia you can close this one off as solved as I will just use that for this ROM 🙂

    Thanks again Matt

    #101948
    Profile photo of Floob
    Floob
    Moderator

    Yep, certainly just seems to be that rom with the ones I checked, the rest seemed fine.
    There is a comment on cropping here:
    http://emulation-general.wikia.com/wiki/Nintendo_Entertainment_System_emulators

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101952
    Profile photo of cattmlark
    cattmlark
    Participant

    Interesting find on that article, regarding cropping differences between certain games and lack of a standard on the NES. When I try SMB3 on RetroPie the cropping is there (according to the article) and is correct, and there is no part of the needed viewable screen that is missing, so the emulation seems perfect in regards to the video output.

    Thanks for all your help floob.

    #102941
    Profile photo of cattmlark
    cattmlark
    Participant

    Just thought I would let people know in case they come across the same issue on the NES, that I have resolved the issue to a degree on RetroPie 2.6.

    I came to play battletoads and this one was missing the top and bottom of the screen so no health or score was visible, unfortunately 2.6 only has 1 NES emulator, so floob’s suggestion of switching the problem ROMs to another emulator folder isn’t possible with 2.6

    I edited the opt/emulators/configs/nes/retroarch.cfg file with sudo nano and added the line below to the file

    video_overscan_crop = false

    I then restarted the emulator and tried again and this time the whole screen was visible so success and I have fixed the issue. I rechecked castlevania and the whole screen was now there as expected this time.

    The only downside to this is that as this is a global NES retroarch emulator config change, all NES games now have no overscan cropped, so Super Mario Bros 3 for example had overscan visible on the left and bottom side of the screen similar to the article floob posted previously.

    However I would rather have more of the screen than needed visible than missing some like scores or health bars etc.

    Hopefully this will help others having the same issue on 2.6

    Many thanks Matt

    #103105
    Profile photo of dankcushions
    dankcushions
    Participant

    you can do rom-specific config files, but you will need to ugprade to the latest version of retropie, I believe.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar