NES and SNES games running at 50 fps suddenly

Home Forums RetroPie Project Everything else related to the RetroPie Project NES and SNES games running at 50 fps suddenly

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 10 replies, has 4 voices, and was last updated by Profile photo of buzz buzz 2 years, 3 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #82606
    Profile photo of deaftolight
    deaftolight
    Participant

    For some reason, with moderate overclock settings, NES and SNES games are now running around 50 fps with choppy audio. I don’t know why… they always used to work fine with moderate overclock settings… Now I have to overclock to high or turbo to get them to work.

    The Guardian Legend and Mega Man II were my test roms. Anybody experiencing this?

    Model B+ Pi 512MB

    #82671
    Profile photo of mr9v9
    mr9v9
    Participant

    I would suggest to try a few things in your retroarch config, with or without overclocking>

    # Video vsync.
    video_vsync = true
    
    # Forces cropping of overscanned frames.
    # Exact behavior of this option is implementation specific.
    video_crop_overscan = true
    
    # Video refresh rate of your monitor.
    # Used to calculate a suitable audio input rate.
    video_refresh_rate = 60.00

    Make sure you aren’t using a fancy shader, and make sure you don’t have smooth video enabled with the shaders.
    Hope that helps.

    • This reply was modified 2 years, 5 months ago by Profile photo of mr9v9 mr9v9.
    #82684
    Profile photo of deaftolight
    deaftolight
    Participant

    Thanks, but unfortunately it didn’t work.

    The only way I can get games to run at full speed (60 fps) now is to set the overclock to the highest setting, turbo, at 1000 mhz. It’s odd, because I don’t remember having to do that before. Having the overclock set on medium before seemed to run everything fine. I checked top, and retroarch is the only thing running… using 90% CPU and 5% MEM

    #82711
    Profile photo of deaftolight
    deaftolight
    Participant

    This is really throwing me off. I don’t know why all of the sudden the Pi can’t handle this. I can’t think of anything that would have caused it. I hadn’t used it for about a month, and then I installed XBMC standalone alongside… but that wouldn’t cause a slowdown. It’s not like XBMC is running while the Pi is playing ROMs. And the SD card has tons of space still.

    #82748
    Profile photo of mr9v9
    mr9v9
    Participant

    When was the last time you ran sudo rpi-update ?
    It may or may not help….I’m having an issue with one particular game doing that to me, and the sound gets all crunchy like it can’t handle it and fps drop like crazy.
    I’m playing with my overclock settings as well and what I mentioned above seemed to help me. If I find out more I will post back.

    #82782
    Profile photo of deaftolight
    deaftolight
    Participant

    I ran one two weeks ago. now that I think about it, this may have started happening after the update.

    #82785
    Profile photo of mr9v9
    mr9v9
    Participant

    I know it sounds funny but try pulling your Sd card out (With the pi off :)) and connect it to a windows pc and run a checkdisk on it, including the sector check. I know it won’t “find” anything but give it a go anyway and see if your problem persists.
    I fixed my low FPS problem with swapping out a couple bad roms on snes, I also updated my sound settings in my config file if you want to try it out>

    #### Audio
    
    # Enable audio.
    # audio_enable = true
    
    # Audio output samplerate.
    audio_out_rate = 44100
    
    # Audio resampler backend. Which audio resampler to use.
    # Default will use "sinc".
    # audio_resampler =
    
    # Audio driver backend. Depending on configuration possible candidates are: alsa, pulse, oss, jack, rsound, roar, openal, sdl, xaudio.
    audio_driver = alsathread
    
    # Override the default audio device the audio_driver uses. This is driver dependant. E.g. ALSA wants a PCM device, OSS wants a path (e.g. /dev/dsp), Jack wants portnames (e.g. system:playback1,system:playback_2), and so on ...
    # audio_device =
    
    # Audio DSP plugin that processes audio before it's sent to the driver. Path to a dynamic library.
    # audio_dsp_plugin =
    
    # Will sync (block) on audio. Recommended.
    audio_sync = true
    
    # Desired audio latency in milliseconds. Might not be honored if driver can't provide given latency.
    # audio_latency = 64
    
    # Enable audio rate control.
    # audio_rate_control = true
    
    # Controls audio rate control delta. Defines how much input rate can be adjusted dynamically.
    # Input rate = in_rate * (1.0 +/- audio_rate_control_delta)
    # audio_rate_control_delta = 0.005
    
    # Audio volume. Volume is expressed in dB.
    # 0 dB is normal volume. No gain will be applied.
    # Gain can be controlled in runtime with input_volume_up/input_volume_down.
    # audio_volume = 0.0
    #82787
    Profile photo of deaftolight
    deaftolight
    Participant

    Bummer. I just tried the suggestions, and I still get lag even on NES games if the pi is clocked to anything under 1000 MHz. Really stumped. It doesn’t make sense, NES games should run fine at 900 MHz, or even less than that.

    Also, I read in another thread http://www.raspberrypi.org/forums/viewtopic.php?f=78&t=6750&start=350 that the fact RetroArch is taking 95% CPU just to run NES games should be a bit of concern.

    • This reply was modified 2 years, 5 months ago by Profile photo of deaftolight deaftolight.
    • This reply was modified 2 years, 5 months ago by Profile photo of deaftolight deaftolight.
    • This reply was modified 2 years, 5 months ago by Profile photo of deaftolight deaftolight.
    #82815
    Profile photo of deaftolight
    deaftolight
    Participant

    I think it has something to do with the resolution on my TV. If I force VGA by uncommenting hdmi_mode=1 in /boot/config.txt, the NES games run full speed again. However, this makes emualtionstation look awful. I thought runcommand.sh was supposed to take care of this!

    Unforcing VGA, and allowing to display in 1080p, emulationstation looked great, so I tried changing the runcommand.sh parameters in es_systems.cfg
    I tried changing runcommand.sh from 4 to 1, but it did not help. I thought these parameters were supposed to allow us to see ES on our big TVs nicely, and then change the resolution when emulating.

    #84612
    Profile photo of birthdizz
    birthdizz
    Participant

    Similar issues here. I found a good compromise by setting the hdmi_mode to 4 which is 720p I think. Something that I did that might have hurt the experience is commenting out the overclock setting in the /boot/config.txt. I read that by default the RetroPie is OC’d. If that is the case when I switched to 720p I commented that out because I was thinking “oh crap I don’t have a heat sink”.

    #84613
    Profile photo of buzz
    buzz
    Keymaster

    http://www.raspberrypi.org/introducing-turbo-mode-up-to-50-more-performance-for-free/

    We’ve been doing a lot of work to understand the impact of voltage and temperature on lifetime, and are now able to offer a “turbo mode”, which dynamically enables overclock and overvolt under the control of a cpufreq driver, without affecting your warranty. We are happy that the combination of only applying turbo when busy, and limiting turbo when the BCM2835’s internal temperature reaches 85°C, means there will be no measurable reduction in the lifetime of your Raspberry Pi.

    so I wouldn’t worry 🙂

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar