Neo Geo 101 help pls

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 33 replies, has 10 voices, and was last updated by Profile photo of smoothmalik smoothmalik 2 years, 1 month ago.

Viewing 34 posts - 1 through 34 (of 34 total)
  • Author
    Posts
  • #88902
    Profile photo of smoothmalik
    smoothmalik
    Participant

    Ive been playing snes roms fine, however in trying to get a few neogeo roms to even show up in the neogeo screen in retropie seems to be a problem. I have the bios zipped and sitting in the neo geo rom folder along with the roms. Help!

    #88932
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    what emulator you trying to run them on?

    #88941
    Profile photo of smoothmalik
    smoothmalik
    Participant

    I tried putting the roms and bios in the GnGeo-RPi folder once i restart the the pi2 using the 2.6 build the roms aren’t showing up. WHen I add the rom and bios into the regular neogeo folder The roms do show up now in the emulator screen under neogeo.

    #88945
    Profile photo of gingerkanye
    gingerkanye
    Participant

    I’ve been having problems with Neo Geo as well, I keep getting the message “Rom not supported”. I have the bios file in the bios folder and rom folder.

    #88950
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    try using FBA much better neo geo emulation mate, put all roms in that folder with bios, and all should be sweet!

    #88954
    Profile photo of smoothmalik
    smoothmalik
    Participant

    only game ive gotten to work is kof97 …98 nor 2001 will play also the controls are all off how do you config them for neo geo? Im using a ps3 controller thats working fine just not withing the actual neogeo emulators

    #89066
    Profile photo of killer101
    killer101
    Participant

    Talking about arcade and neogeo roms (including neogeo.zip) there are a lot of different sets for different emulators out there. You need the right sets to match the emulator and the version of the emulator. The same old game like with mame roms.

    Where to start? You need to verify the romset against the database according to the emulator. For the fba-libreto core of the 2.6 RetroPie Image it is version 0.2.97.30. Get yourself the database file of this version (for example export it from the windows version of FBA 029730) which you can download from the homepage of Barry Harris.

    After this download a program called RomCenter which can verify and repair sets for a given database. This program is much easier to handle than the good old clrmame.

    When you are done with that, you have the perfect set for this version of fba-libretro and everything should work fine. It does for me!

    • This reply was modified 2 years, 2 months ago by Profile photo of killer101 killer101.
    #89228
    Profile photo of starplatinum81
    starplatinum81
    Participant

    Hi! I’m totally new to this world and I’m waiting for the pi2 to arrive @ home.
    I have a question. With your method with romcenter and a full 0.2.97.34 romset is possible to build A 0.2.97.30 ROMSET?

    How will I change retropie to make fba libreto the default emulator?

    Thank you!

    #89270
    Profile photo of killer101
    killer101
    Participant

    That should work. Both version are not far away from each other, maybe all roms will run out of the box. But see for yourself while running the romset against the database with Romcenter. It can repair a lot of misnamed roms.

    There is no default emulator in Retropie. Just put your Roms in the fba-libretro folder and your mostly good to go. If not, fix the es_config to your needs.

    #89273
    Profile photo of starplatinum81
    starplatinum81
    Participant

    Thanks for your reply! I’ll wait the pi to test the romset!

    #89274
    Profile photo of smoothmalik
    smoothmalik
    Participant

    trying to figure this out is literally like rocket science to me….im a pretty technical guy but this is like so foreign. Ive dealt with roms before and emulators but never neogeo or mame and typically all i had to do was put the roms in a folder and voila they work. Ive downloaded romcenter however on barry harris website I was not able to find any data file for that version of fba. I have downloaded about 5 king of Fighters roms off the internet only one that works right out the gate is kof97 the others state retroacrch failed to load content. I am using the fba libretro folder.

    #89275
    Profile photo of starplatinum81
    starplatinum81
    Participant

    I have this problem also, romcenter doesn’t seem to support database creation from fba.exe, only from mame. Does anyone have a dat file for building 0.2.97.30 romset?

    Thanks!

    #89316
    Profile photo of killer101
    killer101
    Participant

    You can’t download the database from Barry Harris. You need to download the FBA Emulator itself facing the right version (to find somewhere in old releases). Start it up. Somewhere in the menu is a button to extract the database info to a file. RomCenter is able to import this file!

    I know the whole thing sounds complex. But if you invest just a little bit of time you will understand who this works. It is just enough to go with RomCenter. Stay away from clrmamepro, you need a doctors grade to master this one! 😉

    • This reply was modified 2 years, 2 months ago by Profile photo of killer101 killer101.
    #89434
    Profile photo of starplatinum81
    starplatinum81
    Participant

    Thank you! Finally I made it! We need to execute fba.exe and in MISC menu there’s the famous option to extract the database!

    #89436
    Profile photo of smoothmalik
    smoothmalik
    Participant

    so i was only able to find the file for building 0.2.97.34 romset and extract the dat file and load it into romcenter. After doing that just about every rom i have 300+ only 2 work i stopped trying to repair them because none of them were fixed anyway. Im at a deadend here. Also does any neogeo.zip work or is there a certain one that needs to be used.

    #89498
    Profile photo of smoothmalik
    smoothmalik
    Participant

    got a rom fixed in romcenter tested it out and it plays. I copy the zipped rom to the fba-libretro folder and try to play it in retro pi of course it doesnt play…fml

    Attachments:
    #89504
    Profile photo of killer101
    killer101
    Participant

    It can’t be so hard to download the right version?!

    At Barry’s site … FB Alpha … Previous Versions!

    There is all you need …

    I don’t know what Romset do you have, but I can’t believe RomCenter is only able to repair 1 out of 300 roms?!? And yes, the neogeo.zip is also specific to the used emulator!

    Maybe get yourself another romset!

    • This reply was modified 2 years, 2 months ago by Profile photo of killer101 killer101.
    • This reply was modified 2 years, 2 months ago by Profile photo of killer101 killer101.
    #89509
    Profile photo of smoothmalik
    smoothmalik
    Participant

    the 0.2.97.34 is what im using as the .30 is not available on his site. I also will check if im using the corresponding neogeo.zip ive honestly downloaded like 5 diff ones.

    #89511
    Profile photo of killer101
    killer101
    Participant

    Yes it is available … just follow my instructions!

    #89522
    Profile photo of smoothmalik
    smoothmalik
    Participant

    I found the 0.2.97.30 image and exported the data file and loaded it in romcenter. I also downloaded roms and the corresponding bios based off the FB Alpha v0.2.97.31 . loaded everything up in fba in retropie voila everything worked perfectly ( although one rom is unplayable for some reason.)
    killer 101 thanks for the help. If there is anyone else who is struggling like me feel free to ask me anything on the board or through a dm.

    #89528
    Profile photo of killer101
    killer101
    Participant

    After all, welcome to the world of arcade roms! 😉

    As you already noticed, even if the roms perfectly match the emulator, it doesn’t mean that they will always work.

    I tried all 3 R-Type games available for FBA, the only thing I get is a black screen although they perfectly match the emulator version. You have to live with this.

    The alternative was to get the games for mame (completely different romset of course) and they are playable but without sound.

    Luckily R-Type is ported to every known system you can think of! 😉

    #89610
    Profile photo of Floob
    Floob
    Moderator

    This may help with GnGeo. It uses romset 0.138 from MAME

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #90963
    Profile photo of smoothmalik
    smoothmalik
    Participant

    Trying to get this latest unibios working in fba…if anyone can help with the steps on where to but the files etc that would be very helpful….

    #90967
    Profile photo of tipoto
    tipoto
    Participant

    Have you done these steps before trying anything in ES?

    1) You need the unibios 3.1 (easy to find)
    2) Extract the unibios -> you will get a file called ‘uni-bios.rom’
    3) Rename this file to ‘asia-s3.rom’
    4) Use this file to replace the one that has the exact same name inside neogeo.zip (I personally just switch the file names asia-s3.rom <-> uni-bios.rom, that way I keep them both)

    Then you should be good using A+B+C while the splash screen

    #91011
    Profile photo of smoothmalik
    smoothmalik
    Participant

    i unzipped the unibios 3.1 renamed it to the asia-s3.rom
    I unzipped the neogeo.zip
    I placed the renamed asia-s3.rom into the neogeo folder that was created when i unzipped it. I renamed the og asisa-s3.rom to uni-bios.rom
    I zipped the folder and put a copy in the main bios folder and the roms folder of fbi-libretro.

    When the games are about to start and are in the weird color flashing screen I press abc buttons simutaneously nothing happens. I even tried pressing start + the abc buttons as that screen loads, Nothing.

    #91329
    Profile photo of smoothmalik
    smoothmalik
    Participant

    bump… help

    #91632
    Profile photo of depechem70
    depechem70
    Participant

    I have the same problem. MSLUG starts but with missing graphics. Using PI2 2.6.0 Image

    #91633
    Profile photo of smoothmalik
    smoothmalik
    Participant

    The unibios was not enabled in retroach. Once I realized that and enabled it the unibios is now working.

    #91750
    Profile photo of depechem70
    depechem70
    Participant

    How can I enable it?

    #91758
    Profile photo of smoothmalik
    smoothmalik
    Participant

    i dont think missing graphics has anything to do with unibios. Within fba libretro i enabled it in the retroarch settings. For me I press L2 + triangle on the ps2 controller to access that within the emulator. For you the key mapping maybe different.

    #91822
    Profile photo of trixster
    trixster
    Participant

    For people struggling to get mslug3 running and no sound in 4 or 5, read on:

    Mslug3 – rename the zip file to mslug3n.zip. Google “neo geo bios” and download the 1.5MB file linked. Move all the files in this zip into the mslug3n.zip file. Copy the file into your roms directory. It should now work.

    Mslug4 – Google “metal slug 4 (Decrypted C)”. Click the link, download the file. Copy the contents of this zip into your mslug4.zip and then put this back into your roms directory. It should now work.

    Mslug5 – same procedure as 4 but Google for “metal slug 5 (Decrypted C).

    #91937
    Profile photo of smoothmalik
    smoothmalik
    Participant

    Has anyone got KOF 2003 to play? It loads in fba-libretro however the graphics are displaced and not all the imagery loads but the buttons are responsive.

    #91942
    Profile photo of poodull
    poodull
    Participant

    test

    #91948
    Profile photo of smoothmalik
    smoothmalik
    Participant

    what?

Viewing 34 posts - 1 through 34 (of 34 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar