Need help running roms off a thumbdrive

Home Forums RetroPie Project Everything else related to the RetroPie Project Need help running roms off a thumbdrive

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 9 replies, has 5 voices, and was last updated by Profile photo of meneerjansen meneerjansen 1 year, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #119808
    Profile photo of nugg
    nugg
    Participant

    Sorry if this has already been covered, but I couldn’t find the answers I was searching for. I have a 128 gig thumbdrive I planned on using to stores roms. When I was running tests on the thumbstick at the command prompt it would show up then not show up. It was acting as if the PI couldnt handle it.

    I followed this tutorial:

    How to load ROMs from a USB drive on RetroPie 3

    I wasn’t sure if maybe it was the size of the drive that’s a problem, or possibly an update made it not work.

    #119834
    Profile photo of meneerjansen
    meneerjansen
    Participant

    First thing to make absolutely sure it that your Pi is not under powered. Very strange things happen if the peripherals that are connected to your Pi do not get enough power. Use a powered USB hub and make sure your Pi is connected w/ a 5 Volt 2 Ampère adapter.

    Then check if Linux “sees” the USB disk w/ the command:

    df -h
    (meaning: disk free in human readable format, i.e. GB, MB instead of just bytes). Linux can read almost any file system format: ntfs, ext2/3/4, hfs, fat, fat32, etc. etc. So the Pi is probably able to “handle” it.

    Succes!

    #120043
    Profile photo of nugg
    nugg
    Participant

    Thanks! I’ll try it and see.

    #120045
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    better to be in ext4, tho

    #120051
    Profile photo of shoothere
    shoothere
    Participant

    To quickly add a question to this thread:

    I use my USB3 Stick formatted as FAT32 and I find the performance to be rather poor (1.5mbyte per second) as opposed to the internal SD (8 to 10mbyte per second) when transferring files.

    I could imagine it being a BIT slower but even when reading games I notice that, for example, PS1 titles just take that little longer to load (the transitions in Symphony of the Night being most notable).

    Is it because it is formatted as FAT32 and would formatting it as ext4 work better?
    Am I missing something?

    • This reply was modified 1 year, 2 months ago by Profile photo of shoothere shoothere.
    #120086
    Profile photo of meneerjansen
    meneerjansen
    Participant

    To quickly add a question to this thread:

    I use my USB3 Stick formatted as FAT32 and I find the performance to be rather poor (1.5mbyte per second) as opposed to the internal SD (8 to 10mbyte per second) when transferring files.

    I could imagine it being a BIT slower but even when reading games I notice that, for example, PS1 titles just take that little longer to load (the transitions in Symphony of the Night being most notable).

    Is it because it is formatted as FAT32 and would formatting it as ext4 work better?
    Am I missing something?

    I’m no hardware or file system expert, but I don’t think formatting your drive to another file system would greatly improve speed. The thumbdrive might be of another “class” than the SD card you have (may very old USB thumbsticks be compared to class 2 SD cards?). Power might be the issue too. I can hardly transfer files via WiFi to my Pi but I know that the dongle is not thát bad. Also, everybody always advises to use a powered USB hub when connecting peripherals. That’s not for nothing I think…

    #120088
    Profile photo of shoothere
    shoothere
    Participant

    All your points are valid, I did not expect ext4 to make a big difference but thought I’d ask.

    I wouldn’t expect the USB power to be a problem either but would love some feedback if that is the case.

    #120101
    Profile photo of joyrider3774
    joyrider3774
    Participant

    i’m not certain if it’s valid for usb thumbdrives but there is a setting that you can place in config.txt to give the usb ports their maximum current (1200 instead of 600 i think it was) the setting is the following : max_usb_current=1

    i had some problems with harddisk (not thumbdrives) that did not get enough power to boot up or stay booted up that setting “can” help. Also a good power supply is especially needed.

    on side note i’m currently using my old ps3 phat 80 drive in an enclosure with my pi and that setting is not needed with this drive it was with 2 other drives i tried.

    not sure if it would make a diffrence though but you could try it once.

    Also watch out if you overclock and enable that setting it might be your pi becomes unstable while it was not before without that setting. Have read some issues about this but could be it’s a powering problem as well then.

    #120105
    Profile photo of shoothere
    shoothere
    Participant

    I am not thinking of overclocking. I like to work within the boundaries of the “Vanilla Pi3” but the max_usb_current=1 will not void warranty right?

    The USB stick works as one would expect, it mounts and everything it is just very slow (currently copying a PSX .pbp file at 1.8mbyte per second) while I am sure the internal SD could hit 8 to 10.

    I am just curious what causes this. I would expect a Sandisk USB3 stick to not be the bottleneck and that the max USB2 throughput would, if anything, be the culprit.

    #120107
    Profile photo of meneerjansen
    meneerjansen
    Participant

    i’m not certain if it’s valid for usb thumbdrives but there is a setting that you can place in config.txt to give the usb ports their maximum current (1200 instead of 600 i think it was) the setting is the following : max_usb_current=1

    i had some problems with harddisk (not thumbdrives) that did not get enough power to boot up or stay booted up that setting “can” help. Also a good power supply is especially needed.

    on side note i’m currently using my old ps3 phat 80 drive in an enclosure with my pi and that setting is not needed with this drive it was with 2 other drives i tried.

    not sure if it would make a diffrence though but you could try it once.

    Also watch out if you overclock and enable that setting it might be your pi becomes unstable while it was not before without that setting. Have read some issues about this but could be it’s a powering problem as well then.

    Thanks for the usb power tip! I own a Pi 1B and this was introduces w/ the B+ (link), but it might solve some probs for certain people. 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar