N64 (lr) – set individual videoplugin for roms

Home Forums RetroPie Project New to RetroPie? Start Here! N64 (lr) – set individual videoplugin for roms

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 13 replies, has 4 voices, and was last updated by Profile photo of gizmo98 gizmo98 1 year, 2 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #115127
    Profile photo of maketheworldbetter
    maketheworldbetter
    Participant

    hi,
    I’ve read weeks ago, that it now is possible to set individual videoplugins for every rom with N64-lr-core…but how?

    Where do I find informations how to do that?

    #115167
    Profile photo of herbfargus
    herbfargus
    Moderator
    #115183
    Profile photo of gizmo98
    gizmo98
    Participant

    In lr-mupen64plus there is a core option for video plugins. Don’t expect to much. gles2n64 is broken since last june and glide shows a black screen.

    #115241
    Profile photo of maketheworldbetter
    maketheworldbetter
    Participant

    A black screen is everything I got with the lr-n64-emu since months, whichever rom I took 🙁
    However, IÂŽll now try to fix that with some different settings.

    #115273
    Profile photo of dankcushions
    dankcushions
    Participant

    why not use the non-libretro version? it works much better and it’s easy to use a specific video plugin with the runcommand. i think it’s the default on current versions of retropie

    #115649
    Profile photo of maketheworldbetter
    maketheworldbetter
    Participant

    Because Mario is the only game I get to work with non-lr! Both Zelda have much graphical probs and are unplayable, whatever I set. And Mario hast (lightning-)glitches, too – but runs fast and works.

    I hoped that the lr maybe works better….furthermore I hate it to use x different systems….lr here, standalone-emu there….but as said, I never will understand whats Retropies focus is on – to me here is a LOT (!) of disorder 🙂 (sorry to say that, but I am a german piefke)

    #115651
    Profile photo of maketheworldbetter
    maketheworldbetter
    Participant

    Btw, I still dont get it how this should work :’D

    – I can’t find any information how to change that mode through the runcommand in the mentioned link above or in the wiki…….is it point 9, edit custom Retroarch-config? There is nothing inside, empty….what do I need to enter? Where in the wiki do I find any information about changing this?

    #115664
    Profile photo of gizmo98
    gizmo98
    Participant

    Hi Micha,

    der normale “standalone” N64 Emulator sollte immer funktionieren. Die ROMs mĂŒssen entpackt sein, andernfalls bricht der Emulator direkt ab. Die beste KompatibilitĂ€t erreicht man mit dem GLideN64 plugin. Dieses Plugin lĂ€uft nur zufriedenstellend, wenn man die Auflösung auf 640×480/VGA begrenzt.

    Wenn du ein Spiel startest kannst du fĂŒr eine Sekunde auf der Tastatur “x” oder “m” drĂŒcken. Dann erscheint ein AuswahlmenĂŒ der möglichen Emulatoren und Auflösungen.

    Wie du schon festgestellt hast lĂ€uft der Libretro Core nicht so gut. Deshalb werden mehrere Optionen angeboten. Das gilt auch bei anderen Systemen. Ein Emulator lĂ€uft schneller, ein anderer Emulator unterstĂŒtzt mehr Spiele. WĂŒrden wir nicht mehrere Emulatoren anbieten wĂ€re die Auswahl der “spielbaren” ROMs beschrĂ€nkt(er).

    Gruß
    gizmo

    #115827
    Profile photo of maketheworldbetter
    maketheworldbetter
    Participant

    Ganz genau, da kommt dann dieses Runcommand-MenĂŒ, wo ich die Auflösung usw verstellen kann – siehe Link oben das Bild – nur kann ich da nirgends zwischen Glide usw usf umstellen………….

    #115930
    Profile photo of gizmo98
    gizmo98
    Participant

    Die Plugins sind bei RetroPie 3.3 (und wahrscheinlich auch 3.4) auf jeden Fall unter Punkt 1 zu finden:
    -lr-mupen64plus
    -mupen64plus-rice
    -mupen64plus-glesn64
    -mupen64plus-GLideN64

    Video plugins von lr-mupen64plus lassen sich am einfachsten ĂŒber RGUI (Retroarch Ingame MenĂŒ -> select+x) Ă€ndern.

    Handelt es sich um eine aktualisierte oder neue Installation?

    #116090
    Profile photo of maketheworldbetter
    maketheworldbetter
    Participant

    Ja DAS ist da zu finden…aber geht das nicht schon seit Ewigkeiten?
    Ich meine im Changelog oder den News hier nach Version 3.0 (ich glaub 3.2 oder so?) gelesen zu haben, es wĂ€re jetzt möglich, speziell fĂŒr den lr(!)-n64-core fĂŒr jedes Rom auch einen individuellen Renderer festzulegen – oder irre ich mich da?

    Die Frage die ich mir stelle ist – wie stelle ich das fĂŒr den lr-Core (!) fĂŒr jedes Rom individuell ein! Andernfalls – wenn ich das nicht (vorm Start eines Roms) fĂŒr den lr-64-core umstellen kann – ist der lr-N64-core doch irgendwie…nutzlos

    #116095
    Profile photo of gizmo98
    gizmo98
    Participant

    FĂŒr lr-mupen64plus geht das definitiv nicht. Da im Moment nur rice funktioniert lohnt sich die Implementierung einer solchen Funktion aktuell auch nicht.

    #116670
    Profile photo of maketheworldbetter
    maketheworldbetter
    Participant

    Schade. Und wie stelle ich den generell fĂŒr den lrN64-core vor dem Start eines Roms ein? Muss doch da auch unterschiede – Rice, Gles, Glide – geben…kann doch nicht sein, das ich damit nicht ein einziges Spiel zum laufen bekomme?!

    #116701
    Profile photo of gizmo98
    gizmo98
    Participant

    Wenn du ein Spiel startest Select+X drĂŒcken. Unter “Quick Settings” gibt es den Punkt “Core Options”. Dort kann man dann ein Video Plugin einstellen.

    Es ist wohl seltsam, dass der normale Emulator nicht funktioniert.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar