N64 Fails to Launch any ROM

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of zer0cool zer0cool 2 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #16707
    Profile photo of zer0cool
    zer0cool
    Participant

    Hello all. Im new just setup my pi last night. Got wifi/ssh working and xbox360 controller. Moved some roms to it for nes,snes,gbc,gba,n64, and psx. All work except n64.

    Any time i go to start a ROM for n64 the screen goes black for a few seconds, then back to command line briefly, then back to ES.

    I have a model B, 256 RAM split, no OC. I installed using the source option which took a long time. Currently connected are mouse/kb, 1x xbox360 controller, wifi dongle. HDMI to a HDTV.

    Ive tried Mario Cart, Super Smash Bros, Goldeneye, Perfect Dark. All behave the same way.

    Strange as the psx emulator seems to work fine which i thought would be a bigger issue.

    Any help/advice to troubleshoot this would be great. Not sure if there is a log file or a way to pause the screen before ES reloads. Thanks

    #16731
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    mate at the moment the n64 is very touch n go, especially with the include emulator, there are tests being done on a newer version and it looks pretty cool! but as I said we may never have the pleasure of running every rom flawlessly I’m afraid to say, but hang in there

    Sent from my iPhone using Tapatalk

    #16958
    Profile photo of waddupbeazt
    waddupbeazt
    Participant

    Hi zer0cool,

    I got the exact same issue as you do with those games at the N64 emu.

    Quick question tho. How did you get your xbox360 controller to work right away?
    The only one I got working is GBA, would be awesome if you could share your SNES and PSX retroarch config!

    BR,
    WaddupB

    #17058
    Profile photo of zer0cool
    zer0cool
    Participant

    TBH this is all very new to me. I have limited experience with Linux (Ubuntu) and less with emulators.

    I recall there being an option in setup (retropie setup, maybe raspi-config) to install xbox360 driver so i did that. Then i went to configure retroarch controller in the setup and followed the prompts (press this button, press that button), rebooted and it works in all of my emulators so far. No cmd line stuff or config files to manually edit.

    Still having this issue with the N64 emulator. trying to collect info from the console text as to why it opens and then shuts down. May play with config file for it.

    If you need more info about controller setup PM me and ill either start another thread or talk to you about it in PM

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar