N64 controller issue with NES30 (8Bitdo)

Home Forums RetroPie Project Everything else related to the RetroPie Project N64 controller issue with NES30 (8Bitdo)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of puck6t9 puck6t9 2 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #93203
    Profile photo of nbk7
    nbk7
    Participant

    Hi all,

    I ve managed to make my two NES30 controllers (8bitdo) work with NES, SNES and Amiga emulators but I’m really struggling to make it work with mupen64plus.

    Via lr-mupen64plus:
    Aside from the messed up menu e.g. in MarioKart64 it seems like its at least partly using the retroarch.cfg file. During start it shows the correct controller in yellow letters and I m able to go ‘left/right/up/down’ in the menus, go backwards with ‘B’ and choose a setting via ‘A’. Also the combination “select start” finishes a game. But surprisingly while playing the game I cant move to the left/right/up/down anymore. Only the ‘input_r_btn’, ‘start’ and ‘A’ seems to have an effect here.

    Via gles2N64
    Most important for me is to get gles2N64 running because It works better with MarioKart64 – but here I don’t even have any controls at all. Not a single button is working 🙁

    MY 8BitdoNES30GamePad.cfg under /opt/retropie/emulators/retroarch/configs looks like this:

    input_device = “8Bitdo NES30 GamePad”
    input_driver = “udev”
    input_b_btn = “12”
    input_y_btn = “15”
    input_select_btn = “21”
    input_start_btn = “22”
    input_up_btn = “0”
    input_down_btn = “5”
    input_left_btn = “2”
    input_right_btn = “3”
    input_a_btn = “11”
    input_x_btn = “14”
    input_l_btn = “17”
    input_r_btn = “18”

    input_enable_hotkey_btn = “21”
    input_exit_emulator_btn = “22”
    input_menu_toggle_btn = “14”
    input_load_state_btn = “17”
    input_save_state_btn = “18”
    input_reset_btn = “12”
    input_state_slot_increase_btn = “3”
    input_state_slot_decrease_btn = “2”

    I adjusted the InputAutoCfg.ini like this just to see if it would have any effect on the control (but to no avail):

    [8BITDO NES30]
    plugged = True
    plugin = 2
    mouse = False
    DPad R = key(3)
    DPad L = key(2)
    DPad D = key(5)
    DPad U = key(0)
    Start = key(22)
    Z Trig = key(21)
    B Button = key(12)
    A Button = key(11)
    C Button R = key(3)
    C Button L = key(2)
    C Button D = key(5)
    C Button U = key(0)
    R Trig = key(99)
    L Trig = key(120)
    Mempak switch = key(44)
    Rumblepak switch = key(46)
    X Axis = key(276,275)
    Y Axis = key(273,274)

    Also I tried to transfer the values to mupen64plus.cfg – also didnt work out. Any suggestions would be highly apprechiated 🙂

    • This topic was modified 2 years ago by Profile photo of nbk7 nbk7.

    #95041
    Profile photo of puck6t9
    puck6t9
    Participant

    try it like this. Worked with my game pad

    [8Bitdo NES30 GamePad]
    plugged = True
    plugin = 2
    mouse = False
    DPad R = 3
    DPad L = 2
    DPad D = 5
    DPad U = 0
    Start = 22
    Z Trig = 21
    B Button = 12

    and so on.. i had to put the name of the device the same way retropie sees it for it to auto config. for expaple here is mine

    [Jess Tech GGE909 PC Recoil Pad]
    plugged = True
    plugin = 2
    mouse = False
    AnalogDeadzone = 4096,4096
    AnalogPeak = 32768,32768
    DPad R = hat(0 Right)
    DPad L = hat(0 Left)
    DPad D = hat(0 Down)
    DPad U = hat(0 Up)
    Start = button(9)
    Z Trig = button(7)
    B Button = button(0)
    A Button = button(2)
    C Button R = axis(3+)
    C Button L = axis(3-)
    C Button D = axis(2+)
    C Button U = axis(2-)
    R Trig = button(6)
    L Trig = button(4)
    Mempak switch =
    Rumblepak switch =
    X Axis = axis(0-,0+)
    Y Axis = axis(1-,1+)

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar