MSX Input Issues

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: 

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of milcomhd milcomhd 1 year, 3 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #113296
    Profile photo of milcomhd
    milcomhd
    Participant

    Hello all,

    So, I’m fairly new at Linux and I haven’t been able to figure out an answer to this anywhere. When I enter an MSX emulation under both bluemsx and fmsx I have input issues. I use the iBuffalo SNES controller, and the buttons only work for bluemsx. However, the only commands that I can use are A and B. I’ve more or less given up trying to make the controller work, but the keyboard still gives me problems.

    For fmsx, the only commands I can do are the menu options which are f1-f4 (In the game I’m trying to play) and the directional keys to move. On bluemsx I’ve had a little bit more luck. When the emulator boots up I can only press letter commands, like punch and crouch (z and x respectively), and I can move. I then can go into the RGUI to change the user input option from retropad to retrokeyboard, enter back into the game, and I can only use the menu buttons. Obviously this fix isn’t all that great, because it gets annoying to go into the RGUI every time I need to press keys f1-f4 and then switch back afterwards to use letter keys.

    Is this a problem that can be fixed? Is it widespread, or does it only occur with just a few devices? Thank you all for your time! By the way, my Pi-2 is running Retropie v. 3.2.1. Thanks for the help!

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar