Moving save state location

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 12 replies, has 3 voices, and was last updated by Profile photo of oleguer oleguer 1 year, 5 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #109406
    Profile photo of atimmins
    atimmins
    Participant

    Is there a way to change the location of where saves states are located? I am trying to moves save files to a network drive so that I can have multiple raspberry pis and I can save a game on one and then boot up another and start where I left off. I have the network drive mounted, but I can’t figure out how to tell Retropie to look in the new location for previous save files or save new files in the new location.

    I tried changing the savestate_directory and savefile_directory lines at /opt/retropie/configs/all/retroarch.cfg without success. I also tried pasting those lines in the system retroarch.cfg files with no luck. Is there another file that is telling it where to look for save files? Thanks.

    #109412
    Profile photo of Floob
    Floob
    Moderator

    That should be it.
    When you are in game, and save – there should be yellow text along the bottom of the screen – that should show any success or error.
    What does it say for you?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109423
    Profile photo of atimmins
    atimmins
    Participant

    When I save a game it saves to the old location as it used to. When I try to load a save state it gives an error saying it can’t find the save file in the old location (because I moved all the save files to the new location).

    #109434
    Profile photo of Floob
    Floob
    Moderator

    Can you post your /opt/retropie/configs/all/retroarch.cfg on pastebin so we can check it?
    Make sure there isnt a reference to it in the system specific retroarch – unless you want to do it on a per system basis.

    Can you see the full message when it tries to load – does it have a number at the end?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109445
    Profile photo of atimmins
    atimmins
    Participant

    Here is the relevant section of the config file (if you need other sections please let me know):

    # Save all save files (*.srm) to this directory. This includes related files like .bsv, .rtc, .psrm, etc …
    # This will be overridden by explicit command line options.
    savefile_directory = /home/pi/RetroPie/saves

    # Save all save states (*.state) to this directory.
    # This will be overridden by explicit command line options.
    savestate_directory = /home/pi/RetroPie/saves

    The message I get when I try to load a save state is :

    Failed to load state from “/home/pi/RetroPie/roms/nes/Contra.state”.

    As you can see, it is still trying to find the save state file in the default location, but it is unable since I moved them all over to /home/pi/RetroPie/saves. I suspect that if I copied the save file and pasted it back in the default location it would work fine. Does it not allow roms and save files to be stored in different folders?

    #109448
    Profile photo of Floob
    Floob
    Moderator

    I just gave this a go on a clean build of 3.2.1 and it seems to work fine.

    Here is my retroarch.cfg – I have changed the paths to match yours but thats it.
    http://pastebin.com/raw.php?i=m8svaJGH

    Here is the output to show permissions.

    pi@retropie ~/RetroPie $ ls -lah
    total 24K
    drwxr-xr-x  6 pi pi 4.0K Nov  9 02:01 .
    drwxr-xr-x  6 pi pi 4.0K Nov  1 16:46 ..
    drwxr-xr-x  4 pi pi 4.0K Oct 28 22:01 BIOS
    drwxr-xr-x  2 pi pi 4.0K Oct  6 15:10 retropiemenu
    drwxr-xr-x 47 pi pi 4.0K Oct  6 15:09 roms
    drwxr-xr-x  2 pi pi 4.0K Nov  9 02:02 saves

    Have you overridden it in the system retroarch.cfg or perhaps you created the saves folder as root?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109518
    Profile photo of atimmins
    atimmins
    Participant

    Okay so I started over with a backup and was able to change the save directory to a new raspberry pi folder. However, once I turned that new folder to a network folder on my windows computer, it gave me the same error messages as before. Were you able to make it work with a network folder on another computer? What does your /etc/fstab file look like?

    • This reply was modified 1 year, 5 months ago by Profile photo of atimmins atimmins.
    #109702
    Profile photo of atimmins
    atimmins
    Participant

    Anyone have an idea? I am surely not the first person to try this.

    #109775
    Profile photo of Floob
    Floob
    Moderator

    Does user “pi” have write access to the mounted dir? What happens if you SSH in and create a file in that location?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #109813
    Profile photo of atimmins
    atimmins
    Participant

    I thought so, but I could be wrong. I am only able to modify the etc/fstab file with root status, so I don’t know if that is messing things up.

    #109980
    Profile photo of oleguer
    oleguer
    Participant

    I think atimmins you need have root permisions for save and load try this…. edit the fstab on etc/fstab Only add this
    If you try to move to one internal partition:
    /dev/mmcblk0p2 / ext4 auto,users,rw,uid=pi,gid=pi 0 1
    The partition of memory Mount Point Format Permisions (I dont know really)
    When you use usb stick mounted:
    UUID=1ADF-0D47 /mnt/usb1 vfat auto,users,rw,uid=pi,gid=pi 0 0
    My usb stick Mount Point Format Permisions (I dont know really)
    The “only” think you need is take the root permisions for pi default user This is work for me…. You try! And lucky! Thanks and sorry for bad english 😉

    #110086
    Profile photo of atimmins
    atimmins
    Participant

    I have given up on this. It was a nice idea but I can’t make it work. I can successfully mount a windows folder and I can add files to the windows side and see them show up on the pi and add files on the pi and see them show up on windows, but RetroPie seems to have a problem moving the save locations to a network folder. I can move the save location to another folder on the sd card fine, but if I try to move it to a different computer on the network it defaults back to the original save location and won’t look in the network folder despite changes to the opt/retropie/configs/all/retroarch.cfg file.

    Perhaps this is something that can be ironed out for future versions of RetroPie.

    #110097
    Profile photo of oleguer
    oleguer
    Participant

    You can! Try using WINSCP to acess to raspberry pi files if you can use wifi….or use the terminal (connect keyboard to usb port and press F4 to open terminal) and edit them with sudo nano /etc/fstab add the permisions to fstab and lucky!

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar