MK ARCADE JOYSTICK RPI

Home Forums RetroPie Project GPIO Adapter, ControlBlock etc. MK ARCADE JOYSTICK RPI

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of devil78 devil78 1 year, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #98771
    Profile photo of devil78
    devil78
    Participant

    Hello everyone, I open this topic to try to configure my GPIO controller built following this guide:

    mk arcade joystick rpi

    the controller is working properly EmulationStation that, in fact, detects two controllers. The device is composed of two Joystick 14 and buttons (8 per player) configured according to the diagram map = 1.2 as described in the guide. Despite EmulatorStation recognizes the device without problems Retroarch does not want to recognize it. It ‘very frustrating configure any emulator for each correctly recognizes the device.

    A similar problem occurs with the volume of retroarch. There is not much difference between the volume of video that I created for the boot but despite open the file /opt/retropie/emulators/retroarch/bin/ retroarch and imposed the volume to + 6, I find that the value is reset each Start a single emulator.

    My question is, at this point, there is a way to configure retroarch apply globally for the settings for all emulators? Thank you all!

    Picab Multi Emulator - Rasperry pi 2 - Retropie - Arcade Cabinet

    • This topic was modified 1 year, 11 months ago by Profile photo of devil78 devil78.

    #98775
    Profile photo of Floob
    Floob
    Moderator

    The global retroarch.cfg is at:
    /opt/retropie/configs/all/retroarch.cfg

    Check this section

    # Audio volume. Volume is expressed in dB.
    # 0 dB is normal volume. No gain will be applied.
    # Gain can be controlled in runtime with input_volume_up/input_volume_down.
    # audio_volume = 0.0

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #117299
    Profile photo of devil78
    devil78
    Participant

    Hey Floob, thanks for the answer i solved my problems with retroarch… 🙂

    Picab Multi Emulator - Rasperry pi 2 - Retropie - Arcade Cabinet

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar