Missing libretro emulators on RetroPie 3.0?

Home Forums RetroPie Project New to RetroPie? Start Here! Missing libretro emulators on RetroPie 3.0?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 13 replies, has 4 voices, and was last updated by Profile photo of smithers smithers 1 year, 7 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #105643
    Profile photo of fakeuser
    fakeuser
    Participant

    Hi all,

    I’m new to the RetroPie world.

    I been investigating the rebuilding process wit clrmame and I am specially interested on romset used by lr-mame2010 but after the rebuilding process… I noticed that nor /opt/retropie/libretrocores/lr-mame2010 neither /opt/retropie/configs/mame-libretro/retroarch.cfg exists… is that OK? The roms directory is also missing, I know that I can create that but is everything OK? since binanies and configurations for libretro seems to be missing.

    Thanks in advance and nice work!

    #105645
    Profile photo of buzz
    buzz
    Keymaster

    It probably failed to build. It was only added the other day, and although it builds fine for me and herbfargus, it didn’t build for someone else.

    Check the logfile and see what the problem is.

    #105650
    Profile photo of fakeuser
    fakeuser
    Participant

    Thanks for the quick answer, I will check the build log.

    Correct me if I am wrong because I made multiple tests and I dont remember the process exactly… I used the SD card image. Does this also has a build process? I though that the build is only related with the setup script.

    #105651
    Profile photo of buzz
    buzz
    Keymaster

    Not sure what you are asking sorry.

    #105654
    Profile photo of fakeuser
    fakeuser
    Participant

    Sorry for my english 🙁

    I mean that since I used the SD image there is no build process suitable to fail since, as far as I understand, everything is “pre built” when using this method, right?

    Thanks!

    #105657
    Profile photo of buzz
    buzz
    Keymaster

    Nope – items in the experimental menu do not come with prebuilt binaries so require building.

    #105658
    Profile photo of buzz
    buzz
    Keymaster

    I’m getting the feeling you perhaps didn’t build it – but thought it would be preinstalled? It is only available in experimental for now.

    #105660
    Profile photo of fakeuser
    fakeuser
    Participant

    Yes… that is my problem indeed.

    I checked the documentation a ton of times and I didn’t find any clue about what I was doing wrong.

    Thanks for the help!

    #105696
    Profile photo of fakeuser
    fakeuser
    Participant

    Ok… I am still missing something

    There is no retroarch package or lr-mame2010 package on the experimental option from the setup script. I’ve installed retroach from “Install individual emulators” option instead but the files and directories I’ve mentioned on my first post are still missing. What is the exact option to install lr-mame2010?

    Regards!

    • This reply was modified 1 year, 7 months ago by Profile photo of fakeuser fakeuser.
    #105700
    Profile photo of herbfargus
    herbfargus
    Moderator

    This explains how to install new emulators. If you don’t have a rpi2 then its doubtful you’ll get favourable results.

    #105708
    Profile photo of fakeuser
    fakeuser
    Participant

    Thanks herbfargus,

    I’ve executed the script previously, I am just asking where is the option to install lr-mame2010 emulator because I am not able to find it under “Experimental” section as @buzz suggested.

    • This reply was modified 1 year, 7 months ago by Profile photo of fakeuser fakeuser.
    #105711
    Profile photo of buzz
    buzz
    Keymaster

    then you probably didn’t update the retropie-setup script first.

    #105731
    Profile photo of fakeuser
    fakeuser
    Participant

    Oh damn… I’m so sorry 🙁

    I was 100% sure that I executed the update script option before. Now… the option are there, inside the experimental option as you poited previously.

    Thanks for the patience

    #105772
    Profile photo of smithers
    smithers
    Participant

    It takes a lonnnnggg time to compile however its working great at my end – was a nice surprise, along with Mame 0.78 and lr-FBA-Next!

    All the best.
    Steve

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar