minecraft-pi anyone got this working in retropie?

Home Forums RetroPie Project Everything else related to the RetroPie Project minecraft-pi anyone got this working in retropie?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 26 replies, has 10 voices, and was last updated by Profile photo of herbfargus herbfargus 2 years ago.

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #5256
    Profile photo of wrichards
    wrichards
    Participant

    I have it up and running in raspian windows, but would like to add it to the retropie menus… is this made for the raspian windows environment? or can it be added like I added quake3?

    #5318
    Profile photo of karloss
    karloss
    Participant

    I would have thought, if u can get it to compile and work, then it should be ok, though I think it only works in X and retro is setup to run from command line

    Sent from my Nexus 5 using Tapatalk

    #5323
    Profile photo of wrichards
    wrichards
    Participant

    Thanks for the response, I figured it was a window environment olny…. sad

    #82523
    Profile photo of ceuse
    ceuse
    Participant

    so no way to get this to work within emulationstation? sad 🙁

    #82524
    Profile photo of gizmo98
    gizmo98
    Participant

    Should be possible. Are there installation instructions or sources?

    #82532
    Profile photo of ceuse
    ceuse
    Participant

    only the offical one wich reads :

    Daniel Frisk has provided the following instructions on how to get started.

    Minecraft – Pi Edition runs on Raspbian “wheezy” with XWindows. If you need to set that up, visit http://www.raspberrypi.org/downloads and follow the detailed instructions within.
    Boot up your Raspberry Pi with Raspbian. If you haven’t set XWindows to start automatically upon boot, type in “startx”.
    Next click the icon for LXTerminal to open a new terminal window. Use the following commands (in bold) to download and launch:

    To download it: click here or visit https://s3.amazonaws.com/assets.minecraft.net/pi/minecraft-pi-0.1.1.tar.gz
    To decompress it: tar -zxvf minecraft-pi-0.1.1.tar.gz
    To run it: cd mcpi
    Followed by minecraft-pi

    #82572
    Profile photo of blue-dragon360
    blue-dragon360
    Participant

    I’m not sure on this, but I believe that Minecraft relies on the X-Window thing to listen for keyboard/mouse inputs. So I don’t think it will work to add it directly to the emulationstation menu.

    However, you can do what I did, set up a new emulator in RetroPie/roms/Raspbian/ and put in that a rom called “Start Raspbian.sh” which has these contents:

    
    #!/bash/bin
    startx
    

    Then you can navigate to /etc/emulationstation/es_systems.cfg, and add a new entry at the bottom named “Raspbian”, and put in the correct path to the emulator file, as well as setting <extension> to “.sh .SH”. Then, if done correctly, you can launch raspbian desktop from the emulationstation menu. Just not minecraft itself. 🙂

    #82662
    Profile photo of
    Anonymous

    I’m not sure on this, but I believe that Minecraft relies on the X-Window thing to listen for keyboard/mouse inputs. So I don’t think it will work to add it directly to the emulationstation menu.

    However, you can do what I did, set up a new emulator in RetroPie/roms/Raspbian/ and put in that a rom called “Start Raspbian.sh” which has these contents:

    
    #!/bash/bin
    startx
    

    Then you can navigate to /etc/emulationstation/es_systems.cfg, and add a new entry at the bottom named “Raspbian”, and put in the correct path to the emulator file, as well as setting <extension> to “.sh .SH”. Then, if done correctly, you can launch raspbian desktop from the emulationstation menu. Just not minecraft itself. :)

    Re-This couldn’t you very well have a Raspbian desktop pre-loaded with Minecraft (Obviously not ideal but). If you setup Raspbian to start Minecraft up on start-up wouldn’t this ‘In essence’ be starting up Minecraft in a way? Instead of exiting Minecraft you would have to save/logout and exit the OS though. Not sure if it would kick back to ES.

    #82701
    Profile photo of gizmo98
    gizmo98
    Participant
    #82719
    Profile photo of blue-dragon360
    blue-dragon360
    Participant

    That is interesting! Forgot about the xinit command. Too bad there’s no way to do fullscreen though.. I tried messing with it for a bit, but I had no luck. I’d definitely add this to my emulationstation menu if it could fullscreen, though. I wonder if a mod for minecraft pi would be in order?

    #82721
    Profile photo of gizmo98
    gizmo98
    Participant

    Minecraft-Pi seems to have a fixed resolution. So changing the screen resolution with runcommand.sh to for example 720p could be a solution. I will check it out later.

    #82733
    Profile photo of mac2298
    mac2298
    Participant

    Funny thing: I just reset my Pi yesterday so that I could dedicate it to a RetroPie project, and when I started Emulation Station for the first time since restarting I went into ports and lo and behold, there was Minecraft. It wasn’t there before I restarted my Pi… I’m kind of confused as to why it’s there now. Is everyone else seeing Minecraft under ports? If so, I guess I sound like a total noob right now… lol. Anyone got ideas on how to run it?

    #82755
    Profile photo of blue-dragon360
    blue-dragon360
    Participant

    I’m assuming you downloaded a new image? If so, maybe the dev has put it in the image. That’s really the only explanation that makes sense. 🙂 You can probably run it just by selecting it and pressing A/whatever you’ve mapped to your select button? I’m not sure though. Good luck!

    Re. Changing screen resolution: I’m not entirely sure on how runcommand.sh works through es_systems.cfg, but looking through the code it looks like it uses tvservice. I decided I’d go ahead and test some through the command line, but I can’t find a tvservice mode that works. I tried basically every item under the CEA and DMT return of tvservice (tvservice -m “CEA/DMT”) but each either makes minecraft too big for the screen or too small. Is there a way to explicitly state resolution, without having to go through set modes?

    #82756
    Profile photo of gizmo98
    gizmo98
    Participant

    576p is to small and 720p is to big. Someone could ask the minecraft developer to add a fullscreen mode and an exit button –> http://www.minecraftforum.net/forums/other-platforms/minecraft-pi-edition.

    #82776
    Profile photo of blue-dragon360
    blue-dragon360
    Participant

    I kind of doubt that will be happening, sadly. It appears that the MC developer hasn’t worked on it in a while (and I don’t think he will be).

    However, I did find a different option after searching some: There appears to be a mod for minecraft that allows it to go fullscreen for HDTVs. http://www.minecraftforum.net/forums/other-platforms/minecraft-pi-edition/1960005-survival-mode-patch

    I installed it like he recommends, but like another poster further down, it throws an error when trying to run (from desktop or xinit). “Couldn’t create SDL window”. I’ve PM’d the author, hoping to hear back (although somewhat doubtful).

    As for the exit button, I decided just to make a python script that returned the words “Press Alt+Ctr+Backspace to exit!” at the beginning of the game. Crude, I know, but it works 😛

    #82778
    Profile photo of
    Anonymous

    Is there something specific I need to do to get this to pull into my ports section? Do I need to install this manually or just run an update command?

    #82786
    Profile photo of blue-dragon360
    blue-dragon360
    Participant

    Is there something specific I need to do to get this to pull into my ports section? Do I need to install this manually or just run an update command?

    If the update command doesn’t work (I have no idea, kind of doubt it would though) you could create a Minecraft.sh file in your ports emulator folder with these contents:

    
    #!/bin/bash
    xinit /home/pi/mcpi/minecraft-pi
    

    Or wherever you have your minecraft-pi file. Then, just “sudo chmod +x Minecraft.sh”, and it should show up and run in your ports emulator.

    #83740
    Profile photo of mac2298
    mac2298
    Participant

    Sorry I haven’t given an update, and it seems like this thread is dead, but I believe that the dev has added minecraft.sh to the ports section. However, whenever I click on it the game fades out and comes back in. Just interested in seeing if anyone else is still trying to work this out.

    #84088
    Profile photo of biglazyb
    biglazyb
    Participant

    Hi mac2298 — I am working on this. I have minecraft-pi working under retropie. I am still trying to get the controls worked out.

    As a quick how-did-it work so far:

    download the minecraft tarball independent of Retropie 2.3 —
    tar it in /opt/emulators/minecraft
    this will create /opt/emulators/minecraft/rpmc/ that will have the executable
    write a shell script that calls the program using xinit
    Modify es_systems.cfg to call the shell script
    make sure to use the absolute path in all cases, and that your permissions are ok.

    My goal now is to figure out how to map the joypad controls from teensy to simulate the keyboard.

    • This reply was modified 2 years, 3 months ago by Profile photo of biglazyb biglazyb.
    #84118
    Profile photo of mac2298
    mac2298
    Participant

    thanks for that, biglazyb. Unfortunately, I didn’t catch half of what you said. I’m not ultra savvy with all the retropie lingo yet. Still, it sounds like a lot of work that you have to go through to get minecraft to work. What I don’t get is that a while ago, when I tried ES for the first or seccond time, minecraft worked through it, without any hasle. However, I have since wiped my pi clean and started anew, and now it doesn’t work so easily. Any idea why? If this is indeed the only way to get this to work, would you mind taking the time for me to simplify the instructions a bit? Not sure what “tar” is, or how to execute the shell script! Thanks! 🙂

    #84207
    Profile photo of biglazyb
    biglazyb
    Participant

    Hi mac2298,

    No idea on why mc would be in one retropie distribution and not another. I am no expert, but I do know that I have gotten things messed up so bad I had no choice but to re-image the SD card in the pi.

    Apologies for my abbreviated description of the install I did — I will post a clear ‘how-to’ once I get things working correctly.

    #84270
    Profile photo of blue-dragon360
    blue-dragon360
    Participant

    Hello,
    Quick question. You mentioned you got it working, but it looks like all you’re doing is installing it in a different directory (the emulators directory) and linking it on emulationstation. Is this correct? If so, did you figure out a fix for the screen resolution issue that occurs even when running xinit on it from the default install directory?

    Also, if you can figure out the controller mapping that’d be amazing. I have no idea where to start with that 😀

    Thanks for the input!

    #84491
    Profile photo of biglazyb
    biglazyb
    Participant

    Hi blue-dragon360 —

    Your guess is correct, and I still have the xinit screen resolution issue. I haven’t had much time to mess with this, but the controls and the resolution are next on the list.

    I am using a custom Teensy joystick setup. The teensy can be programmed and mapped to either send joypad commands or keyboard commands. Because the Teensy works fine for all the other emulators, I am thinking I may need to re-program the teensy in code to be a keyboard when minecraft starts up, and then reprogram back to a joypad when minecraft closes. (the exit issue also plagues me).

    Lots to do — if I make progress I will post. Everyone have a good 2015!

    • This reply was modified 2 years, 3 months ago by Profile photo of biglazyb biglazyb.
    #93120
    Profile photo of basst
    basst
    Participant

    Minecraft-pi running from EmulationStation:

    #93149
    Profile photo of herbfargus
    herbfargus
    Moderator

    How did you get it full screen? Is it just because your screen is so small? I have a 42 inch 1080 television and it only shows up in the upper left corner. Do you know of any way to make it fullscreen?

    #93223
    Profile photo of basst
    basst
    Participant

    Hi,

    I’m using the “Matchbox” window manager to start Minecraft-Pi fullscreen.
    You can install Matchbox with the following command: sudo apt-get install matchbox

    I’m using this file (startMinecraft.sh) to start Minecraft:

    #!/bin/sh
    xset -dpms  # disable DPMS (Energy Star) features.
    xset s off  # disable screen saver
    xset s noblank  # don't blank the video device
    matchbox-window-manager &
    /opt/retropie/emulators/minecraft/mcpi/minecraft-pi

    And then run it with this command:
    xinit ./startMinecraft.sh

    #93232
    Profile photo of herbfargus
    herbfargus
    Moderator

    Perfect! Thank you so Much! Ok so for anyone else to lay out my steps:

    sudo apt-get install matchbox

    I created a new theme for emulationstation for Minecraft:

    I first created a new folder in the roms folder called minecraft.

    home/pi/RetroPie/roms/minecraft/

    and in the above minecraft folder I created a shell script called

    minecraft.sh

    the contents of this file are:

    #!/bin/sh
    xset -dpms  # disable DPMS (Energy Star) features.
    xset s off  # disable screen saver
    xset s noblank  # don't blank the video device
    matchbox-window-manager &
    /opt/minecraft-pi/minecraft-pi

    it differs a bit from Basst’s cause I’m using the 3.0 Beta image.

    Then I added a section to

    /etc/emulationstation/es_systems.cfg

    <system>
        <name>minecraft</name>
        <fullname>minecraft-pi</fullname>
        <path>~/RetroPie/roms/minecraft</path>
        <extension>.sh .SH</extension>
        <command>xinit /home/pi/RetroPie/roms/minecraft/minecraft.sh</command>
        <platform>minecraft</platform>
        <theme>minecraft</theme>
      </system>

    and last but not least I added a theme folder named minecraft to

    /etc/emulationstation/themes/simple

    This is a link to my minecraft theme folder

    https://www.dropbox.com/s/3z8jfbpgxt9wqsx/minecraft.zip?dl=0

    Hopefully this was useful to someone!

    as a side note: for the menus you’ll want to use a keyboard as the mouse gets a little wonky with the matchbox window.

    Attachments:
Viewing 27 posts - 1 through 27 (of 27 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar