Mapping PS3 buttons in AdvanceMame 1.2 / RetroPie 3.0

Home Forums RetroPie Project Everything else related to the RetroPie Project Mapping PS3 buttons in AdvanceMame 1.2 / RetroPie 3.0

RetroPie has a new website and forum. Please visit for the new site. The new forum is located at This forum is left here as a read-only archive.

This topic contains 10 replies, has 9 voices, and was last updated by Profile photo of qwerty69 qwerty69 1 year, 3 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #93763

    Hello All,

    Has anyone had any luck mapping the PS3 buttons (triangle, circle, or X) in AdvanceMame 1.2?

    I can only seem to get the square button to be recognized. After updating the advmame-1.2.rc file multiple times I’ve figured out a bit but it would appear that the triangle, circle, and X buttons cannot be mapped.

    For those interested, utilizing the AdvanceMame [joy,button] scheme and assuming all below are set for joy = 0, here are the mappings I’ve determined for “button” per my PS3 controller via bluetooth setup:

    top or 3 = start
    top2 or 4 = d-pad up
    trigger or 0 = select
    thumb or 1 = L3
    thumb2 or 2 = R3
    pinkie or 5 = d-pad right
    base or 6 = d-pad down
    base2 or 7 = d-pad left
    base3 or 8 = L2
    base4 or 9 = R2
    base5 or 10 = L1
    base6 or 11 = R1
    12 = square

    Any insight into this problem would be greatly appreciated.


    Profile photo of Floob

    I’ve only used AdvanceMAME a bit, but its seems quite happy to map inputs using the GUI when it runs (via TAB). Have you tried that?

    RetroPie help guides -->
    Please read this before asking for help -->



    Yes, you are correct. AdvanceMAME does seem quite happy to map buttons utilizing the GUI with TAB except that it will not recognize the triangle, circle, or X there either. This is what originally caused me to seek out another means, i.e. the rc file.


    Profile photo of bitsentry

    Yep, I have the exact same problem. Haven’t had much time to troubleshoot but it seems that certain buttons aren’t mappable from the GUI with AdvanceMAME. The ones it does map it gives weird names like “top” for the start button or “trigger” for the select button. Basically exactly what the OP posted.

    It also seems to inadvertently pick up inputs from the PS3 controller’s motion sensors and tries to map them as axis.

    Using PS3 controller over bluetooth. All other emulators work fine.
    Pi2 and RetroPie 3.0 beta 2.

    Profile photo of poplekiller


    Don’t ask me why but it seems that buttons 12, 13, 14, 15 are ok for the PS3 wireless driver.
    It doesn’t match anything in jstest and I don’t find advj (the utility supposed to be with advancemame) to test the joy

    Profile photo of poplekiller

    hum, i wrote too quickly, only square is working … oddly, I got some of the cross (left up) buttons to quick in SF II, I will check how it look in the UI config

    Profile photo of dischargehammer

    I have the same problem. Triangle, square and circle are not responding. Other buttons and triggers work, but give weird mapping names like “dead” or “top2”. Could this probably be circumvented by configuring controls with a .cfg file ?

    Profile photo of blewis87

    Change device_joystick auto to device_joystick raw in the .rc config file.

    Then, all the buttons will show up.

    You’re welcome! (I created an account just to spread the good news!)

    Profile photo of robertus

    i can’t configure my ps3 controller, recognize only select and analog to up down ad press.

    why ? i tried to modified auto in raw on \\RETROPIE\configs\mame-advmame\advmame-0.94.0.rc without success

    Profile photo of dudleydes

    I have managed to get all of the buttons on PS3 controller recognised by changing device_joystick auto to device_joystick sdl in the .rc config files. The buttons will now be mapped to a more familiar j:button15 format.

    Profile photo of qwerty69

    Setting device_joystick to sdl in all three .rc files (one for each version) worked for me.

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at

Skip to toolbar