Map controls in Retroarch

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 9 replies, has 3 voices, and was last updated by Profile photo of labelwhore labelwhore 2 years, 1 month ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #87996
    Profile photo of man3l3t
    man3l3t
    Participant

    Hi! I have Retropie 2.6 on my microSD. I can’t configure controls in Retroarch. In 2.2 version of Retropie I must edit the retroarch.cfg and changue the lin “input_enable_hotkey=escape” to “input_enable_hotkey=null” and then I can press F1 to acces to the menu. In Retropie 2.6 I can’t acces to the menu pressing F1 and this line is not setted to “escape” so I don’t know how to acces to the menu in Retroarch to map my controls.
    I think that the front-end map my controls when I run Retropie with a fresh image and say me to hold a button to configure my gamepad, but in snes there are A,B,X and Y controls and the front-end only say me to configure A and B.

    The menu is like this:

    Thanks!

    #87999
    Profile photo of labelwhore
    labelwhore
    Participant

    There is an option in the retropie_setup.sh script to register a retroarch controller in step 3. Have you tried that?

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    #88008
    Profile photo of man3l3t
    man3l3t
    Participant

    You say to do this: https://www.youtube.com/watch?v=9PWO-F4zuaY ?
    I want to configure my controller without the command line, like this image retroarch config

    • This reply was modified 2 years, 2 months ago by Profile photo of man3l3t man3l3t.
    #88012
    Profile photo of Floob
    Floob
    Moderator

    I would strongly recommend the method labelwhore suggests.
    If you want to do it via the menu, press F1 when in a game.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88015
    Profile photo of man3l3t
    man3l3t
    Participant

    In the method labelwhore suggests there isn’t the option to exit emulator and configure emulator by emulator like I did in the other method that I suggest. The problem is that if I press F1 in a game doesn’t appeat that menu.

    Thanks!

    #88017
    Profile photo of Floob
    Floob
    Moderator

    You can set options to exit emulator by setting a hotkey, like this:

    You can set per emulator settings by using the files here:
    /opt/retropie/configs/{systemname}/retroarch.cfg

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88018
    Profile photo of man3l3t
    man3l3t
    Participant

    I see the line input_exit_emulator_btn so it resolve the action exit in the emulator. This is a hotkey that you say?

    And in PSX emulator, for example, how can I set the 2 player options? The labelwhore only configures one pad but I have lots of buttons and 2 joysticks connected to and iPAC board.

    Thanks!

    #88083
    Profile photo of man3l3t
    man3l3t
    Participant

    Gamepad version:

    cd RetroPie-Setup/
    sudo ./retropie_setup.sh
    Setup & Register Retroarch controller
    See the gamepad name (gamepadname.cfg) and buttons (X: “5” for example)
    cd /opt/retropie/emulators/retroarch/configs/
    ls –> see gamepadname
    sudo nano gamepadname(help with TAB).cfg
    Put the line: input_exit_emulator_btn=”nºbutton” in the end
    cd..
    cd..
    cd..
    cd configs –> I’m in /opt/retropie/configs
    ls
    cd emulatorthatIwant
    ls
    retroarch.cfg (It’s the same that is in /configs/all¿?¿?)
    search Joypad buttons
    quit # in A, B, X, Y, Start, Select, L, R
    copy and paste the buttons befor in order to changue input_player1 to input_player2 to configure the controller 2 in the iPac board.

    search input_exit_emulator and changue to input_exit_emulator_btn=”nºbutton” –> Didn’t do this before??
    search input_autodetect_enable=true and put to false in order to not generate conflicts if I put another gamepad

    cd /etc/emulationstation
    sudo nano es_systems.cfg
    search the emulator that I want to configure and in the line <command> changue the directory /opt/retropie/emulators/retroarch/configs/all to /opt/retropie/emulators/retroarch/configs/emulatorthatIwant

    I think that if I use and iPac board and not a gamepad I can’t Register Retroarch controller. And also I know who the buttons are (for example: button8=”C”, joystick_left=”U”).

    What is the use of input_enable_hotkey? What is hotkey?

    All of this is very frustrating for me but I think that more or less I’m in the correct way to configure separate emulators.

    Please correct me in the orders that I make mistakes.

    Very thanks to all!

    #90226
    Profile photo of man3l3t
    man3l3t
    Participant

    I can now access to the menu in retroarch. Just remove the retroarch.cfg:

    sudo rm /opt/retropie/configs/retroarch.cfg

    #90236
    Profile photo of labelwhore
    labelwhore
    Participant

    I’m guessing not having the config file may cause some other issues. To properly set up controls for player 2, all you need to do is copy the section in retroarch.cfg for player 1 and just change input_player1_* to input_player2_* in the copied lines.

    input_enable_hotkey is the hotkey you need to hold for save states and exiting the emulator. For example, mine is set to the back button, so I need to hold back and press start to exit an emulator.

    http://www.th3rdwave.com/tracks/
    ^^ my other hobby

    • This reply was modified 2 years, 1 month ago by Profile photo of labelwhore labelwhore.
Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar