MAME without keyboard

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of leiptrstormr leiptrstormr 1 year, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #101298
    Profile photo of alienhead
    alienhead
    Participant

    Hi!
    I’m using retropie with my saitek gamepad. It works great with (s)nes, gameboy, megadrive… Now I want to use it also with MAME, but it seems not to be recognized. I read that I need to press “Tab” to configure the gamepad, but I don’t own a usb keyboard. Is there a way via ssh and a config file to use my gamepad?
    thanks in advance

    #101300
    Profile photo of herbfargus
    herbfargus
    Moderator

    I don’t know of any way to change those configs but you could try switching to lr-mame4all for the default emulator- that uses retroarch configs

    #101302
    Profile photo of alienhead
    alienhead
    Participant

    @herbfargus: thanks. I tried lr-mame4all but had some issues with various roms. with mame4all all my roms loaded without problems but I can’t control them. :-/

    #101525
    Profile photo of leiptrstormr
    leiptrstormr
    Participant

    I don’t know of any way to change those configs but you could try switching to lr-mame4all for the default emulator- that uses retroarch configs

    The global retroarch input configs use select as coin insert on Final Burn Alpha, but not in advance mame or mame4all. Without coin insert, everything else is useless. I can’t even use the start + select hotkeys to exit the game. From what I understand, configs are in /opt/retropie/configs with /all being global. My retroarch.cfg inputs look like this and I am using RPi2 V3 beta4 image.

    Edit: Ok so I figured out default settings on RPi2 V3 beta4 doesn’t use lib retro mame4all.
    /opt/retropie/configs/mame-mame4all/emulators.cfg
    Change to default=”lr-imame4all”

    • This reply was modified 1 year, 9 months ago by Profile photo of leiptrstormr leiptrstormr.
Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar