MAME Setup on 1.9.1 – Roms not loading

Home Forums RetroPie Project Everything else related to the RetroPie Project MAME Setup on 1.9.1 – Roms not loading

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 2 voices, and was last updated by  raspdodo 2 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5300
    Profile photo of jplaj
    jplaj
    Participant

    I recently updated, using the RetroPie 1.9.1 image file on this website. I’ve managed to get everything working from my old image except for MAME. All files return a “Game ‘title’ not supported” message. These are the exact same files copied and pasted (without ES Scraper information) from my old card, where they worked…well enough.

    Is this something where I’ll need to find new Roms for an updated version? Or is there a coding error I can fix? (I found one website saying I needed to go into ESconfig and change the “ROM” in the command line to “BASENAME,” but that didn’t help)

    Any ideas what’s wrong with my MAME and how I can get it running again? Thanks.

    #5316
    Profile photo of jplaj
    jplaj
    Participant

    So I’m about 75% confident that I know what happened and how to fix it. I just need to ask a favor; would someone who has MAME running correctly on the 1.9.1 installation go to their es_system.cfg file and copy their MAME entry to this thread so I can compare it to mine?

    Thanks.

    #5324
    Profile photo of jplaj
    jplaj
    Participant

    So I’ve made progress…figured out what I did wrong (copied my es_system.cfg from my old file…1.9.1 has a different path I had to designate).

    However, solving that problem, I uncovered a new one. I can now get into MAME on all the old roms that worked on my other system, but it gives me an error message (in MAME, not the raspberry pi log) saying required files are missing, then after a moment it shuts down MAME and brings me back to emulationstation.

    Any ideas?

    #5334
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    which emulator are you using for MAME?

    If you have found the solution to your problem please mark the topic as resolved.

    #5335
    Profile photo of jplaj
    jplaj
    Participant

    I didn’t realize there was an option. My command line in es_system.cfg sends me here:

    COMMAND=/home/pi/RetroPie/emulators/mame4all-pi/mame

    So whichever version of mame is running from that file (again, based off the 1.9.1 image downloaded from this website). Keep in mind, I had to figure that out myself, so it may not be the original path designated for the emulator. Is there a better one to use?

    #5341
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    The default MAME emulator in the RetroPie image is imame4all, you can replace it with mame4all-pi which is optimized for the Pi and has much better performance. You can install it via the setup script (it’s in Option 2 “Source based installation”)

    Then you need to edit your es_systems.cfg and replace the existing MAME section with this:

    DESCNAME=MAME
    NAME=mame
    PATH=/home/pi/RetroPie/emulators/mame4all-pi/roms
    EXTENSION=.zip .ZIP 
    COMMAND=/home/pi/RetroPie/emulators/mame4all-pi/mame %BASENAME%
    PLATFORMID=23

    Then create a folder ‘cfg’ in /home/pi/RetroPie/emulators/mame4all-pi/

    Roms go in /home/pi/RetroPie/emulators/mame4all-pi/roms/

    mame.cfg is the config file for mame4all-pi located in /home/pi/RetroPie/emulators/mame4all-pi/

    You will need a keyboard to setup your gamepad/joystick if you use one, press tab to open the GUI

    mame4all-pi requires 0.37b5 roms

    Hope this helps

    If you have found the solution to your problem please mark the topic as resolved.

    #5349
    Profile photo of jplaj
    jplaj
    Participant

    No, it helps. Thanks. Actually, after your last comment I started looking around and changed my es_system.cfg path back to the retroarch folder instead of the mame4-all-pi/mame direction. Once I did that, everything started working perfectly.

    I appreciate the information. I figure if I keep making stupid mistakes like that, pretty soon I’ll know the programming inside and out.

    Thanks again!

    #5361
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Oh good glad you got it working. You should mame4all-pi though, it’s quite a performance increase over the default core 🙂

    If you have found the solution to your problem please mark the topic as resolved.

    #44788

    raspdodo

    I’m new of retropie. Trimmtrab is the procedure that you display good for retropie v2.3?
    Thanks a lot for response

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar