MAME Roms not working

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 65 replies, has 18 voices, and was last updated by Profile photo of Roo Roo 2 years, 1 month ago.

Viewing 35 posts - 1 through 35 (of 66 total)
  • Author
    Posts
  • #6105
    Profile photo of digitalforce
    digitalforce
    Participant

    First off, thanks to all for this awesome project. I’ve always dreamed of having a tiny, low powered and cost effective MAME/emu box and now this is it!

    I am having no issues at all getting NES, SNES and Genesis stuff running and working but every MAME rom I try to run, it starts loading the files for the ROM and then says FILES NOT FOUND like all of the roms are not the right version. What version of MAME is this built upon and which romset should I seek out?

    Thanks in advance!

    #6109
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Firstly if you haven’t already you should change the default emulator in RetroPie to mame4all-pi as it has much better performance. Search the forum on how to do this. Then the romset you need is 0.37b5

    If you have found the solution to your problem please mark the topic as resolved.

    #6114
    Profile photo of digitalforce
    digitalforce
    Participant

    Thanks trimm — Is it a pretty advanced procedure? If you have a quick “how to” — That would be much appreciated.

    #6116
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Install mame4all-pi via the RetroPie setup script (Option 2 “Source based installation” then select only mame4all-pi) Then edit es_systems:

    sudo nano /home/pi/.emulationstation/es_systems.cfg

    And replace this:

    DESCNAME=MAME 
    NAME=mame 
    PATH=/home/pi/RetroPie/roms/mame EXTENSION=.zip .ZIP 
    COMMAND=/home/pi/RetroPie/emulators/RetroArch/installdir/bin/retroarch -L /home/pi/RetroPie/emulatorcores/imame4all-libretro/libretro.so --config /home/pi/RetroPie/configs/all/retroarch.cfg --appendconfig /home/pi/RetroPie/configs/mame/retroarch.cfg %ROM%" # alternatively: COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1 "/home/pi/RetroPie/emulators/pifba/fba2x %ROM%" PLATFORMID=23

    with this:

    DESCNAME=MAME
    NAME=mame
    PATH=/home/pi/RetroPie/emulators/mame4all-pi/roms
    EXTENSION=.zip .ZIP 
    COMMAND=/home/pi/RetroPie/emulators/mame4all-pi/mame %BASENAME%
    PLATFORMID=23

    Then reboot. Roms need to go in /home/pi/RetroPie/emulators/mame4all-pi/roms (you need to create the directory)

    If you have found the solution to your problem please mark the topic as resolved.

    #6134
    Profile photo of digitalforce
    digitalforce
    Participant

    Thanks for the help. I followed this exactly and put the same .zip (roms) into that new folder. After a reboot, MAME no longer even shows up on the menu at all.

    Wondering if we are missing quotations or something…

    #6136
    Profile photo of digitalforce
    digitalforce
    Participant

    I just ran the mame4all-pi executable and it loads with NO ROMS FOUND. Is there a way to rescan or configure mame4all directly?

    EDIT: Found the mame.cfg file, changed the roms directory and so when I run I run it directly, the mame screen comes up and then just kicks me back to prompt.

    EDIT 2: Got the standalone mame4all in console working with the “sudo ./mame contra” command. Still can’t get mame4all to show up in the main menu while all other emulators and apps work great.

    #6140
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    can you post the contents of your es_systems.cfg? Also double check that the paths are correct they may have changed.

    If you have found the solution to your problem please mark the topic as resolved.

    #6141
    Profile photo of digitalforce
    digitalforce
    Participant

    Here you go —

    Attachments:
    1. es_systems.txt
    #6144
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    in your es_systems you’ve got the rom path wrong, should be

    PATH=/home/pi/RetroPie/emulators/mame4all-pi/roms

    reboot and they should show up. change the rom path back to how it was originally in mame.cfg and you should be good to go

    If you have found the solution to your problem please mark the topic as resolved.

    #6150
    Profile photo of sewersurfer
    sewersurfer
    Participant

    Hello, I followed your guide to install mame4all-pi and it worked just fine, thank you. Performance is much better now!

    However, I have 2 problems:
    1. The installation somehow changed the resolution of both emuluationstation and the emulators itself so that now, they are “boxed”, meaning that the screen is only a box within my TV. They are still displayed in the correct aspect ratio (16:9 for emulationstation, 4:3 for emulators/games) but not fullscreen anymore. How can I change that back to what it was before??
    2. How can I use my gamepad in mame4all? It works fine with every other emulator and in emulationstation but not in mame4all.

    thank you!!

    #6151
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hello, I followed your guide to install mame4all-pi and it worked just fine, thank you. Performance is much better now!

    However, I have 2 problems:<br>
    1. The installation somehow changed the resolution of both emuluationstation and the emulators itself so that now, they are “boxed”, meaning that the screen is only a box within my TV. They are still displayed in the correct aspect ratio (16:9 for emulationstation, 4:3 for emulators/games) but not fullscreen anymore. How can I change that back to what it was before??<br>
    2. How can I use my gamepad in mame4all? It works fine with every other emulator and in emulationstation but not in mame4all.

    thank you!!

    Hi, to configure your gamepad connect a usb keyboard and press tab when you run mame4all-pi, this will bring up the GUI and you can map your buttons in there, including GUI keys (back/exit is the exit emulator key) Also check out mame.cfg for other options.

    Regarding the resolution I have no idea why that has happened, installing mame4all-pi shouldn’t mess with any settings like that. Double check your config.txt, or it could be a setting on your tv.

    If you have found the solution to your problem please mark the topic as resolved.

    #6166
    Profile photo of sewersurfer
    sewersurfer
    Participant

    Oddly enough the resolution is perfectly fine on a different TV (fullscreen 16:9 in emulationstation, fullscreen 4:3 in emulators). I didn´t change anything on my TV during the installation, but I will try a different HDMI port…

    As for the gamepad-issue: The GUI was the first thing I tried and it din´t work at first, but I found out that the issue was my gamepad. It is a MadCatz SF4 gamepad and was set to “D-pad” instead of “left or right stick”. If I set it to “ls” or “rs” it works just fine 🙂
    The thing that´s bugging me right now however is that mame4all does not save the changes I make in the GUI. For instance if I map “pause” to the start button on my gamepad it works fine for that session but once I hit escape, go back to emulationstation and again go back into the game, the mapping is gone and back to it´s default (pause on keyboard-p). What do I have to do so that mame4all remembers what I change in the GUI when it comes to button mapping??

    thank you

    #6167
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Sorry I forgot you need to create a folder cfg in the mame4all-pi directory or it won’t save. Hope you sort your tv problem out!

    If you have found the solution to your problem please mark the topic as resolved.

    #6218
    Profile photo of sewersurfer
    sewersurfer
    Participant

    Thanks for your help, much appreciated. Everything is up and running now 🙂

    The TV problem remains though. I tried it on 3 different tvs: on 2 the picture is in a box. On one TV it worked just like it should, no box, no edges. Fullscreen. Very strange… But I am pretty sure that it is not a TV related problem.

    #6221
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    If you post your config.txt i’ll have a look. Also have a look at the video options you can configure in RPiconfig: http://elinux.org/RPiconfig#Video
    May be something in there that can help you.

    If you have found the solution to your problem please mark the topic as resolved.

    #6240
    Profile photo of sewersurfer
    sewersurfer
    Participant

    I changed the overscan option and now it works fine. thank you

    #6241
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    I was thinking it might be that, glad you sorted it 🙂

    If you have found the solution to your problem please mark the topic as resolved.

    #6244
    Profile photo of cyberfantome
    cyberfantome
    Participant

    I followed the above and none of my zipped roms work. I get a screen that shows the contents and file not found errors or it just exits back to ES.

    #6248
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    which romset are you using? needs to be 0.37b5

    If you have found the solution to your problem please mark the topic as resolved.

    #6342
    Profile photo of fmn5075
    fmn5075
    Participant

    Hello,

    first thanks for all the precious help bring in this forum.

    I have the same problem with my joystick (Hori fighting stick 3), Sewersurfer could you explain ‘was set to “D-pad” instead of “left or right stick”. If I set it to “ls” or “rs” it works just fine’ ?
    How could I set my joystick this way ? this setting is in retropie config or in mame config ?

    Thanks in advance.

    #6367
    Profile photo of charles
    charles
    Participant

    Hi, I have been having the same issue, but after following all of these steps I am left with mame4all-pi giving me a bunch of * while trying to load a game. It ultimately takes me back to the emulationstation. I have tried using many other games with MAME, all end the same. Games on other emulators (NES, SNES, Megadrive, etc.) still work. 🙁

    #6375
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    which romset are you using?

    If you have found the solution to your problem please mark the topic as resolved.

    #6384
    Profile photo of charles
    charles
    Participant

    As far as I know I am not using a ROM set. The games that I have tried with mame4all-pi are Pac-Man, Asteroids, 25th Anniversary Pac-Man, and around 14 more. Some of them come with files missing. I also have tried downloading them from different sites too.

    #6392
    Profile photo of sewersurfer
    sewersurfer
    Participant

    Hello,

    first thanks for all the precious help bring in this forum.

    I have the same problem with my joystick (Hori fighting stick 3), Sewersurfer could you explain ‘was set to “D-pad” instead of “left or right stick”. If I set it to “ls” or “rs” it works just fine’ ?<br>
    How could I set my joystick this way ? this setting is in retropie config or in mame config ?

    Thanks in advance.

    Sure: As opposed to the Xbox360 controller, my gamepad (MadCatz Street Fighter IV) has only one d-pad, but with a little switch on the back of the gamepad I can choose wether that D-pad should be recognized as either the left analogue stick, or the right analogue stick, or the d-pad. As the emulator seems to expect input from one of the two analogue sticks it won´t work if I set the gamepad to d-pad.

    If you can set it up that way using the config-files or not, that I don´t know. But you might wanna check if your fightstick has that option as well.

    #6399
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    As far as I know I am not using a ROM set. The games that I have tried with mame4all-pi are Pac-Man, Asteroids, 25th Anniversary Pac-Man, and around 14 more. Some of them come with files missing. I also have tried downloading them from different sites too.

    The roms you need to use are from 0.37b5 which is an old romset from around the year 2000. Most of the rom sites have newer roms which won’t work, you’ll have to locate the compatible versions.

    If you have found the solution to your problem please mark the topic as resolved.

    #6417
    Profile photo of charles
    charles
    Participant

    Can you possibly send me the link to it because looking them up, downloading, and putting them in the mame4all-pi roms folder still gives me the same result.

    #6449
    Profile photo of fmn5075
    fmn5075
    Participant

    Thanks a lots sewersurfer, very helpful explanation !

    I’ll give a try.

    #11883
    Profile photo of wadevondoom
    wassap

    I think he cannot link to the download site as downloading roms that you don’t own is illegal. I only found one site that had a full set of roms for the 0.37b5 set and to get the name for that site you can search google for “old computer rom 0.37b5”. They require a donation however to get access to that romset. I checked the piratebay and others and this was the only place I could find. They ask for a $15 donation for full access. I happily paid it and have every rom I could want.

    #56673
    Profile photo of pmcuk
    pmcuk
    Participant

    just search google pleasuredome

    #77868

    LaLaLand

    I have the a Hori fighting stick mini 3 and I got the same problem as fmn5075.

    I looked thru the source code and found the problem to be in this file:

    src/rpi/input.cpp

    Basically under SDL the Hori joystick is detected as the POV hat instead of a joystick. So to fix the issue you just have to change the function ‘is_joy_axis_pressed’ to get the ‘Hat’ instead:

    if(SDL_JoystickGetAxis(myjoy[joynum], axis) < -12000) return true;

    become:

    if(axis == 0 && SDL_JoystickGetHat(myjoy[joynum], 0) & SDL_HAT_LEFT) return true;
    if(axis == 1 && SDL_JoystickGetHat(myjoy[joynum], 0) & SDL_HAT_UP) return true;

    Similarly the line:

    if(SDL_JoystickGetAxis(myjoy[joynum], axis) > 12000) return true;

    become:

    if(axis == 0 && SDL_JoystickGetHat(myjoy[joynum], 0) & SDL_HAT_RIGHT) return true;
    if(axis == 1 && SDL_JoystickGetHat(myjoy[joynum], 0) & SDL_HAT_DOWN) return true;

    You just have to recompile it (i.e. type make) and it should work after. Hope this help.

    #84515
    Profile photo of zombi8008
    zombi8008
    Participant

    Install mame4all-pi via the RetroPie setup script (Option 2 “Source based installation” then select only mame4all-pi) Done
    Then edit es_systems:
    sudo nano /home/pi/.emulationstation/es_systems.cfg

    do not have a file es_systems.cfg

    what I am doing wrong

    #84571
    Profile photo of Floob
    Floob
    Moderator

    You could create one there or use
    /etc/emulationstation/es_systems.cfg

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84831
    Profile photo of chito
    chito
    Participant

    So quick question…. does retropie 2.3 have mame4all-pi as the default mame now? cause looking at the es_systems.cfg it appears it does… but im a noob so i dont know how to confirm this

    #84852
    Profile photo of Floob
    Floob
    Moderator

    Yes it does. Although 2.4 beta is out now! I’ll check that out tonight.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84914
    Profile photo of chito
    chito
    Participant

    Mame4all is missing so many games. I know that its meant to be better performance by not emulating newer games but there are plenty of older games that are missing. Is there a better alternative? Or is there a way to add games to a custom compilation?

Viewing 35 posts - 1 through 35 (of 66 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar