lr-fba global controller config not working

Home Forums RetroPie Project Controller Configuration in RetroPie lr-fba global controller config not working

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: , ,

This topic contains 10 replies, has 5 voices, and was last updated by Profile photo of Floob Floob 1 year, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #97128
    Profile photo of octogenarian
    octogenarian
    Participant

    Hi,

    First time post – please be gentle. I’ve just upgraded from 2.6 to the 3.02 beta. After some tinkering I now understand the implications of allowing emulators to be chosen by group or ROM and I think it’s fab. However set up is now a little bit more difficult as it pretty much means you have to have a controller config set up for every emulator you’re interested in, (lessening the advantage of Retroarch) as performance varies wildly.

    Anyway I digress.

    I have managed to configure Retroarch along with hotkeys for various emulators but it seems that lr-fba is refusing to respond to my global Retroarch settings. All of the other emulators set to start with the lr-prefix behave as expected. Any idea what the issue might be? Does Emulationstation itself play a role in setting a file path for example?

    The local lr-fba retroarch config file now has a hashed out include path to the main config file and that is set correctly. It has a live input_remapping_directory file path pointing to /opt/retropie/configs/fba/ so that all seems to be in order.

    #97146
    Profile photo of Floob
    Floob
    Moderator

    Unless you manually edit your config files, by default the libretro cores will all use the controller file in /opt/retropie/emulators/retroarch/configs/{yourcontroller}.cfg

    It will then parse the system specific retroarch file which are in /opt/retropie/configs/{systemname}/retroarch.cfg (which in turn pulls in the system wide retroarch.cfg from /opt/retropie/configs/all/retroarch.cfg)

    Id its just lr-fba playing up, I presume there is an issue with that system specific retroarch.cfg

    Can you post your
    /opt/retropie/configs/fba/retroarch.cfg as an attachment here?

    Or post it up on pastebin.com

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97158
    Profile photo of octogenarian
    octogenarian
    Participant

    Thanks for coming back to me Floob. Settings for the file are below:

    #include “/opt/retropie/configs/all/retroarch.cfg”
    # All settings made here will override the global settings for the current emulator core

    input_remapping_directory = /opt/retropie/configs/fba/

    #97162
    Profile photo of Floob
    Floob
    Moderator

    When you say you have upgraded from 2.6 to 3 – how did you do that?

    Have you tried writing the RetroPie 3 image to a clean SD card?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #97164
    Profile photo of octogenarian
    octogenarian
    Participant

    I upgraded via option 1 in the setup script.

    #97190
    Profile photo of Floob
    Floob
    Moderator

    Could you try a clean install with a version 3 image?
    Also, do you have a different controller to test with as well?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #102716
    Profile photo of a7mag3ddon
    a7mag3ddon
    Participant

    Has anyone sorted this? I have exact same issue and i am using clean install of B3 RC1 and lr-fba isnt picking up my joypad but other retroarch emus are fine.

    #104386
    Profile photo of misled3k
    misled3k
    Participant

    I had the same problem — fixed it by moving all my roms & bios from the “neogeo” roms folder to the “fba” roms folder. I tried the “neogeo” rom folder first because that is what the wiki suggested, but it was just redirecting me to the fba emulator with an incorrect config file.

    #104396
    Profile photo of Floob
    Floob
    Moderator

    Has anyone sorted this? I have exact same issue and i am using clean install of B3 RC1 and lr-fba isnt picking up my joypad but other retroarch emus are fine.

    Beta 3 did have some controller issues.
    Try the RetroPie 3 final that is out now.

    Sorry – just read you have RC1 – that should be ok, and works ok for me. Is it just the case that you cant add credits? Have you tried Rigth Shift?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #104435
    Profile photo of beliaaal
    beliaaal
    Participant

    I can confirm this! This is also my 1st post.
    I use a ps3 controller and i have no trouble with insert coin since i changed:
    input_enable_hotkey_btn = "16"
    16 is the PS button, so i doesn’t conflict with select.
    I also have no problems with my bluetooth dongle or pairing my ps3 controllers.
    no problems with lr-imame4all
    no problems with lr-mupen64plus
    no problems with lr-pcsx-rearmed
    no problems with lr-snes9x-next

    The shortcut PS Button + Start can quit this 4 emulators, but when I load a game in lr-fba I have to ssh into it to reboot the system since neither the keyboard nor the controllers work.
    If anyone can identify the problem please enlighten us!

    *EDIT*

    Reinstalling it from source in a fresh retropie 3 fixed it for me.
    (only on the 5th try tho ^^)

    */EDIT*

    #104438
    Profile photo of Floob
    Floob
    Moderator

    @beliaaal What happens if you try to set your left trigger as the hotkey enable for lr-fba only? (in /opt/retropie/configs/fba/retroarch.cfg)

    I *think* the only reason you cant get the controller to work is due to not being able to add credits or use the hotkey there – so try as above and change to something else in lr-fba.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 11 posts - 1 through 11 (of 11 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar