Logitech F710g with RetroPie EmulationStation

Home Forums RetroPie Project Controller Configuration in RetroPie Logitech F710g with RetroPie EmulationStation

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 2 voices, and was last updated by Profile photo of philmw60 philmw60 1 year, 11 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #98652
    Profile photo of philmw60
    philmw60
    Participant

    Hi,

    First of all I’m a complete newb, so apologies if I’ve missed something obvious.

    I’ve got the standard retropie / emulationstation distro up and running on my RPI B model and recently purchased a Logitech F710 wireless gamepad. Problem is I can’t configure it!

    When I go into configure input (from main emulationstation menu) it states “1 gamepad detected” but when I press and hold any button on the gamepad, nothing happens on the Pi. At the same time the “mode” button blinks a few times then goes off. I’ve seen other posts suggesting this could be due to low battery but I’ve tried other brand new batteries and still no luck.

    It’s so frustrating cos EmulationStation detects that the Wireless receiver is plugged into the USB port! I even unplug it / reconnect it while the Pi is on and I get a brief message in yellow text stating the gamepad is recognised.

    The menus in Retroarch even identify it as a Logitech Gamepad F710! Could it be that the USB port on the RPI isn’t providing enough power to the receiver?

    Has anyone had any luck getting this controller to work? I haven’t installed any additional drivers and like I say this is the standard Retropie distro I downloaded just a few weeks ago.

    Thanks so much in advance.

    Phil

    #98654
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    thats really odd! i’ve never had any issues with my Logitech Gamepad F710, even when using rpi B, its usually just plug & play

    #98658
    Profile photo of philmw60
    philmw60
    Participant

    Do you ever get the green blinking light for the mode button on the gamepad? I’m beginning to wonder if the gamepad itself is faulty. Also do you have it on ‘X’ or ‘D’ mode? Cheers

    #98673
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    the light if I remember blinks when connecting, then on steady if using the pad, or off if using the stick, so you can switch between the 2. off hand I can’t remember what my switch is on, but I’ll look when I get home

    #98678
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    update: my switch is set on “x”

    #98682
    Profile photo of philmw60
    philmw60
    Participant

    I got it working!

    I used the Wireless Gamepad F710 Connect Utility in my windows machine to do initial config between the gamepad and the receiver. Now it works with my RPI šŸ˜€

    I didn’t receive any instructions with my gamepad (mail order) but seems this is a pre-req step you have to do:

    – Insert receiver into USB port
    – remove 1 battery from gamepad
    – reinsert battery into gamepad
    – Connect utility then showed connected

    Now if I press mode button the light is either on solid, or off.

    Thanks anyway

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar