Logitech f710 working BUT can't change mapping

Home Forums RetroPie Project Everything else related to the RetroPie Project Logitech f710 working BUT can't change mapping

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of kassemmel kassemmel 2 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #87749
    Profile photo of kassemmel
    kassemmel
    Participant

    Hi,

    I’m using retropie 2.5 on my pi2
    My Logitech f710 (on xinput) is working but i can’t change mapping at all. It looks like it doesn’t even look for the files (wrong path????) i’ve tried changing /opt/retropie/configs/all/retroarch.cfg and /opt/retropie/configs/nes/retroarch.cfg but no matter how i map the buttons, nothing changes at all (yes i am saving those files).

    there has to be some kind of config somewhere but i couldn’t find anything except for /home/pi/RetroPie-Setup/supplementary/settings.xml (had a path change from retroarch to something else but didn’t do anything as well) on the pi and nothing related with google.

    I’ve initially configured the controller with joyconfig (sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg) and was wondering, why joyconfig has shown me other button numbers than the ones in /home/pi/RetroPie-Setup/supplementary/RetroArchConfigs/LogitechGamepadF710.cfg even though it shows “joypad port#0 (Logitech Gamepad F710) configure” on the screen when i’m starting an emulator.
    Does anyone know where to look or even a potential fix for this issue?
    I just want to exit an emulator by controller 🙁

    Thank you in advance

    #87771
    Profile photo of Mutex
    Mutex
    Participant

    I’m using the same gamepad and had similar results. I ended up disabling the gamepad autodetect in the retroarch.cfg and adding my buttonmapping to the retroarch.cfg.

    I was able to change the button layout in the autoconfig file for the f710 but that doesn’t work well with all emulators especially with genesis.

    If autoconfig is activated retroarch doesn’t check the configfolders defined in the es_systems file and just uses the autoconfig for every emulator. At least it did that for me.

    #87784
    Profile photo of kassemmel
    kassemmel
    Participant

    If autoconfig is activated retroarch doesn’t check the configfolders defined in the es_systems file and just uses the autoconfig for every emulator. At least it did that for me.

    I guess you’re relating to those lines?

    # Enable input auto-detection. Will attempt to autoconfigure
    # joypads, Plug-and-Play style.
    # input_autodetect_enable = true

    Will try this when i get home. Is there a way to make this work in Kodi (experimental retropie package) as well? I just found some xbox 360 controller stuff that will probably work but i don’t want to fuck up the configs again if there’s a cleaner way of binding the gamepads input to keyboard buttons (without xboxdrv).

    Thank you

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar