Load RetroPie on LCD display

Home Forums RetroPie Project Video Output on RetroPie Load RetroPie on LCD display

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 3 voices, and was last updated by Profile photo of senkun senkun 1 year ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #118857
    Profile photo of ts87
    ts87
    Participant

    Ok, here is the current setup:
    – Installed Raspbian Jessie
    – Installed RetroPi on top
    – Installed drivers for LCD screen

    Now when the Raspberry boots to RetroPi it shows the picture on the HDMP. However when i go to startx in the terminal it loads Jessie on the LCD screen..
    Is there possibility to redirect the picture of RetroPi from HDMI to the LCD?

    #118860
    Profile photo of herbfargus
    herbfargus
    Moderator

    Fbcp

    #118862
    Profile photo of ts87
    ts87
    Participant

    What do you mean? I installed Fbcp like that:

    sudo apt-get install cmake
    git clone https://github.com/tasanakorn/rpi-fbcp
    cd rpi-fbcp/
    mkdir build
    cd build/
    cmake ..
    make
    sudo install fbcp /usr/local/bin/fbcp

    and still the same – EmulationStation loads on the HDMI instead of LCD.

    #118876
    Profile photo of herbfargus
    herbfargus
    Moderator

    Does it show on the LCD when not plugged into HDMI? Might be a setting in config.txt that you can mess with. I think I did something with the HDMI configs but it was a long time ago so I don’t remember exactly.

    #118878
    Profile photo of ts87
    ts87
    Participant

    I did check the file /boot/config.txt and i did set the following:

    hdmi_cvt 320 240 60 1 0 0 0
    hdmi_group=2
    hdmi_mode=87

    however still no result..
    Great, played a little bit too much with it.. Now it’s not booting, only white screen – time to reinstall the SD card..

    • This reply was modified 1 year ago by Profile photo of ts87 ts87.
    #118930
    Profile photo of ts87
    ts87
    Participant

    Short update..
    I messed with the config.txt some more. I managed to rotate the LCD screen to the direction i actually needed (EmulationStation still boots on HDMI).
    Few notes that might help:
    When i set my Raspian Jessie to load on LCD it changes the /boot/config.txt by adding
    dtoverlay=waveshare32b
    dtoverlay=ads7846

    I check the file /usr/share/X11/xorg.conf.d/99-fbturbo.conf
    and i see output is set to /dev/fb1

    From what i have seen online so far all should be fine.. but the fact is EmulationStation loads on the hdmi 🙁

    I think i need to modify /opt/retropie/supplementary/runcommand/runcommand.sh by adding something like this:
    mode_new = “DMT-87”
    return

    on function get_mode()
    Unfortunately i don’t see such function in that file..

    • This reply was modified 1 year ago by Profile photo of ts87 ts87.
    #118935
    Profile photo of herbfargus
    herbfargus
    Moderator

    Did you edit the cmdline.txt at all? I had to add fbcon10 or something like that

    My notes for my build are on this page:http://blog.petrockblock.com/forums/topic/gamepi-zero-attachment-fileimage-jpeg/ may differ slightly from your hardware

    #119180
    Profile photo of ts87
    ts87
    Participant

    @herbfargus thank you kindly!
    So i re-installed Jessie.
    Then i installed the LCD driver.
    Next i installed RetroPie.
    RetroPie shows on HDMI.
    Switch to LCD terminal.

    sudo raspi-config
    expand filesystem
    
    disable overscan
    
    force audio to 3.5mm 
    
    advanced options >> enable Device Tree
    
    advanced options >> enable SPI >> load SPI kernel module by default
    
    sudo reboot

    Next
    FBCP

    sudo apt-get install cmake
    git clone https://github.com/tasanakorn/rpi-fbcp
    cd rpi-fbcp/
    mkdir build
    cd build/
    cmake ..
    make
    sudo mkdir /usr/local/bin
    sudo install fbcp /usr/local/bin/fbcp

    Next
    /etc/profile.d/10-emulationstation.sh

    on its own on the second line before emulationstation is called.

    /usr/local/bin/fbcp &

    /boot/config.txt

    
    sudo nano /boot/config.txt
    hdmi_force_hotplug=1
    hdmi_cvt=320 240 60 1 0 0 0 
    hdmi_group=2
    hdmi_mode=87

    and finally
    sudo nano /home/pi/emulationstation.sh

    #!/bin/bash
    /usr/bin/local/fbcp &
    emulationstation
    sudo chmod +x emulationstation.sh

    Not sure if the last one did anything, but after reboot RetroPie loaded on the LCD 🙂

    #120251
    Profile photo of senkun
    senkun
    Participant


    Then i installed the LCD driver.

    Thank you for the step-by-step, I presume you’re using a 3.2″ lcd from WaveShare? May I ask what is that LCD driver that you installed in the second step right after installing Jessie?

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar