How to get scanlines and vastly improve picture quality: the best method

Home Forums RetroPie Project Video Output on RetroPie How to get scanlines and vastly improve picture quality: the best method

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

Tagged: ,

This topic contains 118 replies, has 21 voices, and was last updated by Profile photo of dragonjab dragonjab 1 year, 8 months ago.

Viewing 14 posts - 106 through 119 (of 119 total)
  • Author
    Posts
  • #100318
    Profile photo of patrickm
    patrickm
    Participant

    Is there a way to have crt-hyllian and crt-caligari shaders for 720p with even scanlines and integer scaling disabled, or a way to compile these shaders for 720p?

    The short answer to both questions is no.

    Guess I’ll have to stick with integer scaling enabled then….odd thing is for Playstation there doesn’t appear to be any artifacts when integer scaling is disabled….I guess that’s because Playstation games have a higher internal render res than snes and genesis games.

    We’ll probably have to wait for the RPi 3 to be able to get these emulators running at full speed, 1080p rendering res and with shaders

    Actually, playstation games always have scaling artifacts because the emulator forces a particular resolution but the games would change resolutions. You can deal with this with the sharp-bilinear shader or the pixelate shader, but they don’t run well at 1080p on the pi.

    #100330
    Profile photo of blockaboots
    blockaboots
    Participant

    So where’s the option to adjust integer scaling?, all I see is an option to turn it on or off

    #100391
    Profile photo of patrickm
    patrickm
    Participant

    So where’s the option to adjust integer scaling?, all I see is an option to turn it on or off

    As per the instructions in the post “how to get perfect video scaling…”:

    1. Turn integer scale on
    2. Menu -> Options -> Video Options -> Custom Ratio

    In order for the overlays to line up right you have to choose the correct scale factor for the y axis.

    • This reply was modified 1 year, 9 months ago by Profile photo of patrickm patrickm.
    #100860
    Profile photo of blockaboots
    blockaboots
    Participant

    Hmm ok i have just tried this method and it seem to be cutting a fair amount from the top and bottom of the display, for this i have been using Genesis-Plus-GX core. This is whats ive done….

    1. I have downloaded both your scanline overlays and made cfg files for both and placed them in the overlay folder

    2. Set the render res for the lr-genesis-plus-gx core to 1280×960

    3. Loaded Alien Storm and once loaded enabled integer scaling

    4. selected your scanline1920x1080-5x overlay

    5. go into options>video options>custom raito and set it to 4×5 (1280×1120)

    but when playing Alien Storm the bottom energy bar to completely cut off the screen!, i have tried the overscan setting but that doesn’t appear to change anything. Have i done anything wrong or is this just a problem we have to live with?, if so the crt-hyllian shader and integer scaling option is the way to go as at least with that no vital section of the game screen is cut off!?

    • This reply was modified 1 year, 9 months ago by Profile photo of blockaboots blockaboots.
    #100915
    Profile photo of patrickm
    patrickm
    Participant

    Hmm ok i have just tried this method and it seem to be cutting a fair amount from the top and bottom of the display, for this i have been using Genesis-Plus-GX core. This is whats ive done….

    1. I have downloaded both your scanline overlays and made cfg files for both and placed them in the overlay folder

    2. Set the render res for the lr-genesis-plus-gx core to 1280×960

    3. Loaded Alien Storm and once loaded enabled integer scaling

    4. selected your scanline1920x1080-5x overlay

    5. go into options>video options>custom raito and set it to 4×5 (1280×1120)

    but when playing Alien Storm the bottom energy bar to completely cut off the screen!, i have tried the overscan setting but that doesn’t appear to change anything. Have i done anything wrong or is this just a problem we have to live with?, if so the crt-hyllian shader and integer scaling option is the way to go as at least with that no vital section of the game screen is cut off!?

    Please read through the information I’ve provided in “how to get perfect video scaling.”

    You should not set the render resolution as you have done. It should be set to “use video output” or left blank.

    Yes, some of the picture will be cropped at 5x scale, but what is cropped corresponds exactly to the overscan area on an NTSC CRT TV. It is very rare for important graphics to be placed in the overscan area; game developers intentionally avoided this.

    • This reply was modified 1 year, 9 months ago by Profile photo of patrickm patrickm.
    #100933
    Profile photo of blockaboots
    blockaboots
    Participant

    Ah thank you that worked, i missed the step about setting the ‘use video output’ option.

    Im using the 5x scanline overlay but i fell the scanlines are slightly too narrow and sharp, is there an easy what to make the slightly thicker and softer at all?

    I think im liking the look of the interlacing shader option more atm

    #101230
    Profile photo of dankcushions
    dankcushions
    Participant

    i’ve been experimenting with the “wii” scanlines overlay preset in retroarch, and it seems to line-up with each pixel, across different emulators (MD/SNES/PSX/FBA-libretro). is that normal? i don’t even have integer scaling on!

    i realise that i haven’t got the “true” aspect ratios, as per this thread, but i liked the idea of filling the whole screen (vertically) if possible.

    one thing i did find is that i would get strange moire effects unless i turned the overlay opacity down to .35, but i wonder if that is just my TV, or a scaling issue? it’s really annoying in piFBA and Mame4All-Pi as they don’t have retrorch’s configuration, just a single scanlines on/off setting 🙁

    #101989
    Profile photo of patrickm
    patrickm
    Participant

    i’ve been experimenting with the “wii” scanlines overlay preset in retroarch, and it seems to line-up with each pixel, across different emulators (MD/SNES/PSX/FBA-libretro). is that normal? i don’t even have integer scaling on!

    i realise that i haven’t got the “true” aspect ratios, as per this thread, but i liked the idea of filling the whole screen (vertically) if possible.

    one thing i did find is that i would get strange moire effects unless i turned the overlay opacity down to .35, but i wonder if that is just my TV, or a scaling issue? it’s really annoying in piFBA and Mame4All-Pi as they don’t have retrorch’s configuration, just a single scanlines on/off setting :(

    That’s a scaling problem. I’ve explained how to get perfect scaling while filling the vertical area in my two posts “how to get scanlines” and “how to get perfect video scaling.” This is accomplished by cropping the overscan and letterboxing that is normally visible at 4x vertical scale by setting the vertical scale to 5x scale.

    The wii scanline overlay is 640×480, so if Retroarch is set to render at a higher resolution than this, the overlay will be scaled with bilinear scaling, which blurs the image and causes artifacts. You need to use an overlay that matches the resolution you’re using.

    Also make sure that your tv is not stretching the picture by any amount. Using your tv’s zoom feature will scale the content.

    • This reply was modified 1 year, 8 months ago by Profile photo of patrickm patrickm.
    #101990
    Profile photo of patrickm
    patrickm
    Participant

    Ah thank you that worked, i missed the step about setting the ‘use video output’ option.

    Im using the 5x scanline overlay but i fell the scanlines are slightly too narrow and sharp, is there an easy what to make the slightly thicker and softer at all?

    I think im liking the look of the interlacing shader option more atm

    It’s easy to edit the scanline image in a graphics program. I may whip up an overlay with “soft” scanlines, if I have the time. The narrowness is a consequence of 5x scale- the scanlines are 2px wide with 3px between them. You could make the scanlines 3px wide but that would be too wide. At 2px wide, the scanlines are approximately as wide as they are on a CRT when bloom is above 50%.

    If you want “perfect” scanlines, you have to use 4x scale, which leaves letterboxing and overscan visible. It’s a trade-off.

    • This reply was modified 1 year, 8 months ago by Profile photo of patrickm patrickm.
    #102607
    Profile photo of dragonjab
    dragonjab
    Participant

    Sorry to bother, but @patrickm did Floob ever do a video about your method of using scanlines? Would be nice to have a video about this method and another from your other post, about the perfect scaling.

    #102850
    Profile photo of dragonjab
    dragonjab
    Participant

    Ok so I try the steps again, but we no results. Every time I have it all setup, the minute I log out of the RGUI the settings are gone. I also try doing this through the retropie settings on the new Retropie Release Candidate 1. Which I’m guessing is the general RGUI for all the retroarch emulators. Please help a video would be helpful.

    #102853
    Profile photo of Floob
    Floob
    Moderator

    You could try this tool to make it easier:
    http://blog.petrockblock.com/forums/topic/list-of-recommended-resolutions-for-each-system/#post-102532

    Its not finished but it should help you.
    I’ll try to sort a video soon to explain how the data gets overwritten when you use RGUI.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #102860
    Profile photo of patrickm
    patrickm
    Participant

    Ok so I try the steps again, but we no results. Every time I have it all setup, the minute I log out of the RGUI the settings are gone. I also try doing this through the retropie settings on the new Retropie Release Candidate 1. Which I’m guessing is the general RGUI for all the retroarch emulators. Please help a video would be helpful.

    You might try turning on “auto save config on exit.” Under general options, I think. I haven’t tried this myself, though.

    #102876
    Profile photo of dragonjab
    dragonjab
    Participant

    I finally figure it out thanks.

Viewing 14 posts - 106 through 119 (of 119 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar