Linux howto (how to burn image to SD card in linux)

Home Forums RetroPie Project Everything else related to the RetroPie Project Linux howto (how to burn image to SD card in linux)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of buzz buzz 2 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #84411
    Profile photo of martinsson
    martinsson
    Participant

    Hello all

    This project made my soul sing, having grown up it all these wonderful devices I could not help but trying it out, but I have hit a snag.

    Using Debian (7.7), how do I best go about burning the image to my 16Gb SD card, I have downloaded the RetroPieImage_ver2.3.img and tried the following :

    Searched the forums for “linux burn howto” “dd command” “unetbootin howto” and more without finding what I’m after.

    Tried DD’ing the image to my SD card like this :

    dd if=<source> of=<target> bs=<byte size>

    source :
    /home/martinsson/Downloads/RetroPieImage_ver2.3.img

    target :
    /dev/sdb1

    dd if=/home/martinsson/Downloads/RetroPieImage_ver2.3.img of=/dev/sdb1

    And it worked – but the raspberry does not boot up.

    I also tried unetbootin (in vine) which also worked, but with the same result, no boot up.

    When looking at the SD card in the thunar file manager i see all the right files for a linux distro (have seen alot of them).

    I have tried formating the SD card to both EXT2 and EXT3 in Gparted before burning the image using the diffrent methods above, no luck though.

    I can’t rule out hardware failure on the RP, or insuficient powersupply (have tried alot of different methods though, TV’s USB, cellphone charger etc.)

    Further thoughts are the DD command, i left out the bs=<byte size> part of it, maybe that’s it.

    Any suggestions from you linux users out there would be great.

    Thanks for a cool project and making it available to us!

    #84412
    Profile photo of buzz
    buzz
    Keymaster

    the image contains partitions and should be written to the main sdcard block device device, not a partition of said device. so if you device is /dev/sdb it should be written to that not /dev/sdb1

    sdb1 would have been partition 1 of an existing partition table on the sdcard.

    However I recommend to avoid accidents you use dd if=image of=/dev/disk/by-id/YOURUSBDEVICE (so you don’t overwrite a system disk or something)

    for example on my system cards in my sdcard reader will show up as

    /dev/disk/by-id/usb-Generic_Storage_Device_00000000000006-0\:0
    (with existing partitions having -part1 and -part2 appended)

    • This reply was modified 2 years, 3 months ago by Profile photo of buzz buzz.
    #84414
    Profile photo of martinsson
    martinsson
    Participant

    Major facepalm 🙂 I don’t know what’s wrong with me, honestly, this was slightly embarrasing…

    root@debian-workstation:/home/martinsson# dd if=/home/martinsson/Downloads/RetroPieImage_ver2.3.img of=/dev/sdb
    6758400+0 records in
    6758400+0 records out
    3460300800 bytes (3.5 GB) copied, 1126.67 s, 3.1 MB/s

    Worked like a charm ! Huge thanks for pointing out my blunder buzz !

    Now for setting up my wireles keyboard as a controller and adding some rom’s, this might mean I’ll be back here demonstrating even more blunders 🙂

    #84415
    Profile photo of buzz
    buzz
    Keymaster

    Glad you got it sorted 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar