Launch ROM. Sound plays but no video display

Home Forums RetroPie Project Everything else related to the RetroPie Project Launch ROM. Sound plays but no video display

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 6 replies, has 2 voices, and was last updated by Profile photo of zziggy zziggy 3 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3250
    Profile photo of zziggy
    zziggy
    Participant

    Hi all:

    I have been tinkering with the retroarch.cfg file to try to get my TV (using HDMI) to display video for my roms with no success.

    DukeNukem displays fine, and I can launch roms, but my screen then goes blank (TV resets to default input screen when there is no input) and I can hear the main menu music. I can’t figure out what I need to do to get my games to display correctly. I’ve tried specifying aspect ratio, forcing different screen settings, and also just commenting everything out in retroarch.cfg.

    What am I doing wrong? I figured the video display would work out of the box. Current video setup looks like this:


    # Video driver to use. “gl”, “xvideo”, “sdl”
    # video_driver = “gl”

    # Which OpenGL context implementation to use.
    # Possible ones for desktop are: glx, x-egl, kms-egl, sdl-gl, wgl.
    # By default, tries to use first suitable driver.
    # video_gl_context =

    # Windowed xscale and yscale
    # (Real x res: base_size * xscale * aspect_ratio, real y res: base_size * yscale)
    # video_xscale = 3.0
    # video_yscale = 3.0

    # Fullscreen resolution. Resolution of 0 uses the resolution of the desktop.
    #video_fullscreen_x = 1366
    #video_fullscreen_y = 768

    # Start in fullscreen. Can be changed at runtime.
    # video_fullscreen = true

    # If fullscreen, prefer using a windowed fullscreen mode.
    # video_windowed_fullscreen = true

    # Which monitor to prefer. 0 (default) means no particular monitor is preferred, 1 and up (1 being first monitor),
    # suggests RetroArch to use that particular monitor.
    # video_monitor_index = 0

    # Forcibly disable composition. Only works in Windows Vista/7 for now.
    # video_disable_composition = false

    # Video vsync.
    # video_vsync = true

    # Attempts to hard-synchronize CPU and GPU. Can reduce latency at cost of performance.
    # video_hard_sync = false

    # Sets how many frames CPU can run ahead of GPU when using video_hard_sync.
    # Maximum is 3.
    # video_hard_sync_frames = 0

    # Inserts a black frame inbetween frames.
    # Useful for 120 Hz monitors who want to play 60 Hz material with eliminated ghosting.
    # video_refresh_rate should still be configured as if it is a 60 Hz monitor (divide refresh rate by 2).
    # video_black_frame_insertion = false

    # Use threaded video driver. Using this might improve performance at possible cost of latency and more video stuttering.
    # video_threaded = false

    # Smoothens picture with bilinear filtering. Should be disabled if using pixel shaders.
    video_smooth = false

    # Forces rendering area to stay equal to game aspect ratio or as defined in video_aspect_ratio.
    # video_force_aspect = true

    # Only scales video in integer steps.
    # The base size depends on system-reported geometry and aspect ratio.
    # If video_force_aspect is not set, X/Y will be integer scaled independently.
    # video_scale_integer = false

    # A floating point value for video aspect ratio (width / height).
    # If this is not set, aspect ratio is assumed to be automatic.
    # Behavior then is defined by video_aspect_ratio_auto.
    #video_aspect_ratio = 1.75

    # If this is true and video_aspect_ratio is not set,
    # aspect ratio is decided by libretro implementation.
    # If this is false, 1:1 PAR will always be assumed if video_aspect_ratio is not set.
    # video_aspect_ratio_auto = true

    # Forces cropping of overscanned frames.
    # Exact behavior of this option is implementation specific.
    # video_crop_overscan = true

    # Path to shader. Shader can be either Cg, CGP (Cg preset) or XML/GLSL format if support is enabled.
    # video_shader = “/path/to/shader.{cg,cgp,shader}”

    # Load video_shader on startup.
    # Other shaders can still be loaded later in runtime.
    # video_shader_enable = false

    # Defines a directory where shaders (Cg, CGP, XML) are kept for easy access.
    # video_shader_dir =

    # CPU-based filter. Path to a bSNES CPU filter (*.filter)
    # video_filter =

    # Path to a TTF font used for rendering messages. This path must be defined to enable fonts.
    # Do note that the _full_ path of the font is necessary!
    # video_font_path =

    # Size of the TTF font rendered.
    # video_font_size = 48

    # Attempt to scale the font to fit better for multiple window sizes.
    # video_font_scale = true

    # Enable usage of OSD messages.
    # video_font_enable = true

    # Offset for where messages will be placed on screen. Values are in range 0.0 to 1.0 for both x and y values.
    # [0.0, 0.0] maps to the lower left corner of the screen.
    # video_message_pos_x = 0.05
    # video_message_pos_y = 0.05

    # Color for message. The value is treated as a hexadecimal value.
    # It is a regular RGB hex number, i.e. red is “ff0000”.
    # video_message_color = ffffff

    # Video refresh rate of your monitor.
    # Used to calculate a suitable audio input rate.
    # video_refresh_rate = 59.95

    # Allows libretro cores to set rotation modes.
    # Setting this to false will honor, but ignore this request.
    # This is useful for vertically oriented games where one manually rotates the monitor.
    # video_allow_rotate = true

    # Forces a certain rotation of the screen.
    # The rotation is added to rotations which the libretro core sets (see video_allow_rotate).
    # The angle is <value> * 90 degrees counter-clockwise.
    # video_rotation = 0

    #3252
    Profile photo of zziggy
    zziggy
    Participant

    Fixed this issue by changing the run command in es_systems from 1 to 2. But now I am unable to use my controller in game, but I had the controller working for an entire game of 1943. I’m not sure why it doesn’t work anymore.

    #3253
    Profile photo of newsworthy
    newsworthy
    Participant

    I notice my TV switches from HD to VGA input when a ROM is loaded. Does your TV automatically switch it’s settings when it detects an input that changes?

    Looking at that file settings, have you tried setting your video resolution to the native for your TV to minimize the change?

    # Fullscreen resolution. Resolution of 0 uses the resolution of the desktop.
    #video_fullscreen_x = 1366
    #video_fullscreen_y = 768

    # Start in fullscreen. Can be changed at runtime.
    # video_fullscreen = true

    I’d try setting your fullscreen settings to your TV native (The one Emulation Station runs in) and fullscreen to true. Remove the # mark prior to the setting.

    Just an idea, I have no expertise in this.

    Retropie Beginner/Tinkerer

    #3254
    Profile photo of newsworthy
    newsworthy
    Participant

    Your TV native resolution could be one of the following:

    Full HD (NTSC/PAL) 1920×1080
    HD (NTSC/PAL) 1280×720
    SD (NTSC) 720×480
    SD (PAL) 720×576

    Best of luck. 🙂

    Retropie Beginner/Tinkerer

    #3267
    Profile photo of zziggy
    zziggy
    Participant

    Yeah I tried that but it looks like I didn’t enter the correct resolution.

    I ended up fixing the controllers by defaulting the config and remapping the keys again. But now I have no sound! Goodness when does it end! I’ll report back soon, hopefully.

    #3272
    Profile photo of zziggy
    zziggy
    Participant

    Grr, I’m having no luck.

    My current config.txt

    # uncomment if you get no picture on HDMI for a default “safe” mode
    #hdmi_safe=1

    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1

    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16

    # uncomment to force a console size. By default it will be display’s size minus
    # overscan.
    #framebuffer_width=800
    #framebuffer_height=600

    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1

    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=2
    hdmi_mode=4

    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2

    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    config_hdmi_boost=4

    # uncomment for composite PAL
    #sdtv_mode=2

    #uncomment to overclock the arm. 700 MHz is the default.
    arm_freq=1000

    # for more options see http://elinux.org/RPi_config.txt
    core_freq=500
    sdram_freq=500
    over_voltage=4
    gpu_mem=384
    avoid_safe_mode=1
    force_turbo=0

    And my current audio settings on retroarch.cfg

    # Enable audio.
    audio_enable = true

    # Audio output samplerate.
    audio_out_rate = 44100

    # Audio driver backend. Depending on configuration possible candidates are: alsa, pulse, oss, jack, rsound, roar, openal, sdl, xaudio.
    #audio_driver = sdl

    # Will sync (block) on audio. Recommended.
    #audio_sync = true

    Any ideas? I’ve tried flipping just about every option.

    #3276
    Profile photo of zziggy
    zziggy
    Participant

    I ended up switching to RCA and everything works like a charm.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar