Kodi Addon: Internet Archive ROM Launcher (IARL)

Home Forums RetroPie Project Ideas for Further Enhancements Kodi Addon: Internet Archive ROM Launcher (IARL)

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of momaw27 momaw27 1 year, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #106686
    Profile photo of zachmorris
    zachmorris
    Participant

    Hello Everyone,

    I’ve written an addon for Kodi called the Internet Archive ROM Launcher. You can read more about it here.
    IARL
    I’ve got an RPi2, and put the most recent build of RetroPie onto it, then installed Kodi and installed my addon. It works pretty well for the most part, and you can currently set it up to automatically put games in the standard RetroPie folders, all you need is an internet connection. So far so good.

    What I’m looking to do to enhance my addon and RetroPie is to allow launching of games via Kodi and my addon. I’ve tried several things and can’t get it to work quite yet.

    Here’s what I’ve tried.
    1. Setup a shell script that the Kodi addon will call to launch games (NES game as an example here):

    curl -v -H "Accept: application/json" -H "Content-type: application/json" -X POST -d '{"id":1,"jsonrpc":"2.0","method":"Application.Quit"}' http://kodi@localhost:8080/jsonrpc
    
    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ nes "ROMPATH" &
    wait
    
    /opt/retropie/supplementary/runcommand/runcommand.sh 0 "kodi-standalone" "kodi"

    But that doesn’t quite work. After Kodi exits, EmulationStation starts back up and I don’t see the game launch. Also just trying the command via ssh without Kodi running:
    /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ nes "ROMPATH"

    Will launch the game, but it will be ‘behind’ emulationstation. If I exit ES by hitting F4 I see my game popup. In addition, I’ve tried several ways to launch Kodi. Depending on how I do it, after it exits I get the dreaded black screen.

    Any shell script experts out there that can help? I think the Internet Archive ROM Launcher would be a pretty awesome addition to the RetroPie project.

    Some screenshots of IARL for good measure:
    Screenshot 1

    Screenshot 2

    Screenshot 3

    • This topic was modified 1 year, 7 months ago by Profile photo of zachmorris zachmorris.

    #106721
    Profile photo of momaw27
    momaw27
    Participant

    Wow dude, this looks pretty awesome! Looking forward to seeing how this develops.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar