keymap changed after exit emulator

Home Forums RetroPie Project Everything else related to the RetroPie Project keymap changed after exit emulator

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of tafazzi87 tafazzi87 2 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #11997
    Profile photo of tafazzi87
    tafazzi87
    Participant

    hi guys, i’ve retropie 2.1 and i set my joystick for exit from an emulator. when i exit from pifba or pisnes, keymap for emulationstation changed and i’ve to plug out my joystick and plug in again and after that it works again. For example if i press dpad down, it select like A button. how can i fix that? or it is a bug for new emulation station?
    P.S. sorry for my english

    #12024
    Profile photo of tafazzi87
    tafazzi87
    Participant

    maybe it’s because when i exit from a game, i’ve Segmentation fault on game’s rom ?

    #12049
    Profile photo of nemo93
    nemo93
    Participant

    hi tafazzi!

    this is really weird. What controller are you using? Perhaps you could try to remove the es_input.cfg file from the .emulationstation directory? After the deletion of this file, reboot your raspberry and EmulationStation should bring up the input configuration menu where you’ll be asked to press various buttons on your controller.

    in order to remove the file, locate the “.emulationstation” folder located in the home directory (/home/pi/). The es_input.cfg file should be there. on the command line you could type the following:

    $ rm /home/pi/.emulationstation/es_input.cfg
    $ sudo reboot
    

    hope this helps.
    cheers,

    #12051
    Profile photo of tafazzi87
    tafazzi87
    Participant

    i’m using ps2 controller with an usb adapter…i’ve try to remove es_input.cfg but i’ve same problem when i exit from an emulator…
    i press select+start to exit from game by my controller and i’ve this output :

    
    =====================================================
    performance
    Powering on HDMI with explicit settings (CEA mode 1)
    /opt/retropie/supplementary/runcommand/runcommand.sh: line 23: 2233 Segmentation error /opt/retropie/emulators/pifba/fba2x /home/pi/RetroPie/roms/fba/game.zip
    Powering on HDMI with preferred settings
    ondemand
    =========================================
    
Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar