Keyboard settings is wrong ! HELP PLZ!

Home Forums RetroPie Project Everything else related to the RetroPie Project Keyboard settings is wrong ! HELP PLZ!

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 21 replies, has 2 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 2 years, 11 months ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #6570
    Profile photo of sn00wman86
    sn00wman86
    Participant

    I was at my work when i set me Keyboard settings (up/down/left/right/etc)

    And i get something wrong when i set this keys so now i can move Up/donw/left/right and i need to set this key settings again. How do i reset them so i get like it was from the first time i start Retropie. (Only what/need to reset the keyboard choose. )

    #6571
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hi, from terminal (f4) run:

    rm ~/.emulationstation/es_input.cfg

    then reboot to reset ES controls

    If you have found the solution to your problem please mark the topic as resolved.

    #6572
    Profile photo of sn00wman86
    sn00wman86
    Participant

    Thanks and my next question is how can i make my Keyboard to be swedish, Right now i have us in the program πŸ™ Were hard to find the right key πŸ˜› and wish key is ~ i only find that one but it’s on the top not middle πŸ˜›

    #6573
    Profile photo of sn00wman86
    sn00wman86
    Participant

    I fix that problem with the keys πŸ™‚ How to fix the problem like the pics shows ?

    When i test it everyting works but cant not sve πŸ™

    Attachments:
    #6575
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Make sure /home/pi/RetroPie/configs/all/retroarch.cfg exists then type this:

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    And try joypad config again

    If you have found the solution to your problem please mark the topic as resolved.

    #6578
    Profile photo of sn00wman86
    sn00wman86
    Participant

    how do i write to come to /home/pi/RetroPie/configs/all/retroarch.cfg right now i am in pi@raspberrypi ~$

    Write like you do to a noob. never work with dos or what it call πŸ˜›

    #6579
    Profile photo of sn00wman86
    sn00wman86
    Participant

    and i write like this in the file # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/ ? Is it some special place i need to write it on ?

    #6580
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    yes just type it in the terminal after pi@raspberrypi ~$

    If you have found the solution to your problem please mark the topic as resolved.

    #6581
    Profile photo of sn00wman86
    sn00wman86
    Participant

    so in pi@raspberrypi ~$ i type /home/pi/RetroPie/configs/all/retroarch.cfg and ENTER to see if it exists and after in the file i type:

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    and save and after try the controll ?

    But what do i do if that file not exist ? :S

    #6582
    Profile photo of sn00wman86
    sn00wman86
    Participant

    When i write: /home/pi/RetroPie/configs/all/retroarch.cfg
    in pi@raspberrypi ~$’
    I get a messenger like :
    -bash: /home/pi/RetroPie/configs/all/retroarch.cfg: Permission denied

    #6587
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    to create retroarch.cfg type in terminal (after pi@raspberrypi ~$):

    nano /home/pi/RetroPie/configs/all/retroarch.cfg

    Then press ctrl x and save. Then type:

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    then run joypad config again

    If you have found the solution to your problem please mark the topic as resolved.

    #6588
    Profile photo of sn00wman86
    sn00wman86
    Participant

    # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    Is it Space between xml and /home ?

    #6589
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    yes

    If you have found the solution to your problem please mark the topic as resolved.

    #6590
    Profile photo of sn00wman86
    sn00wman86
    Participant

    I get [ Error Writing /home/pi/RetroPie/configs/all/retroarch.cfg: No such file or directory ] when i save it ^^ So guess i have no Permission so save it ^^

    #6591
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    you get that error after running joypad config?

    If you have found the solution to your problem please mark the topic as resolved.

    #6592
    Profile photo of sn00wman86
    sn00wman86
    Participant

    after i have write it on the doc. and try to save it. that say like i write.

    #6608
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    you need to place a retroarch.cfg in /home/pi/RetroPie/configs/all/retroarch.cfg

    Use nano:

    nano /home/pi/RetroPie/configs/all/retroarch.cfg

    Type a random character and ctrl x and press y to save.

    If you have found the solution to your problem please mark the topic as resolved.

    #6609
    Profile photo of sn00wman86
    sn00wman86
    Participant

    So now i have make a new directory <strong (/home/pi/RetroPie/configs/all/)

    Have Create retroarch.cfg and have write # cp /home/pi/RetroPie-Setup/supplementary/settings.xml /home/pi/supplementary/supplementary/ES-config/

    And I press ctrl + X to save it and the program ask my if i want to save it and i press Y and after that i get a messenger like this: [ Error writing /home/pi/RetroPie/configs/all/retroarch.cfg: Permission Denied

    Okey Now i have fix so i can save it. and after i save and reboot the system i try to config the controll but i get Script Error!!!

    #6615
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Ok I have no idea why this isn’t working, the other way to set your pad up is to edit retroarch.cfg manually.

    See this thread for instructions: http://blog.petrockblock.com/forums/topic/input-configuration-script-fails-bindings-are-off/

    If you have found the solution to your problem please mark the topic as resolved.

    #6617
    Profile photo of sn00wman86
    sn00wman86
    Participant

    ok πŸ™‚ Thanks πŸ™‚ I have reinstall Retropie know so will put that inside πŸ™‚

    And everything i not find in the lite i add to it ?

    like this for a exemple :
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”

    only find without _axis in the list.

    input_player1_l_x_plus

    #6655
    Profile photo of sn00wman86
    sn00wman86
    Participant

    This have i done now.
    1. cd RetroPie-Setup and go to sudo ./retropie_setup.sh
    2. Take Choose 2. Source-based INSTALLATION (16-20 hours)
    3. Choose 4. UPDATE RetroPie Setup script
    4. Go in to Choose 3. SETUP.
    5. Choose 16. Install drivers for Xbox3600 Wired Controll
    6. Choose 19. Register Controll for RetroArch emulation

    And i Reboot some times from 1 – 6. After all this was finnish I Config the control for the Emulationstation Meny, and it’s working.

    And next step i did was go to Input Configuration in emulationstation. And set all keys and this time i can save the the keys i choose with the Xbox360 Controll. and after I have save it I Exit. And reboot. and after that i try to start Snes Emulation. But when i start a game only the keyboard works not the Xbox360 Control.

    Can i use that instructions for this problems to or do i need some other instructions?

    #6673
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Unzip and place this retroarch.cfg I have attached in /home/pi/RetroPie/configs/all/

    To do this:

    Download Filezilla: https://filezilla-project.org/

    Connect your Pi to your network via ethernet. In terminal on Pi type: sudo ifconfig

    Note the IP address of the Pi starting 192.168 after ‘inet addr’

    Open Filezilla, in top left box ‘host’ type the IP address you just noted.
    Then in ‘username’ box type pi
    In ‘password’ box type raspberry
    In ‘port’ box type 22

    Press ‘quickconnect’
    In ‘remote site’ box on right side navigate to: home/pi/RetroPie/configs/all/

    Drag the retroarch.cfg into the ‘remote site’ box to copy over.

    Start your emulator and the controls should work, they’re set up for a xbox 360 pad. If they don’t work run:

    nano /home/pi/RetroPie/configs/all/retroarch.cfg

    and change input_player1_joypad_index = “0” to input_player1_joypad_index = “1” (or possibly 2)

    You can also modify the controls if you wish by changing the button numbers.

    I have set the β€˜hotkey’ button to the β€˜back’ button on the pad. This means that if you press the back button and specific buttons you can access different options:

    back & start = emulator exit
    back & home button = Retroarch GUI (useful for setting frameskip)
    back & left shoulder button = load save file
    back & right shoulder button = save file
    back & left trigger = select save state decrease
    back & right trigger = select save state increase

    Hope this helps

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 22 posts - 1 through 22 (of 22 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar