Keyboard Input Not Being Saved

Home Forums RetroPie Project Everything else related to the RetroPie Project Keyboard Input Not Being Saved

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 12 replies, has 3 voices, and was last updated by Profile photo of werebox3333 werebox3333 1 year, 8 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #103900
    Profile photo of werebox3333
    werebox3333
    Participant

    Alrighty, so here’s how this goes. I SSH into my Pi to edit the /opt/retropie/all/retroarch.cfg file, and I set it to what I want all my keys mapped to. The problem? It saves, but when I restart my Pi, the emulators ignore it. I’ve tried the in-game control configuration for GPSP, but it never saves, either. I’m using a standard USB keyboard, which will soon be replaced by GPIO Input, I have RetroPie 3.0, and I’m using my main game hub as a Raspberry Pi A+ but doing setup on my B+. Any help would be appreciated!

    #103901
    Profile photo of buzz
    buzz
    Keymaster

    http://blog.petrockblock.com/forums/topic/suggestion-to-get-support-with-your-problems/

    without at least the config you are talking about I cannot advise.

    #103902
    Profile photo of buzz
    buzz
    Keymaster

    Please post any configs to pastebin.com or similar and reference them.

    #104000
    Profile photo of werebox3333
    werebox3333
    Participant

    I found out the problem. GPSP is standalone, and has it’s own config file. It says it exists in /opt/retropie/emulators/gpsp/ but when I try to open the config file it says “file does not exist”.

    #104001
    Profile photo of herbfargus
    herbfargus
    Moderator

    While in the emulator press F10 and configure it from there

    https://github.com/RetroPie/RetroPie-Setup/wiki/Game-Boy-Advance

    #104002
    Profile photo of werebox3333
    werebox3333
    Participant

    Yeah, but my problem is that the controls don’t save. I don’t want to re-configure them every time I want to play a game, and my 8 year old couldn’t do that either.

    #104003
    Profile photo of herbfargus
    herbfargus
    Moderator

    I thought there was a save config option in the F10 menu. I don’t have access to my pi right now but I’ll check again once I do.

    #104004
    Profile photo of werebox3333
    werebox3333
    Participant

    As far as I saw, there isn’t. I can check again.

    #104005
    Profile photo of werebox3333
    werebox3333
    Participant

    Well, I change it, and exit gPSP, and it says “config file missing”.

    #104008
    Profile photo of herbfargus
    herbfargus
    Moderator

    I think you may have found a bug. I tested it and got the same results. I thought that it was supposed to save to /opt/retropie/emulators/gpsp/gpsp.cfg after changing controls but it didn’t seem to do anything. I shall open a ticket on github.

    https://github.com/RetroPie/RetroPie-Setup/issues/957

    • This reply was modified 1 year, 8 months ago by Profile photo of herbfargus herbfargus.
    #104010
    Profile photo of werebox3333
    werebox3333
    Participant

    Thanks so much Herb!

    #104011
    Profile photo of herbfargus
    herbfargus
    Moderator

    Thank jools (aka buzz)- he’s the one who actually knows how to fix things 😛

    #104012
    Profile photo of werebox3333
    werebox3333
    Participant

    Ah, yes, I’ll have to get on GitHub and thank him!

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar