JZIntv issue exiting back to emulation station UI

Home Forums RetroPie Project Everything else related to the RetroPie Project JZIntv issue exiting back to emulation station UI

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of thedishking thedishking 2 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #84187
    Profile photo of thedishking
    thedishking
    Participant

    Hello,

    I have almost successfully installed RetroPie 2.3 on a B+.

    Everything works great, except for the abity to exit back to the Emulation Station launcher.

    When I press F1 on the keyboard, I get a black screen and it is “stuck” there.

    I don’t know “where” the system is at after I press F1; as all UI is gone from the screen and the unit appears to be locked up.

    The only way I have found to get back to the “launcher” is to remove the power to the Pi and reboot it. I am unable to get to a terminal by pressing F4.

    I have tried many different things including writing the image to a different card, using a different keyboard, not enabling wireless settings, etc., and am truly stuck.

    I have tried building this on a B as well, and have the same results.

    I am running the memory split at 256.

    I can pres Esc on the Atari emulation and it goes back to the launcher just fine.

    I have also tried the ./jzintv from a prompt, and am able to launch a game, and press F1 to leave the game.

    Since it works fine from a terminal session, I think JZIntv works just fine. I think there is something with regard to the Emulation Station that is causing this.

    I am running this on a B+ and have the Ultimate Intellivision Interface for the controllers connected as well.

    Could someone please help me get pointed in the right direction?

    Thank you very much!!!!!!

    #84201
    Profile photo of dudleydes
    dudleydes
    Participant

    This is a long-standing issue regarding ES2 and a number of emulators. You can read the full thread here.

    https://github.com/Aloshi/EmulationStation/issues/206

    There are 2 fixes you could try.

    1. Force VGA by editing the RPi config file and uncommenting the lines hdmi_group=1, hdmi_mode=1.

    2. Try lonehelmet’s fix posted on 18 Sep 2014 at the EmulationStation issue thread.

    #84203
    Profile photo of Floob
    Floob
    Moderator

    If you get a black screen when exiting ES, you can hold Alt-F2 to get a separate display up, then ALT-F1 to flip back to the original that should then show a display.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84264
    Profile photo of thedishking
    thedishking
    Participant

    Thank you very much for the advice.

    I was able to shut down Emulation Station and restart it, and it does work perfectly.

    Would it be possible to write a script that shuts down Emulation Station and then starts it back up?

    Apparently others are experiencing this issue.

    I am trying a few other things and will report back with updates.

    While it would be nice to have emulation of other systems, my preference is to get Intellivision working a perfectly as possible.

    I have several Intellivision Flashback systems that I am upgrading with the Pi, and would like for them to work as intended.

    Thank you again for your help!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar