JUYAO controller – not correctly recognized by Raspberry Pi?

Home Forums RetroPie Project Controller Configuration in RetroPie JUYAO controller – not correctly recognized by Raspberry Pi?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 4 replies, has 4 voices, and was last updated by Profile photo of sid723 sid723 1 year, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #103860
    Profile photo of fizz

    Hi there.

    I’m new to this forum, so I start by saying hi! I hope someone can help me, because I’m stuck.

    Pi Model: B rev 2
    RetroPie Version Used: 2.6.0
    From: SD Image
    Devices connected: Arcade controller + USB keyboard
    Controller used: JUYAO
    Error messages received: No error message, but only one controller is recognized.
    Guide used: Did not find any guides on this particular problem
    File: No
    Attachment of config files: Tell me if you need anything in particular
    How to replicate the problem: ??

    I have bought a JUYAO arcade controller for connection of 2 arcade joysticks + buttons to the Raspberry Pi. However, the raspberry does not seem to recognize the control board.

    I have done the following:
    I have created a file /etc/udev/rules.d/00-arcadejs.rules
    Where I’ve put the following:
    ATTRS{name}=="Arcade Controller JUYAO Dual Arcade",ACTION=="add",ENV{ID_INPUT_TABLET}="0",ENV{ID_INPUT_JOYSTICK}:="1"

    In this way the Raspberry is recognizing one of the two controllers at least, and I can get it to work with the RetroPi. But only one controller, not two.

    I cannot manage to configure the second controller.

    If I plug the controller into my computer (Win) it sees two joysticks and double sets of buttons, so I think the connections are correct.

    Does anyone have any ideas on this? Is there anything I can change in the 00-arcadejs.rules file in order to add another controller?

    Thanks in advance

    Profile photo of helpman

    I also bought a juyao controller. It’s still on its way so I couldn’t test this, but what I’ve found is you need to add a rule file (as you already did)

    cd /etc/udev/rules.d/
    sudo nano 00-arcadejs.rules
    This will create a file called 00-arcadejs.rules in the correct directory
    In the window that comes up (nano file editor) enter:
    ATTRS{name}==”Arcade Controller JUYAO Dual Arcade”,ACTION==”add”,ENV{ID_INPUT_TABLET}=”0″,ENV{ID_INPUT_JOYSTICK}:=”1″

    Press CTRL + X and save the file when asked.

    … AND…
    Edit the file
    And add this at the bottom
    Then reboot the raspberry

    Hope this works! Soon I’ll have to do it too 🙂

    Profile photo of Dinofly


    I can’t get my device to work. I tried adding the udev rule and the cmdline.txt usb quirk but nothing changed.
    I wonder, what is the string that should be used in the udev rule to identify the device ? My device does not seem to have the same name than the one i see on different topics when searching Google.
    For example, its name in “lsusb” is… empty:

    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 413c:1010 Dell Computer Corp.
    Bus 001 Device 005: ID 0314:0328
    Bus 001 Device 007: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
    Bus 001 Device 006: ID 413c:2110 Dell Computer Corp.

    Here is the full output of “lsusb -v”: http://pastebin.com/54jvby3W
    Notice this:

    iManufacturer           1 D_R_M
    iProduct                2 JUYAO Dual Arcade

    I’ll try with the following udev rule to match with the name of my device:

    Edit: still no luck with this one 🙁
    Any idea ?

    • This reply was modified 1 year, 1 month ago by Profile photo of Dinofly Dinofly.
    • This reply was modified 1 year, 1 month ago by Profile photo of Dinofly Dinofly.
    Profile photo of Dinofly

    OK problem solved.
    The udev configuration should use the name that “evtest” outputs. evtest is not installed by default, so i just apt-get install evtest to get it.

    I fixed the rule like this:
    ATTRS{name}=="D_R_M JUYAO Dual Arcade",ACTION=="add",MODE="0666",ENV{ID_INPUT_TABLET}="0",ENV{ID_INPUT_JOYSTICK}="1"

    And i added a “usbquirks” item to the /boot/cmdline.txt file (at the end of the existing line, not on a new line!) :

    Profile photo of sid723

    I bought a similar usb dual arcade device on ebay. I thkught it was the Xin-Mo type, but when I hooked it up to the RasPi, it said the type was ‘JUYAO_2_PLAYER_ARCADE’ type. Mine has 22 pins on both sides of the board for each of the 2 players. My issue is that I want to play Mortal Kombat or Street fighter, but I can only get 2 kick and 2 punch buttons to work along with the joysticks. Those games should have 3 punck and kick buttons. Does anyone know how I can change the config to make all 3 kick and punch buttons to work?
    Appreciate any advice.

    Sent from my GT-P3113 using Tapatalk

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar