Issues w/ Input Configs

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of flickcorp flickcorp 2 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #26671
    Profile photo of flickcorp
    flickcorp
    Participant

    I have a basic config that works for all emulators that I have tried but for some for example SNES I would like to flip the A & B and X & Y which doesn’t look like it would be difficult if my configs worked properly unless I am doing them wrong here is some brief code snippets.

    Here is my global config:

    /opt/retropie/configs/all/retroarch.cfg

    input_player1_b_btn = "2"
    input_player1_y_btn = "3"
    input_player1_a_btn = "1"
    input_player1_x_btn = "0"

    Here is my SNES config:
    /opt/retropie/configs/snes/retroarch.cfg

    input_player1_b_btn = "1"
    input_player1_y_btn = "0"
    input_player1_a_btn = "2"
    input_player1_x_btn = "3"

    Raspberry Pi B 512mb
    Generic 64gb SD
    Overclock Turbo

    Raspberry Pi B+ 512mb
    Generic 128gb MicroSD
    Overclock Turbo

    Raspberry Pi2 B 1gb
    Samsung Evo 16gb MicroSD
    Overclock Pi2

    #26962
    Profile photo of lunarkingdom
    lunarkingdom
    Participant

    I believe there is a way to put an emulator specific config file in the emulator specific file so you can say use a ps1 controller with psx and a nintendo controller for nes but someone with a little more knowledge will have to chime in on this. I assume you can copy your tetrarch.cfg file and put it in there then rewrite it like you have shown BUT like I said I have not done it so lets wait till someone who has can share the knowledge.

    #27187
    Profile photo of flickcorp
    flickcorp
    Participant

    Yea according to the headers of the retroarch.cfg in the folders other then all says anything you do will override I believe this would work if it did just that but for me it doesn’t.

    What seems to happen everytime I reboot it loads a default out of the blue even if I change something it just reverts back. I wonder if it may have something to do with my sd card I am running a 64GB micro sd with an adaptor.

    Thanks for the speedy reply…

    Raspberry Pi B 512mb
    Generic 64gb SD
    Overclock Turbo

    Raspberry Pi B+ 512mb
    Generic 128gb MicroSD
    Overclock Turbo

    Raspberry Pi2 B 1gb
    Samsung Evo 16gb MicroSD
    Overclock Pi2

    #31625
    Profile photo of jamcinty
    jamcinty
    Participant

    I’m having the same issue. Did you get it resolved?

    #31697
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    I have encountered this issue as well, it could be a bug in ES.

    If you have found the solution to your problem please mark the topic as resolved.

    #31993
    Profile photo of flickcorp
    flickcorp
    Participant

    nope still not resolved just keep changing and eventually the main one will stay not sure on the others kinda just settled until theres a fix out there

    Raspberry Pi B 512mb
    Generic 64gb SD
    Overclock Turbo

    Raspberry Pi B+ 512mb
    Generic 128gb MicroSD
    Overclock Turbo

    Raspberry Pi2 B 1gb
    Samsung Evo 16gb MicroSD
    Overclock Pi2

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar