Issue with controler and retropie 3

Home Forums RetroPie Project Controller Configuration in RetroPie Issue with controler and retropie 3

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 9 replies, has 4 voices, and was last updated by Profile photo of Floob Floob 1 year, 11 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #98495
    Profile photo of vincentouioui
    vincentouioui
    Participant

    Hello everyone,

    I encoutered some problem with retropie v3 and my controler : http://www.smallcab.net/kit-joysticks-zippy-boutons-interface-usb-p-387.html

    The buttons are OK, but my joystick is very sensitive. I push down once, it looks like 5 ! (try on the main menu)

    I read a topic which mentionned a kernel flash, but is it compatible with my version ?
    So i have to buy another adaptateur, or i have to use GPIO ?

    Thanks a lot,

    #98519
    Profile photo of trobba
    trobba
    Participant

    I am also having problems on my raspberry pi 2 with retro pie v3.0

    I have a usb snes controller which works perfectly in the main menu. I have programmed the controller for use in retroarch but when I play a game the d pad doesn’t work but every other button does.

    Please help

    #98683
    Profile photo of vincentouioui
    vincentouioui
    Participant

    I installed the custom kernel found here, but it’s not working, can’t boot on retropie, back to original OS, & still not working

    need help 🙁

    Thx

    #98845
    Profile photo of chiefer
    chiefer
    Participant

    Hi guys first time poster 🙂

    Thought I wouldn’t bother with a new thread as this seems apt.

    I tried posting on the EmulationStation forums without reply, and have done as much search as I can.

    Am running Retro Pie 3 on a RPB with a NES USB controller

    I’ve mapped the retroarch buttons everywhere I can within the interface and the ‘B’ registers, but in game for some reason the B button doesn’t work.

    Any ideas?

    #98853
    Profile photo of chiefer
    chiefer
    Participant

    Tried on 2.6 image as well and same problem.

    Def a software issue.

    #98871
    Profile photo of Floob
    Floob
    Moderator

    Does it work in jstest?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98883
    Profile photo of chiefer
    chiefer
    Participant

    Thanks for the reply and video link.

    Yep done in 2.6 yesterday and fresh install back with 3 and same thing, all looks and registers OK, exactly as per your video.

    #98897
    Profile photo of Floob
    Floob
    Moderator

    When you say the B button doesnt work, does one of the other buttons act as B – obviously only 2 will work with the NES.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98934
    Profile photo of chiefer
    chiefer
    Participant

    Nope, I tested mapping B to another input and no luck, all this despite being registered correctly using jstest which is odd.

    #99033
    Profile photo of Floob
    Floob
    Moderator

    Have you tried this in a couple of different games?
    Do you have another controller to try it out with?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 10 posts - 1 through 10 (of 10 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar