is there a list of roms that work properly?

Home Forums RetroPie Project Everything else related to the RetroPie Project is there a list of roms that work properly?

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 13 replies, has 5 voices, and was last updated by Profile photo of leeroydix123 leeroydix123 3 years, 10 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2027
    Profile photo of leeroydix123
    leeroydix123
    Participant

    hello there, kinda new to raspberry pi and linux managed to get emulatiostation/retroarch, currently only have snes games and running into a few issues (no music donkey kong, sound issues mortal kombat, mario 3 on all stars cant seem to move when the game starts up on world map)
    so what i’m asking is, is here a list of roms that work 100% or are these issues on my side? oh and also been trying to get a better quality of picture on my tv running emustation (1080p hd tv) was wondering what setting i need to configure.

    thanks in advance to anyone that lends me a hand!

    #2028
    Profile photo of anakaine
    anakaine
    Participant

    The issues of working roms is a contentious issue, and one that will probably have to be solved on your end. As a small but widely viewed development community, it would be improper to recommend what roms works, and from where you can obtain them, as this could be seen as advocating piracy. Remember, generally speaking you must own the game in order to play it (Unless you’re in a country such as Australia, where you’re still not technically allowed to have the ROMs, since you didn’t purchase the rom, but the cartridge).

    With Super Mario Bros 3, I found that it was a complete pain to use until my controllers were properly configured. Then, if you’ve accidently tapped a button on the world / level screen and changed between pink/blue bars at the bottom, it wont let you move. Tap button (B maybe?) again to change bar colours, then move.

    Are you running HDMI? I found the 1.6 disk image to provide superb quality on a 55″ 1080p TV when running over HDMI, by default.

    #2030
    Profile photo of leeroydix123
    leeroydix123
    Participant

    i am running 1.5 disk image through hdmi, maybe it is my controller which i still cant get to work on the emulator menu just in games. (its a cheap snes usb)

    #2031
    Profile photo of jplaj
    jplaj
    Participant

    Can you describe what happens when you try to load a rom? Does it freeze, crash back to the ES Menu, or is it something else? It’s possible that it’s a configuration issue and not the roms.

    If you hit F4 after trying to load one, tell us what you see on the log screen.

    In addition, if you’re trying to run MAME, I’ve found that the other .zip files in the directory affect the one you’re trying to run. If you keep a few different versions of the same game in the MAME rom folder, you’re more likely to find one that works (whereas the same file might not load if it’s the only one there).

    #2034
    Profile photo of leeroydix123
    leeroydix123
    Participant

    oh no sorry if i’ve mislead, i can work roms just a lot of them dont seem to be running at 100% i.e little sound issues or issues with controller having trouble with a few genesis games recognising my controller aswell. and as for super mario allstars it just doesn’t respond to any buttons in super mario 3 once ingame and on the world map which is a shame because thats probably my fav snes game.

    #2035
    Profile photo of karloss
    karloss
    Participant

    super mario all stars (i assume thats what your playing) switches over and wants you to use control 2 after getting to the world map, for some reason..

    #2044
    Profile photo of jplaj
    jplaj
    Participant

    I have the same issue with Mario All Stars. If you have two controllers, just switch over to player 2 (and Luigi should work with the player 1 controller). I don’t know why it does that.

    Are you having trouble with all genesis games or do some of them work? When configuring the controller, the retroarch.cfg file works for most systems, but you need to alter the dgen.cfg in the same folder. (/home/pi/RetroPie/configs/all/)

    It doesn’t use exactly the same language as the retroarch.cfg, but if you just replace the number listed with the number that corresponds to your controller, it should work. For example, what’s listed in retroarch.cfg as:

    input_player1_a_btn = “1”
    input_player1_b_btn = “2”

    Will be listed in dgen.cfg as:

    joy_pad1_b = joystick0-button2
    joy_pad1_c = joystick0-button1

    (Or whatever buttons you’d like to assign)

    As for your other problems, that’s probably an emulator issue. A lot of emulators won’t play games 100% the same as the original system could, and each program has its own quirks. The same rom on one emulator might have crackling sound, but on another emulator the sound might work, but there might be layering problems.

    Just try a few different roms for the same game until you find one with as few problems as possible. It may not be perfect, but hopefully you’ll be able to find one that you can enjoy despite the flaws.

    #2045
    Profile photo of leeroydix123
    leeroydix123
    Participant

    ahh ok thanks for the response, it is only some roms that don’t work 100% so maybe will try a few others and will have a look at changing that file, cheers.

    #2052
    Profile photo of leeroydix123
    leeroydix123
    Participant

    didn’t want to make another thread but ive found another issue i can’t seem to get around, certain roms missing from the list on the emulator. I have a 79 roms and only 58 available on the emulator list all the same type of file unzipped etc whats causing this issue?

    #2054
    Profile photo of jplaj
    jplaj
    Participant

    I’m not sure what could be causing that. Are all the file extensions in the same folder, not in any subfolders? Did you notice this problem, by any chance after running ES Scraper? Are some of the file extensions in different cases (e.g. .nes vs .NES)? Did you experience any errors when copying roms into the directory?

    If none of these are the case, I suggest starting a new thread to get more targeted help from the forum.

    #2078
    Profile photo of karloss
    karloss
    Participant

    There is a google spreadsheet I have seen floating about, that I added to, with working roms and such, i will see if i can find it and will post a link..

    #2096
    Profile photo of leeroydix123
    leeroydix123
    Participant

    I’m not sure what could be causing that. Are all the file extensions in the same folder, not in any subfolders? Did you notice this problem, by any chance after running ES Scraper? Are some of the file extensions in different cases (e.g. .nes vs .NES)? Did you experience any errors when copying roms into the directory?

    If none of these are the case, I suggest starting a new thread to get more targeted help from the forum.

    all same folder no problems copying over etc certain ones just dont show up.

    #2097
    Profile photo of petrockblog
    petrockblog
    Keymaster

    didn’t want to make another thread but ive found another issue i can’t seem to get around, certain roms missing from the list on the emulator. I have a 79 roms and only 58 available on the emulator list all the same type of file unzipped etc whats causing this issue?

    Maybe this is a bug of Emulation Station. You might want to report this at https://github.com/Aloshi/EmulationStation/issues?page=1&state=open.

    #2173
    Profile photo of leeroydix123
    leeroydix123
    Participant

    fixed the issue in the end was problems with the files, i have an issue now though i still cant seem to figure out how to stop my roms from switching to 640X480 when i load them up.

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar