Inverted axes only with FBA

Home Forums RetroPie Project Controller Configuration in RetroPie Inverted axes only with FBA

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of ftbz ftbz 1 year, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #103986
    Profile photo of ftbz
    ftbz
    Participant

    Hello folks!

    I built my own arcade cabinet and I’m stuck with an annoying problem with FBA. My joystick axis are inverted, this problem only appears with FBA. On the main menu and on the SNES emulator, it’s working fine.

    I’ve searched on the forum and didn’t find a solution for the problem.

    I hope that someone here can help me, because everybody here are cool :P. Any idea?

    Some informations:
    Raspberry Pi 2
    retropie-v3.0-rpi1.img
    jstest dectets two axes (-32767 to 32767)

    Thanks!

    #103988
    Profile photo of herbfargus
    herbfargus
    Moderator

    It would be helpful if you specified which emulator you are using. See this page:

    https://github.com/RetroPie/RetroPie-Setup/wiki/FinalBurn-Alpha

    If it’s pifba, then switch the 0 and 1 under the joystick axis options in fba2x.cfg… If that doesn’t work try making one or both negative.

    #104032
    Profile photo of ftbz
    ftbz
    Participant

    Thanks for the tips. I’m using pifba and I tried the different settings you mentioned in fba2x.cfg and nothing was working.

    Disappointed after a week of tests, I tried Recalbox yesterday evening (after reading a post here) and everything is working fine with it.

    Thanks again, I will try RetroPie again in a second time.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar