Input Mapping for Dip Switches / Service Mode on lr-imame4all

Home Forums RetroPie Project Controller Configuration in RetroPie Input Mapping for Dip Switches / Service Mode on lr-imame4all

RetroPie has a new website and forum. Please visit https://retropie.org.uk/ for the new site. The new forum is located at https://retropie.org.uk/forum/. This forum is left here as a read-only archive.

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of beyondsanity beyondsanity 1 year, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #96825
    Profile photo of cyberiano
    cyberiano
    Participant

    Hi guys!

    After hours of research and testings I still can’t figure it out how to access to “Dip Switches” menu on lr-imame4all.

    On the other emulators simply pressing the Tab key shows the MAME menu and you can select “Dip Switches”.

    I looked the whole retroarch menu settings and options, there’s nothing there.

    Finally I have MK2, MK3 and UMK3 working pretty well on the raspberry pi 2 B+ with lr-imame4all, but I need to increase the volume (by default is TOO LOW, barely audible), and this only can be done from the service mode menu (with the dip switches).

    #96856
    Profile photo of Floob
    Floob
    Moderator

    I think it might be coin + start. But then that is the default to restart in retroarch, so maybe turn off hotkeys then try it?

    As an aside are you tempted to try the non libretro mame4all, or even fba-libretro on the Pi?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #96863
    Profile photo of cyberiano
    cyberiano
    Participant

    Thanks Floob! I will try that one.

    I use the non libretro mame4all as default, but that version can’t run MK2, Mk3 and UMK3 (Segmentation fault error), these games are “essentials” for me 🙂 hehe.

    #96867
    Profile photo of Floob
    Floob
    Moderator

    Thats weird, if they run in lr-imame4all they should run fine in mame4all, as they both use the 0.37b5 version.

    You could always try advance mame:
    http://blog.petrockblock.com/forums/topic/mame-versions-and-romsets-on-retropie/#post-92997

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #96883
    Profile photo of cyberiano
    cyberiano
    Participant

    Yes that’s weird indeed! And that’s what I thought at first but doesn’t work at all. I got surprised see that ROMs working on imame4all…

    In advmame runs but horrible slow. Is not an option.

    So, I just did what you said, disabling hotkeys and still can’t enter to mame menu pressing coin + start.

    It’s a shame but it seems that option it’s not available in imame4all libretro core.

    #96917
    Profile photo of shaedo
    shaedo
    Participant

    I was just about to make a thread on this exact same issue. 🙂

    I’ve also tried everything I can think of to get into the test/service menu on mame4all-libretro. I prefer to use retroarch for the shaders (the mame4all scanline shader is pretty poor) and for the extensive settings compared to mame4all.

    The cave shooter, ESP Ra.De. won’t progress past the initial mandatory test/service screen because I can’t exit it. All other cave shooters I’ve tried also start with the picture flipped upside down, which is something else that I need to get into the service/test menu for.

    I can also confirm that anything past the first Mortal Kombat, doesn’t work on mame4all.

    #96920
    Profile photo of Floob
    Floob
    Moderator

    Ok, here are my (very quick tests):

    mame4all
    Mortal Kombat – Works
    Mortal Kombat 2 – Segmentation fault
    Mortal Kombat 3 – Segmentation fault
    ESP.Ra.De – Works – Flip screen by choosing “Invert” under config menu, then save with holding down “F2”

    mame4all-libretro
    Mortal Kombat – Works (Need to increase volume in RGUI settings)
    Mortal Kombat 2 – Works (Need to increase volume in RGUI settings)
    Mortal Kombat 3 – Works (Need to increase volume in RGUI settings)
    ESP.Ra.De – Stuck at service menu

    advancemame 1.2
    Mortal Kombats – all a bit slow except maybe the first one.
    ESP.Ra.De – Works – looks better than mame4all – doesnt start at service menu

    I’ll try to find the service menu option on lr-mame4all

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #96945
    Profile photo of shaedo
    shaedo
    Participant

    Thanks for taking a look, Floob. I’ll keep looking as well.

    #104120
    Profile photo of beyondsanity
    beyondsanity
    Participant

    Hello,

    i’m having the same problems, did someone find out how to access the dip-switch menu on lr-mame4all?

    I also have problem with the screen resolution of MK games, they seem stretched when using lr-mame4all.

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar